aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 19:13:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-23 20:02:29 +0000
commit4c4d74fc6cf404cf1c731e3dfe9265712f74969b (patch)
tree6b26f480a4a07ac3eec97537fd5d40e8829caf03 /chinese
parent6d73075a1f68049176318f7f48d21f59bcb2c374 (diff)
downloadports-4c4d74fc6cf404cf1c731e3dfe9265712f74969b.tar.gz
ports-4c4d74fc6cf404cf1c731e3dfe9265712f74969b.zip
chinese/scim-pinyin: Fix build with llvm16
- Pet portclippy - Utilize USES=localbase Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'chinese')
-rw-r--r--chinese/scim-pinyin/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/chinese/scim-pinyin/Makefile b/chinese/scim-pinyin/Makefile
index 166952b00d1f..576ea9b13da8 100644
--- a/chinese/scim-pinyin/Makefile
+++ b/chinese/scim-pinyin/Makefile
@@ -8,22 +8,26 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= SCIM Chinese Smart Pinyin input method
WWW= https://github.com/scim-im/scim
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
BUILD_DEPENDS= scim>=1.2.0:textproc/scim
RUN_DEPENDS:= ${BUILD_DEPENDS}
-LICENSE= GPLv2
-LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake iconv libtool:keepla localbase:ldflags pathfix pkgconfig
+USE_CXXSTD= c++14
-USES= gmake iconv libtool:keepla pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-skim-support
+
INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include -D__STDC_ISO_10646__
-LDFLAGS+= -L${LOCALBASE}/lib -lintl
+CPPFLAGS+= -D__STDC_ISO_10646__
+LDFLAGS+= -lintl
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
+
NLS_USES= gettext
NLS_CONFIGURE_ENABLE= nls