aboutsummaryrefslogtreecommitdiff
path: root/chinese
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
committerFelix Palmen <zirias@FreeBSD.org>2022-09-11 10:20:14 +0000
commitddae4e92d8313a1461145e3b4f0232fe463feaee (patch)
treee84ab3fcfdf00dbf560f8ef9ae031d0c2ed252f5 /chinese
parent51a360b7fe98be99d21134e5fe624ba12d596dd9 (diff)
downloadports-ddae4e92d8313a1461145e3b4f0232fe463feaee.tar.gz
ports-ddae4e92d8313a1461145e3b4f0232fe463feaee.zip
Mk/Uses: always use colon for build/run suffix
Most USES use a colon for build/run(/test) suffixes. Change kde.mk, qt.mk and pyqt.mk to do the same, and update all ports using that. Document in CHANGES. PR: 266034 Exp-run by: antoine Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D36349
Diffstat (limited to 'chinese')
-rw-r--r--chinese/fcitx-libpinyin/Makefile2
-rw-r--r--chinese/fcitx5-chinese-addons/Makefile2
-rw-r--r--chinese/gcin-qt5/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/chinese/fcitx-libpinyin/Makefile b/chinese/fcitx-libpinyin/Makefile
index 47ba82dab65e..a4e0570830b6 100644
--- a/chinese/fcitx-libpinyin/Makefile
+++ b/chinese/fcitx-libpinyin/Makefile
@@ -33,7 +33,7 @@ QT5_DESC= Enable Qtr for dictmanager
.if ${PORT_OPTIONS:MQT5}
USES+= qt:5
-USE_QT= qmake_build gui webengine buildtools_build
+USE_QT= qmake:build gui webengine buildtools:build
USE_LDCONFIG= ${PREFIX}/lib/fcitx/qt
PLIST_SUB+= QT5=""
.else
diff --git a/chinese/fcitx5-chinese-addons/Makefile b/chinese/fcitx5-chinese-addons/Makefile
index 82fb09bce79c..a47792788e23 100644
--- a/chinese/fcitx5-chinese-addons/Makefile
+++ b/chinese/fcitx5-chinese-addons/Makefile
@@ -32,7 +32,7 @@ USE_LDCONFIG= yes
GUI_DESC= Configuration GUI
GUI_USES= qt:5
-GUI_USE= qt=dbus,concurrent,webkit,buildtools_build,qmake_build
+GUI_USE= qt=dbus,concurrent,webkit,buildtools:build,qmake:build
GUI_LIB_DEPENDS= libFcitx5Qt5DBusAddons.so:textproc/fcitx5-qt
GUI_CMAKE_ON= -DUSE_WEBKIT:BOOL=true
diff --git a/chinese/gcin-qt5/Makefile b/chinese/gcin-qt5/Makefile
index ee49850d008b..281f8ebe5b03 100644
--- a/chinese/gcin-qt5/Makefile
+++ b/chinese/gcin-qt5/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libgcin-im-client.so:chinese/gcin
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/qt5-im
USES= compiler:c++11-lang gmake pkgconfig qt:5 tar:xz
-USE_QT= qdbus qmake_build buildtools_build core gui
+USE_QT= qdbus qmake:build buildtools:build core gui
USE_CXXSTD= c++11
MAKE_ENV= INSTALL_PROGRAM="${INSTALL_PROGRAM}" \
MKDIR="${MKDIR}"