aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 14:35:15 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-20 17:42:36 +0000
commit31ead562ed657bd5e4c1ee8d7ac907d628119725 (patch)
treea4a90835f3fdbfd2aa756e5c1949101680035175 /comms
parent05706f90a8f196ba6a92886c6f2bd5e2a3192dc9 (diff)
downloadports-31ead562ed657bd5e4c1ee8d7ac907d628119725.tar.gz
ports-31ead562ed657bd5e4c1ee8d7ac907d628119725.zip
comms/uird: Fix build with llvm16
- Pet portclippy Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'comms')
-rw-r--r--comms/uird/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
index 654b339dff90..b24194d0ead3 100644
--- a/comms/uird/Makefile
+++ b/comms/uird/Makefile
@@ -10,20 +10,29 @@ WWW= http://kbinstuff.googlepages.com/uirduniversalirreceiverdaemon
USES= perl5 gmake tar:tgz
-WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= ${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
PLIST_FILES= bin/uird
PORTDOCS= Documentation
OPTIONS_DEFINE= DOCS
+.include <bsd.port.options.mk>
+
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/uird ${STAGEDIR}${PREFIX}/bin
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}