aboutsummaryrefslogtreecommitdiff
path: root/comms
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-08-19 09:00:54 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-08-19 09:44:00 +0000
commita716d1907d41966896374b51815956ac4a8aa3c2 (patch)
tree1a6555db076a929e8914d2957bd28e35abe9db7f /comms
parent79b2c0fdd330702b81ab1c88c63e26fde36abcc3 (diff)
downloadports-a716d1907d41966896374b51815956ac4a8aa3c2.tar.gz
ports-a716d1907d41966896374b51815956ac4a8aa3c2.zip
comms/freedv: Fix build and plist issues
* Add pkgconfig to USES * Remove codec2 path arguments from CMAKE_ARGS * Fix plist issue Approved by: portmgr (blanket, build fix)
Diffstat (limited to 'comms')
-rw-r--r--comms/freedv/Makefile10
-rw-r--r--comms/freedv/pkg-plist10
2 files changed, 14 insertions, 6 deletions
diff --git a/comms/freedv/Makefile b/comms/freedv/Makefile
index a47ed50e1c17..54d5fc16f4ef 100644
--- a/comms/freedv/Makefile
+++ b/comms/freedv/Makefile
@@ -21,15 +21,13 @@ LIB_DEPENDS= libcodec2.so:audio/codec2 \
libspeexdsp.so:audio/speexdsp \
liblpcnetfreedv.so:audio/lpcnet
-USES= cmake compiler:c++11-lib tar:xz
+USES= cmake compiler:c++11-lib pkgconfig tar:xz
USE_WX= 3.0+
-USE_GITHUB= yes
+USE_GITHUB= yes
GH_ACCOUNT= drowe67
-GH_PROJECT= freedv-gui
+GH_PROJECT= freedv-gui
-CMAKE_ARGS+= -DCODEC2_INCLUDE_DIRS=${LOCALBASE}/include/codec2 \
- -DCODEC2_LIBRARY=${LOCALBASE}/lib/libcodec2.so \
- -DUSE_STATIC_CODEC2=FALSE \
+CMAKE_ARGS= -DUSE_STATIC_CODEC2=FALSE \
-DUSE_STATIC_PORTAUDIO=FALSE \
-DUSE_STATIC_SOX=FALSE \
-DUSE_STATIC_SPEEXDSP=FALSE
diff --git a/comms/freedv/pkg-plist b/comms/freedv/pkg-plist
index f82fe84ace20..e756cec72b41 100644
--- a/comms/freedv/pkg-plist
+++ b/comms/freedv/pkg-plist
@@ -1,5 +1,15 @@
bin/freedv
share/applications/freedv.desktop
+%%DATADIR%%-gui/USER_MANUAL.html
+%%DATADIR%%-gui/USER_MANUAL.md
+%%DATADIR%%-gui/USER_MANUAL.pdf
+%%DATADIR%%-gui/wav/all_2020.wav
+%%DATADIR%%-gui/wav/ve9qrp_1600.wav
+%%DATADIR%%-gui/wav/ve9qrp_2400b.wav
+%%DATADIR%%-gui/wav/ve9qrp_700c.wav
+%%DATADIR%%-gui/wav/ve9qrp_700d.wav
+%%DATADIR%%-gui/wav/ve9qrp_700e.wav
+%%DATADIR%%-gui/wav/ve9qrp_800xa.wav
share/icons/hicolor/128x128/apps/freedv.png
share/icons/hicolor/256x256/apps/freedv.png
share/icons/hicolor/48x48/apps/freedv.png