aboutsummaryrefslogtreecommitdiff
path: root/deskutils
diff options
context:
space:
mode:
authorJason W. Bacon <jwb@FreeBSD.org>2023-07-31 15:22:39 +0000
committerJason W. Bacon <jwb@FreeBSD.org>2023-07-31 15:24:35 +0000
commitabf65f917805960ad0e90c12334d01b8929db2f0 (patch)
tree713e50f42c911f223b0c31b7e7b8bc881041bda1 /deskutils
parent81713c91293a5cbc0c74c6a29a31096b4cb86dd8 (diff)
downloadports-abf65f917805960ad0e90c12334d01b8929db2f0.tar.gz
ports-abf65f917805960ad0e90c12334d01b8929db2f0.zip
deskutils/freebsd-update-notify: Desktop notification for av. updates
Freebsd-update-notify is a script invoked by cron to check for available updates and issue popup notification on the desktop. The user can elect to install and reboot or ignore them for now.
Diffstat (limited to 'deskutils')
-rw-r--r--deskutils/Makefile1
-rw-r--r--deskutils/freebsd-update-notify/Makefile39
-rw-r--r--deskutils/freebsd-update-notify/distinfo3
-rw-r--r--deskutils/freebsd-update-notify/pkg-descr3
4 files changed, 46 insertions, 0 deletions
diff --git a/deskutils/Makefile b/deskutils/Makefile
index b3a9a88edd59..8910812b7f14 100644
--- a/deskutils/Makefile
+++ b/deskutils/Makefile
@@ -57,6 +57,7 @@
SUBDIR += fff
SUBDIR += flameshot
SUBDIR += foliate
+ SUBDIR += freebsd-update-notify
SUBDIR += freemind
SUBDIR += freeplane
SUBDIR += ganttproject
diff --git a/deskutils/freebsd-update-notify/Makefile b/deskutils/freebsd-update-notify/Makefile
new file mode 100644
index 000000000000..6fb0aa63b00b
--- /dev/null
+++ b/deskutils/freebsd-update-notify/Makefile
@@ -0,0 +1,39 @@
+PORTNAME= freebsd-update-notify
+DISTVERSION= 0.1.0-2
+DISTVERSIONSUFFIX= -g9a58564
+CATEGORIES= deskutils
+
+MAINTAINER= jwb@FreeBSD.org
+COMMENT= Notify desktop user when FreeBSD updates are available
+WWW= https://github.com/outpaddling/freebsd-update-notify
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= zenity:x11/zenity auto-admin:sysutils/auto-admin
+
+USE_GITHUB= yes
+
+GH_ACCOUNT= outpaddling
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= libexec/freebsd-update-notify \
+ libexec/freebsd-update-cron \
+ man/man8/freebsd-update-notify.8.gz \
+ "@sample etc/freebsd-update-notify.crontab.sample etc/cron.d/freebsd-update-notify" \
+ "@dir etc/cron.d"
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/cron.d
+ ${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update-notify \
+ ${STAGEDIR}${PREFIX}/libexec
+ ${INSTALL_SCRIPT} ${WRKSRC}/freebsd-update-cron \
+ ${STAGEDIR}${PREFIX}/libexec
+ ${INSTALL_DATA} ${WRKSRC}/freebsd-update-notify.crontab \
+ ${STAGEDIR}${PREFIX}/etc/freebsd-update-notify.crontab.sample
+ ${INSTALL_MAN} ${WRKSRC}/freebsd-update-notify.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8
+
+.include <bsd.port.mk>
diff --git a/deskutils/freebsd-update-notify/distinfo b/deskutils/freebsd-update-notify/distinfo
new file mode 100644
index 000000000000..87163f0851c6
--- /dev/null
+++ b/deskutils/freebsd-update-notify/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1690816706
+SHA256 (outpaddling-freebsd-update-notify-0.1.0-2-g9a58564_GH0.tar.gz) = 9656b88cce0f6fe68fde943b573519e26bb499f3e11c60169fb7c40caa6b0b24
+SIZE (outpaddling-freebsd-update-notify-0.1.0-2-g9a58564_GH0.tar.gz) = 3426
diff --git a/deskutils/freebsd-update-notify/pkg-descr b/deskutils/freebsd-update-notify/pkg-descr
new file mode 100644
index 000000000000..e5c30c087cf7
--- /dev/null
+++ b/deskutils/freebsd-update-notify/pkg-descr
@@ -0,0 +1,3 @@
+Freebsd-update-notify is a script invoked by cron to check for
+available updates and issue popup notification on the desktop. The
+user can elect to install and reboot or ignore them for now.