aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
authorErik Jensen <erik@tenku.dk>2023-10-25 06:55:45 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-10-27 06:35:10 +0000
commit83b30edf372baecff6adf7ce5aa8f247a11f44e0 (patch)
tree3bf265a2a3513e895efb008d7cbeed6a3f4da53b /devel
parent906ef9acf9b9578cfab90e69b5da610a06ea305d (diff)
downloadports-83b30edf372baecff6adf7ce5aa8f247a11f44e0.tar.gz
ports-83b30edf372baecff6adf7ce5aa8f247a11f44e0.zip
devel/root: Fix build/run depends in Makefile
Turn bash and nlohmann-json into run-time dependencies, as well as build-time dependencies. PR: 274696 MFH: 2023Q4 (cherry picked from commit a19d67508e63f959c27d1b13a27aca88f136e10e)
Diffstat (limited to 'devel')
-rw-r--r--devel/root/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/devel/root/Makefile b/devel/root/Makefile
index 14f01c1b1da4..4ea696cb7d3d 100644
--- a/devel/root/Makefile
+++ b/devel/root/Makefile
@@ -11,8 +11,9 @@ WWW= https://root.cern/
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/LGPL2_1.txt
-BUILD_DEPENDS= bash:shells/bash \
- nlohmann-json>=3:devel/nlohmann-json
+BUILD_AND_RUN_DEPENDS= bash:shells/bash \
+ nlohmann-json>=3:devel/nlohmann-json
+BUILD_DEPENDS= ${BUILD_AND_RUN_DEPENDS}
LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libcurl.so:ftp/curl \
libfftw3.so:math/fftw3 \
@@ -29,6 +30,7 @@ LIB_DEPENDS= libcfitsio.so:astro/cfitsio \
libXrdCl.so:databases/xrootd \
libxxhash.so:devel/xxhash \
libzstd.so:archivers/zstd
+RUN_DEPENDS= ${BUILD_AND_RUN_DEPENDS}
USES= cmake compiler:c++17-lang desktop-file-utils \
gettext-runtime gnome iconv jpeg shebangfix ssl