aboutsummaryrefslogtreecommitdiff
path: root/dns
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2023-02-24 10:09:28 +0000
committerMartin Matuska <mm@FreeBSD.org>2023-02-24 10:22:36 +0000
commit956aa4e270bf746d69ee77c8497dae2d28376cb4 (patch)
tree75ab6411df0f56d9a67b0f701d1d8d518f57c529 /dns
parent5c35cbe93da05bd8243721adcfc1d9015be7eab6 (diff)
downloadports-956aa4e270bf746d69ee77c8497dae2d28376cb4.tar.gz
ports-956aa4e270bf746d69ee77c8497dae2d28376cb4.zip
dns/udns: unbreak build on 14-CURRENT
Fix detection of inet_pton() and inet_ntop()
Diffstat (limited to 'dns')
-rw-r--r--dns/udns/Makefile2
-rw-r--r--dns/udns/files/patch-configure27
2 files changed, 28 insertions, 1 deletions
diff --git a/dns/udns/Makefile b/dns/udns/Makefile
index c391036d15bd..ec3bcd299dcc 100644
--- a/dns/udns/Makefile
+++ b/dns/udns/Makefile
@@ -1,6 +1,6 @@
PORTNAME= udns
PORTVERSION= 0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= http://www.corpit.ru/mjt/udns/
diff --git a/dns/udns/files/patch-configure b/dns/udns/files/patch-configure
new file mode 100644
index 000000000000..ca6971268eae
--- /dev/null
+++ b/dns/udns/files/patch-configure
@@ -0,0 +1,27 @@
+--- configure.orig 2023-02-24 09:54:25 UTC
++++ configure
+@@ -83,17 +83,20 @@ else
+ fi
+
+ ac_ign \
+- ac_yesno "for inet_pton() && inet_ntop()" \
++ ac_yesno "for working inet_pton() && inet_ntop()" \
+ ac_have INET_PTON_NTOP \
+ ac_link <<EOF
+ #include <sys/types.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#include <string.h>
+ int main() {
++ char addr[sizeof(struct in_addr)];
+ char buf[64];
+- long x = 0;
+- inet_pton(AF_INET, &x, buf);
+- return inet_ntop(AF_INET, &x, buf, sizeof(buf));
++ char *localhost = "127.0.0.1";
++ inet_pton(AF_INET, localhost, addr);
++ inet_ntop(AF_INET, addr, buf, sizeof(buf));
++ return strncmp(localhost, buf, sizeof(localhost));
+ }
+ EOF
+