aboutsummaryrefslogtreecommitdiff
path: root/french
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 05:31:29 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2021-09-19 06:00:49 +0000
commit72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63 (patch)
tree5a38291fea0ecf3734c8329b934dc334c8a9feb8 /french
parent915dbfaa562e20c8402d3873f8bfbf07899f9f8a (diff)
downloadports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.tar.gz
ports-72664fc2b4d33ca3ae39c8e7ab6f8fa85c08bd63.zip
*/*mythes: Avoid using %% in Makefile
Use ${DATAIDR} instead of %%DATADIR%%
Diffstat (limited to 'french')
-rw-r--r--french/mythes/Makefile8
-rw-r--r--french/mythes/Makefile 37
2 files changed, 41 insertions, 4 deletions
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
index 7d32204305d5..db1a8b5a53d6 100644
--- a/french/mythes/Makefile
+++ b/french/mythes/Makefile
@@ -16,13 +16,13 @@ NO_ARCH= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
-PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
- %%DATADIR%%/th_fr_FR_v2.idx
+PLIST_FILES= ${DATADIR}/th_fr_FR_v2.dat \
+ ${DATADIR}/th_fr_FR_v2.idx
FRALIASES= fr_BE fr_CA fr_CH fr_LU
.for ALIAS in ${FRALIASES}
-PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
- %%DATADIR%%/th_${ALIAS}_v2.idx
+PLIST_FILES+= ${DATADIR}/th_${ALIAS}_v2.dat \
+ ${DATADIR}/th_${ALIAS}_v2.idx
.endfor
do-install:
diff --git a/french/mythes/Makefile b/french/mythes/Makefile
new file mode 100644
index 000000000000..7d32204305d5
--- /dev/null
+++ b/french/mythes/Makefile
@@ -0,0 +1,37 @@
+PORTNAME= mythes
+PORTVERSION= 2.3
+CATEGORIES= french textproc
+MASTER_SITES= http://www.dicollecte.org/download/fr/ \
+ LOCAL/sunpoet/${PORTNAME}
+DISTNAME= thesaurus-v${PORTVERSION}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= office@FreeBSD.org
+COMMENT= French thesaurus
+
+LICENSE= LGPL21
+
+USES= zip
+NO_ARCH= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= %%DATADIR%%/th_fr_FR_v2.dat \
+ %%DATADIR%%/th_fr_FR_v2.idx
+
+FRALIASES= fr_BE fr_CA fr_CH fr_LU
+.for ALIAS in ${FRALIASES}
+PLIST_FILES+= %%DATADIR%%/th_${ALIAS}_v2.dat \
+ %%DATADIR%%/th_${ALIAS}_v2.idx
+.endfor
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.dat ${STAGEDIR}${DATADIR}/th_fr_FR_v2.dat
+ ${INSTALL_DATA} ${WRKSRC}/thes_fr.idx ${STAGEDIR}${DATADIR}/th_fr_FR_v2.idx
+.for ALIAS in ${FRALIASES}
+ ${LN} -s th_fr_FR_v2.dat ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.dat
+ ${LN} -s th_fr_FR_v2.idx ${STAGEDIR}${DATADIR}/th_${ALIAS}_v2.idx
+.endfor
+
+.include <bsd.port.mk>