aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 15:15:52 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 15:41:47 +0000
commitfb2d3dd4f87588de5dd1c4db133fd44a2f1bdb6d (patch)
treeabc62de62c9dd2062c9cca55422f58d2ba743c44 /games
parent5d891e9897b54acf3deb2709b3478392ce75fa83 (diff)
downloadports-fb2d3dd4f87588de5dd1c4db133fd44a2f1bdb6d.tar.gz
ports-fb2d3dd4f87588de5dd1c4db133fd44a2f1bdb6d.zip
games/falconseye: Fix build with llvm16
Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'games')
-rw-r--r--games/falconseye/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/games/falconseye/Makefile b/games/falconseye/Makefile
index f23a463f85ce..f00121a090e3 100644
--- a/games/falconseye/Makefile
+++ b/games/falconseye/Makefile
@@ -36,6 +36,10 @@ NETHACKCONFIG= ${FILESDIR}/x-config
CFLAGS+= -Wno-error=int-conversion
.endif
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400091
+CFLAGS+= -Wno-error=incompatible-function-pointer-types
+.endif
+
post-patch:
@${REINPLACE_CMD} -i '' -e "s|<malloc.h>|<stdlib.h>|" \
${WRKSRC}/include/jtp_gen.h ${WRKSRC}/win/jtp/jtp_dirx.c \