aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-28 16:48:01 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-29 18:24:39 +0000
commitee6c86aea577dec2643f6a9915033feda7f67e26 (patch)
tree36f2f4b966bacb640b14648c3bf90ee926a6c177 /games
parent3d426c920c8a95998ff4fa5b80012055788905cf (diff)
downloadports-ee6c86aea577dec2643f6a9915033feda7f67e26.tar.gz
ports-ee6c86aea577dec2643f6a9915033feda7f67e26.zip
*/*: Refactor with IGNORE_WITH_MYSQL
- There are multiple ports which has MYSQL options and are non-DEFAULT. Most of the time committers actually forget to check with the OPTION enabled and in some cases they are BROKEN with newr versions of mysql. So test with different versions of mysql and mark IGNOPRE_WITH_MYSQL appropriately. Due to the EOL of 5.7 this has not been checked. - Unbreak sysutils/cfengine* with MySQL 8.0 and later - The primary purpose of running this check is having statistics of the MySQL usability over MariaDB to explore the future possibility of shifting to MariaDB as the default as major ports upstream have moved their codebase to support MariaDB over MySQL. - The following actions will also be taken after the sunset of MySQL 5.7 If a port is broken on all instances of MySQL/MariaDB: - If a port has the option of multiple DB backends and MySQL is the default then the DEFAULT will be changed to PGSQL/SQLITE before 2024Q1. And the OPTION will be removed before 2024Q2. If a MAINTAINER is aware about such cases and want to prefer PGSQL over SQLITE or vice versa please do so at your own accord. Otherwise PGSQL will be preferred over SQLITE. - If a port has the option of multiple DB backends and MySQL is not the default then the the OPTION will be removed before 2024Q1. Approved by: portmgr (blanket)
Diffstat (limited to 'games')
-rw-r--r--games/ldmud/Makefile2
-rw-r--r--games/pvpgn/Makefile1
2 files changed, 2 insertions, 1 deletions
diff --git a/games/ldmud/Makefile b/games/ldmud/Makefile
index c7260a2fee67..d6615796d964 100644
--- a/games/ldmud/Makefile
+++ b/games/ldmud/Makefile
@@ -45,7 +45,7 @@ IPV6_CONFIGURE_ENABLE= use-ipv6
MYSQL_USES= mysql
MYSQL_CONFIGURE_ENABLE= use-mysql
MYSQL_LDFLAGS= -L${LOCALBASE}/lib/mysql
-MYSQL_VARS= IGNORE_WITH_MYSQL=80
+MYSQL_VARS= IGNORE_WITH_MYSQL="105m 106m 1011m 80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_ENABLE= use-pgsql
SQLITE_USES= sqlite
diff --git a/games/pvpgn/Makefile b/games/pvpgn/Makefile
index c3edb2131fbd..4c81e8487ee9 100644
--- a/games/pvpgn/Makefile
+++ b/games/pvpgn/Makefile
@@ -44,6 +44,7 @@ D2_CONFIGURE_ENABLE= d2cs d2dbs
MYSQL_USES= mysql
MYSQL_CONFIGURE_WITH= mysql
+MYSQL_VARS= IGNORE_WITH_MYSQL="80 81"
PGSQL_USES= pgsql
PGSQL_CONFIGURE_WITH= pgsql