aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorRobert Clausecker <fuz@FreeBSD.org>2023-07-28 20:28:07 +0000
committerRobert Clausecker <fuz@FreeBSD.org>2023-07-30 22:59:09 +0000
commit1b46f3bddda1f8e0ba018aa94f7e206408c30331 (patch)
tree50b1469f9087420eed984ea179a3fd2b2fbe36d7 /graphics
parenta5783589a611edd6c2e15a71bdd740a0206058e6 (diff)
downloadports-1b46f3bddda1f8e0ba018aa94f7e206408c30331.tar.gz
ports-1b46f3bddda1f8e0ba018aa94f7e206408c30331.zip
graphics/tippecanoe: fix build on armv7
Same fix as for i386. Approved by: portmgr (build fix blanket) Fixes: 1d61daa912396e4f5d31d130fe9600540ba6644b
Diffstat (limited to 'graphics')
-rw-r--r--graphics/tippecanoe/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/tippecanoe/Makefile b/graphics/tippecanoe/Makefile
index cd354b628058..8b2d68bb385b 100644
--- a/graphics/tippecanoe/Makefile
+++ b/graphics/tippecanoe/Makefile
@@ -25,7 +25,7 @@ PLIST_FILES= bin/tile-join bin/tippecanoe bin/tippecanoe-decode \
# Suppress a clang-16 error on 32-bit arch:
# non-constant-expression cannot be narrowed from type 'uint64_t'
-.if ${ARCH} == i386
+.if ${ARCH} == i386 || ${ARCH:Marmv?} != ""
CXXFLAGS+= -Wno-narrowing
.endif