aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2023-07-27 20:29:03 +0000
committerJason E. Hale <jhale@FreeBSD.org>2023-07-27 22:11:04 +0000
commitd9398dbdb15152ff52b2f5345302b3f4d2fdc381 (patch)
tree05f506b3e9e6741494771aefb21a0a848ff409a9 /graphics
parentcc47a3fe11776018b63475d59b2b089ad8e938ce (diff)
downloadports-d9398dbdb15152ff52b2f5345302b3f4d2fdc381.tar.gz
ports-d9398dbdb15152ff52b2f5345302b3f4d2fdc381.zip
graphics/py-qt6-3d: New port
PyQt6-3D is a set of Python bindings for The Qt Company's Qt 3D framework. The bindings sit on top of PyQt6 and are implemented as six separate modules corresponding to the different libraries that make up the framework. https://www.riverbankcomputing.com/software/pyqt3d/
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/py-qt6-3d/Makefile29
-rw-r--r--graphics/py-qt6-3d/distinfo3
-rw-r--r--graphics/py-qt6-3d/pkg-descr5
-rw-r--r--graphics/py-qt6-3d/pkg-plist238
5 files changed, 276 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cb75a7ffc7fd..da260113942c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -949,6 +949,7 @@
SUBDIR += py-pyx
SUBDIR += py-qpageview
SUBDIR += py-qrencode
+ SUBDIR += py-qt6-3d
SUBDIR += py-railroad-diagrams
SUBDIR += py-rasterio
SUBDIR += py-rasterstats
diff --git a/graphics/py-qt6-3d/Makefile b/graphics/py-qt6-3d/Makefile
new file mode 100644
index 000000000000..2f07d6714e78
--- /dev/null
+++ b/graphics/py-qt6-3d/Makefile
@@ -0,0 +1,29 @@
+PORTNAME= 3d
+DISTVERSION= ${PYQT3D_VERSION}
+CATEGORIES= graphics python
+MASTER_SITES= ${MASTER_SITES_PYQT3D}
+PKGNAMEPREFIX= ${PYQT_PY_RELNAME}-
+DISTNAME= ${PYQT3D_DISTNAME}
+
+PYQT_DIST= yes
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt6 3D framework
+WWW= https://www.riverbankcomputing.com/software/pyqt3d/
+
+USES= gl pyqt:6 python qt:6
+USE_GL= gl
+USE_LOCALE= C.UTF-8
+USE_PYQT= sip:build pyqt6 qtbuilder:build
+USE_PYTHON= concurrent flavors
+USE_QT= 3d base
+
+PLIST_SUB= PYQT3D_VERSION=${DISTVERSION} \
+ PYTHON_MAJOR_VER=${PYTHON_MAJOR_VER} \
+ PYTHON_MAJOR_VER_regex=[[:<:]]${PYTHON_MAJOR_VER}[[:>:]]
+
+post-install:
+ @${FIND} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/PyQt6 \
+ -name '*.so*' -exec ${STRIP_CMD} {} +
+
+.include <bsd.port.mk>
diff --git a/graphics/py-qt6-3d/distinfo b/graphics/py-qt6-3d/distinfo
new file mode 100644
index 000000000000..925233511024
--- /dev/null
+++ b/graphics/py-qt6-3d/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1690463072
+SHA256 (PyQt6_3D-6.5.0.tar.gz) = f8ef3e2965a518367eb4cc693fd9f23698fcbeb909c7dcb7269737b8d877f68b
+SIZE (PyQt6_3D-6.5.0.tar.gz) = 7469119
diff --git a/graphics/py-qt6-3d/pkg-descr b/graphics/py-qt6-3d/pkg-descr
new file mode 100644
index 000000000000..ff0abcc52b95
--- /dev/null
+++ b/graphics/py-qt6-3d/pkg-descr
@@ -0,0 +1,5 @@
+PyQt6-3D is a set of Python bindings for The Qt Company's Qt 3D
+framework. The bindings sit on top of PyQt6 and are implemented as six
+separate modules corresponding to the different libraries that make up
+the framework.
+
diff --git a/graphics/py-qt6-3d/pkg-plist b/graphics/py-qt6-3d/pkg-plist
new file mode 100644
index 000000000000..909de07daf58
--- /dev/null
+++ b/graphics/py-qt6-3d/pkg-plist
@@ -0,0 +1,238 @@
+%%PYQT_APIDIR%%/PyQt6-3D.api
+%%PYQT_SIPDIR%%/Qt3DAnimation/Qt3DAnimation.toml
+%%PYQT_SIPDIR%%/Qt3DAnimation/Qt3DAnimationmod.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qabstractanimation.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qabstractanimationclip.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qabstractchannelmapping.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qabstractclipanimator.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qabstractclipblendnode.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qadditiveclipblend.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationaspect.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationclip.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationclipdata.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationcliploader.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationcontroller.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qanimationgroup.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qblendedclipanimator.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qchannel.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qchannelcomponent.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qchannelmapper.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qchannelmapping.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qclipanimator.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qclipblendvalue.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qclock.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qkeyframe.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qkeyframeanimation.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qlerpclipblend.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qmorphinganimation.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qmorphtarget.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qskeletonmapping.sip
+%%PYQT_SIPDIR%%/Qt3DAnimation/qvertexblendanimation.sip
+%%PYQT_SIPDIR%%/Qt3DCore/Qt3DCore.toml
+%%PYQT_SIPDIR%%/Qt3DCore/Qt3DCoremod.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qabstractaspect.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qabstractfunctor.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qabstractskeleton.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qarmature.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qaspectengine.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qattribute.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qbackendnode.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qboundingvolume.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qbuffer.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qcomponent.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qcoresettings.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qentity.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qgeometry.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qgeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qjoint.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qnode.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qnodeid.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qsharedpointer.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qskeleton.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qskeletonloader.sip
+%%PYQT_SIPDIR%%/Qt3DCore/qtransform.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/Qt3DExtras.toml
+%%PYQT_SIPDIR%%/Qt3DExtras/Qt3DExtrasmod.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qabstractcameracontroller.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qabstractspritesheet.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qconegeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qconegeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qconemesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcuboidgeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcuboidgeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcuboidmesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcylindergeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcylindergeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qcylindermesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qdiffusemapmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qdiffusespecularmapmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qdiffusespecularmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qextrudedtextgeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qextrudedtextmesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qfirstpersoncameracontroller.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qforwardrenderer.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qgoochmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qmetalroughmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qmorphphongmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qnormaldiffusemapalphamaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qnormaldiffusemapmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qnormaldiffusespecularmapmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qorbitcameracontroller.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qpervertexcolormaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qphongalphamaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qphongmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qplanegeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qplanegeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qplanemesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qskyboxentity.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspheregeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspheregeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspheremesh.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspritegrid.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspritesheet.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qspritesheetitem.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qt3dwindow.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qtext2dentity.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qtexturematerial.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qtorusgeometry.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qtorusgeometryview.sip
+%%PYQT_SIPDIR%%/Qt3DExtras/qtorusmesh.sip
+%%PYQT_SIPDIR%%/Qt3DInput/Qt3DInput.toml
+%%PYQT_SIPDIR%%/Qt3DInput/Qt3DInputmod.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qabstractactioninput.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qabstractaxisinput.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qabstractphysicaldevice.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qaction.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qactioninput.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qanalogaxisinput.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qaxis.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qaxisaccumulator.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qaxissetting.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qbuttonaxisinput.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qinputaspect.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qinputchord.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qinputsequence.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qinputsettings.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qkeyboarddevice.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qkeyboardhandler.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qkeyevent.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qlogicaldevice.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qmousedevice.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qmouseevent.sip
+%%PYQT_SIPDIR%%/Qt3DInput/qmousehandler.sip
+%%PYQT_SIPDIR%%/Qt3DLogic/Qt3DLogic.toml
+%%PYQT_SIPDIR%%/Qt3DLogic/Qt3DLogicmod.sip
+%%PYQT_SIPDIR%%/Qt3DLogic/qframeaction.sip
+%%PYQT_SIPDIR%%/Qt3DLogic/qlogicaspect.sip
+%%PYQT_SIPDIR%%/Qt3DRender/Qt3DRender.toml
+%%PYQT_SIPDIR%%/Qt3DRender/Qt3DRendermod.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qabstractlight.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qabstractraycaster.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qabstracttexture.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qabstracttextureimage.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qalphacoverage.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qalphatest.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qblendequation.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qblendequationarguments.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qblitframebuffer.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcamera.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcameralens.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcameraselector.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qclearbuffers.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qclipplane.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcolormask.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcomputecommand.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qcullface.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qdepthrange.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qdepthtest.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qdirectionallight.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qdispatchcompute.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qdithering.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qeffect.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qenvironmentlight.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qfilterkey.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qframegraphnode.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qfrontface.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qfrustumculling.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qgeometryrenderer.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qgraphicsapifilter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlayer.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlayerfilter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlevelofdetail.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlevelofdetailboundingsphere.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlevelofdetailswitch.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlinewidth.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qlist.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qmaterial.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qmemorybarrier.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qmesh.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qmultisampleantialiasing.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qnodepthmask.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qnodraw.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qnopicking.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qobjectpicker.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpaintedtextureimage.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qparameter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpickevent.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpickingproxy.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpickingsettings.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpicklineevent.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpickpointevent.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpicktriangleevent.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpointlight.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpointsize.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qpolygonoffset.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qproximityfilter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrastermode.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qraycaster.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qraycasterhit.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderapi.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderaspect.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendercapabilities.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendercapture.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderpass.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderpassfilter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendersettings.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderstate.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrenderstateset.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendersurfaceselector.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendertarget.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendertargetoutput.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qrendertargetselector.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qsceneloader.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qscissortest.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qscreenraycaster.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qseamlesscubemap.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qsetfence.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qshaderdata.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qshaderimage.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qshaderprogram.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qshaderprogrambuilder.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qsortpolicy.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qspotlight.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qstencilmask.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qstenciloperation.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qstenciloperationarguments.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qstenciltest.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qstenciltestarguments.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qsubtreeenabler.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtechnique.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtechniquefilter.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtexture.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtexturedata.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtexturedataupdate.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtextureimage.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtextureimagedata.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtextureimagedatagenerator.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qtexturewrapmode.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qviewport.sip
+%%PYQT_SIPDIR%%/Qt3DRender/qwaitfence.sip
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DAnimation.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DCore.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DExtras.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DInput.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DLogic.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6/Qt3DRender.abi%%PYTHON_MAJOR_VER%%.so
+%%PYTHON_SITELIBDIR%%/PyQt6_3D-%%PYQT3D_VERSION%%.dist-info/INSTALLER
+%%PYTHON_SITELIBDIR%%/PyQt6_3D-%%PYQT3D_VERSION%%.dist-info/METADATA
+%%PYTHON_SITELIBDIR%%/PyQt6_3D-%%PYQT3D_VERSION%%.dist-info/RECORD