aboutsummaryrefslogtreecommitdiff
path: root/lang
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2023-06-14 22:00:28 +0000
committerRene Ladan <rene@FreeBSD.org>2023-06-27 19:34:34 +0000
commit3d9a815d9c5acbb71f4bb07738bdeab4879feacb (patch)
treeeb093f22197a2c68a88dd2372ec1922c3f6d3c10 /lang
parentc58ef91e06e8edc4fd8579837f1453b562da3fbb (diff)
downloadports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.tar.gz
ports-3d9a815d9c5acbb71f4bb07738bdeab4879feacb.zip
all: remove explicit versions in USES=python for "3.x+"
The logic in USES=python will automatically convert this to 3.8+ by itself. Adjust two ports that only had Python 3.7 mentioned but build fine on Python 3.8 too. finance/quickfix: mark BROKEN with PYTHON libtool: compile: c++ -DHAVE_CONFIG_H -I. -I../.. -I -I. -I.. -I../.. -I../C++ -DLIBICONV_PLUG -DPYTHON_MAJOR_VERSION=3 -Wno-unused-variable -Wno-maybe-uninitialized -O2 -pipe -DLIBICONV_PLUG -fstack-protector-strong -fno-strict-aliasing -DLIBICONV_PLUG -Wall -ansi -Wno-unused-command-line-argument -Wpointer-arith -Wwrite-strings -Wno-overloaded-virtual -Wno-deprecated-declarations -Wno-deprecated -std=c++0x -MT _quickfix_la-QuickfixPython.lo -MD -MP -MF .deps/_quickfix_la-QuickfixPython.Tpo -c QuickfixPython.cpp -fPIC -DPIC -o .libs/_quickfix_la-QuickfixPython.o warning: unknown warning option '-Wno-maybe-uninitialized'; did you mean '-Wno-uninitialized'? [-Wunknown-warning-option] QuickfixPython.cpp:175:11: fatal error: 'Python.h' file not found ^~~~~~~~~~ 1 warning and 1 error generated. Reviewed by: portmgr, vishwin, yuri Differential Revision: <https://reviews.freebsd.org/D40568>
Diffstat (limited to 'lang')
-rw-r--r--lang/io/Makefile.addons2
-rw-r--r--lang/mono/Makefile2
-rw-r--r--lang/mono5.10/Makefile2
-rw-r--r--lang/mono6.8/Makefile2
-rw-r--r--lang/pocl/Makefile2
-rw-r--r--lang/py-hy/Makefile2
-rw-r--r--lang/py-lupa/Makefile2
-rw-r--r--lang/py-textX/Makefile2
-rw-r--r--lang/python-tools/Makefile2
-rw-r--r--lang/python3/Makefile2
-rw-r--r--lang/rust-bootstrap/Makefile2
-rw-r--r--lang/rust/Makefile2
-rw-r--r--lang/v8-beta/Makefile2
-rw-r--r--lang/v8/Makefile2
14 files changed, 14 insertions, 14 deletions
diff --git a/lang/io/Makefile.addons b/lang/io/Makefile.addons
index 7555c4b0113b..927429cf8f24 100644
--- a/lang/io/Makefile.addons
+++ b/lang/io/Makefile.addons
@@ -99,7 +99,7 @@ OGG_LIB_DEPENDS= libogg.so:audio/libogg
OPENGL_USES= gl xorg
OPENGL_USE= GL=glut XORG=xmu
POSTGRESQL_USES= pgsql
-PYTHON_USES= python:3.3+
+PYTHON_USES= python
QDBM_LIB_DEPENDS= libqdbm.so:databases/qdbm
READLINE_USES= readline
REGEX_LIB_DEPENDS= libpcre.so:devel/pcre
diff --git a/lang/mono/Makefile b/lang/mono/Makefile
index 4bf1de8ceb26..ff0354bf1af7 100644
--- a/lang/mono/Makefile
+++ b/lang/mono/Makefile
@@ -38,7 +38,7 @@ NLS_USES= gettext
X11_USES= display:test
USES= autoreconf bison compiler:c11 cpe gmake iconv libtool \
- pathfix perl5 python:3.6+ shebangfix tar:bzip2
+ pathfix perl5 python shebangfix tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/lang/mono5.10/Makefile b/lang/mono5.10/Makefile
index d556835c5150..fca4638e78c5 100644
--- a/lang/mono5.10/Makefile
+++ b/lang/mono5.10/Makefile
@@ -39,7 +39,7 @@ NLS_USES= gettext
X11_USES= display:test
USES= autoreconf bison compiler:c11 cpe gmake iconv libtool \
- pathfix perl5 python:3.6+ shebangfix tar:bzip2
+ pathfix perl5 python shebangfix tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/lang/mono6.8/Makefile b/lang/mono6.8/Makefile
index 6bf4c98f11f1..bfff4bf6ef55 100644
--- a/lang/mono6.8/Makefile
+++ b/lang/mono6.8/Makefile
@@ -27,7 +27,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
CONFLICTS_INSTALL= certmgr coin-or-disco disco mono mono[0-9]*
USES= autoreconf bison compiler:c11 cpe gmake iconv libtool localbase \
- pathfix perl5 python:3.6+ shebangfix tar:xz
+ pathfix perl5 python shebangfix tar:xz
USE_PERL5= build
CONFIGURE_SCRIPT= autogen.sh
diff --git a/lang/pocl/Makefile b/lang/pocl/Makefile
index 682871ce64be..52b76134f7ce 100644
--- a/lang/pocl/Makefile
+++ b/lang/pocl/Makefile
@@ -40,7 +40,7 @@ OPTIONS_DEFINE= DOCS
DOCS_DESC= Build documentation (needs textproc/py-sphinx)
DOCS_CMAKE_ON= -DENABLE_DOCS=ON
DOCS_CMAKE_OFF= -DENABLE_DOCS=OFF
-DOCS_USES= python:3.6+
+DOCS_USES= python
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>=0:textproc/py-sphinx@${PY_FLAVOR}
.include <bsd.port.options.mk>
diff --git a/lang/py-hy/Makefile b/lang/py-hy/Makefile
index 0472976dee15..b8a7d134507a 100644
--- a/lang/py-hy/Makefile
+++ b/lang/py-hy/Makefile
@@ -20,7 +20,7 @@ PY_DEPENDS= ${PYTHON_PKGNAMEPREFIX}astor>=0.8:devel/py-astor@${PY_FLAVOR} \
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist
NO_ARCH= yes
diff --git a/lang/py-lupa/Makefile b/lang/py-lupa/Makefile
index 0c997478550e..c49dcfcdd6b4 100644
--- a/lang/py-lupa/Makefile
+++ b/lang/py-lupa/Makefile
@@ -11,7 +11,7 @@ WWW= https://github.com/scoder/lupa
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-USES= lua pkgconfig python:3.6+
+USES= lua pkgconfig python
USE_PYTHON= autoplist concurrent cython distutils unittest
MAKE_ARGS= --no-bundle --with-cython --with-lua-checks
diff --git a/lang/py-textX/Makefile b/lang/py-textX/Makefile
index 4b17fff0d4f3..52d2b50b2c75 100644
--- a/lang/py-textX/Makefile
+++ b/lang/py-textX/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}arpeggio>=2.0.0:devel/py-arpeggio@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}click>=7.0:devel/py-click@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}memory-profiler>0:devel/py-memory-profiler@${PY_FLAVOR}
-USES= python:3.6+
+USES= python
USE_PYTHON= distutils autoplist concurrent pytest # 25 tests fails, see https://github.com/textX/textX/issues/394
NO_ARCH= yes
diff --git a/lang/python-tools/Makefile b/lang/python-tools/Makefile
index f4296366268d..752bca1cf25b 100644
--- a/lang/python-tools/Makefile
+++ b/lang/python-tools/Makefile
@@ -13,7 +13,7 @@ LICENSE= PSFL
PORTSCOUT= ignore:1
-USES= python:3.6+ shebangfix tar:xz
+USES= python shebangfix tar:xz
USE_PYTHON= flavors concurrent
NO_BUILD= yes
NO_ARCH= yes
diff --git a/lang/python3/Makefile b/lang/python3/Makefile
index 23afe56a71bc..4bc0e7a9e93c 100644
--- a/lang/python3/Makefile
+++ b/lang/python3/Makefile
@@ -10,7 +10,7 @@ MAINTAINER= python@FreeBSD.org
COMMENT= Meta-port for the Python interpreter 3.x
WWW= https://www.python.org/
-USES= python:3.6+,run
+USES= python:run
NO_ARCH= yes
NO_BUILD= yes
diff --git a/lang/rust-bootstrap/Makefile b/lang/rust-bootstrap/Makefile
index 2b9a27b61d24..1398b5cedbec 100644
--- a/lang/rust-bootstrap/Makefile
+++ b/lang/rust-bootstrap/Makefile
@@ -30,7 +30,7 @@ BUILD_DEPENDS= ${FLAVOR:S/_/-/g}-freebsd-sysroot>=a2021.09.14:devel/freebsd-sysr
FLAVORS= aarch64 amd64 armv7 i386 powerpc powerpc64 powerpc64le riscv64
FLAVOR?= ${FLAVORS:[1]}
-USES= cpe ninja:build perl5 python:3.6+,build tar:xz
+USES= cpe ninja:build perl5 python:build tar:xz
CPE_VENDOR= ${PORTNAME}-lang
# for openssl-src crate
USE_PERL5= build
diff --git a/lang/rust/Makefile b/lang/rust/Makefile
index 0cac87ed77a5..184c0768b95f 100644
--- a/lang/rust/Makefile
+++ b/lang/rust/Makefile
@@ -30,7 +30,7 @@ ONLY_FOR_ARCHS_REASON?= requires prebuilt bootstrap compiler
BUILD_DEPENDS= cmake:devel/cmake-core
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cpe ninja:build pkgconfig python:3.7+,build ssl tar:xz
+USES= cpe ninja:build pkgconfig python:build ssl tar:xz
CPE_VENDOR= rust-lang
diff --git a/lang/v8-beta/Makefile b/lang/v8-beta/Makefile
index a28f5280d20d..cc2f96927fe2 100644
--- a/lang/v8-beta/Makefile
+++ b/lang/v8-beta/Makefile
@@ -31,7 +31,7 @@ BUILD_DEPENDS= binutils>=0:devel/binutils \
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR}
LIB_DEPENDS= libicudata.so:devel/icu
-USES= compiler:c++17-lang cpe gnome ninja pkgconfig python:3.5+,build tar:xz
+USES= compiler:c++17-lang cpe gnome ninja pkgconfig python:build tar:xz
USE_GNOME= glib20
BINARY_ALIAS= python3=${PYTHON_CMD}
diff --git a/lang/v8/Makefile b/lang/v8/Makefile
index 71490f7435d1..b71e6f2748b5 100644
--- a/lang/v8/Makefile
+++ b/lang/v8/Makefile
@@ -30,7 +30,7 @@ BUILD_DEPENDS= binutils>=0:devel/binutils \
${PYTHON_PKGNAMEPREFIX}Jinja2>=0:devel/py-Jinja2@${PY_FLAVOR}
LIB_DEPENDS= libicudata.so:devel/icu
-USES= compiler:c++17-lang cpe gnome ninja pkgconfig python:3.5+,build tar:xz
+USES= compiler:c++17-lang cpe gnome ninja pkgconfig python:build tar:xz
USE_GNOME= glib20
BINARY_ALIAS= python3=${PYTHON_CMD}