aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorVladimir Druzenko <vvd@FreeBSD.org>2023-12-27 15:06:33 +0000
committerVladimir Druzenko <vvd@FreeBSD.org>2023-12-27 15:14:57 +0000
commit96a9498e4753107d04013305f509ac8a0dc79351 (patch)
tree73d6b5a157208b45b4b90b04d0764da4ead20122 /multimedia
parent183809190723b9b1b6cc88cd72a732c29730d38a (diff)
downloadports-96a9498e4753107d04013305f509ac8a0dc79351.tar.gz
ports-96a9498e4753107d04013305f509ac8a0dc79351.zip
multimedia/vlc: fix build with CHROMECAST ON and devel/protobuf 24 and fix plist error if QT5 is ON and xext,xinerama,xpm installed
1. Non default option CHROMECAST require devel/protobuf. After this commit https://cgit.freebsd.org/ports/commit/?id=69e2e87fa56b54e267429b326f7f6188a7baaa71 consumers require USE_CXXSTD=c++17. 2. There is default ON configure option "skins2" in vlc. It require QT5 and xext,xinerama,xpm - if they installed then it build bin/svlc and it is in stage after build. Added option SKINS default OFF to handle bin/svlc. Approved by: arrowd (mentor) Differential Revision: https://reviews.freebsd.org/D43128
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/vlc/Makefile9
-rw-r--r--multimedia/vlc/pkg-plist1
2 files changed, 9 insertions, 1 deletions
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 0d12ef199451..7242e09200a0 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -74,7 +74,7 @@ OPTIONS_DEFINE= A52 AALIB AOM ASS AVAHI CACA CHROMECAST DAV1D DBUS DCA DOCS DVDR
LIVEMEDIA LUA MAD MFX MODPLUG MPEG2 MTP MUSEPACK \
NCURSES NFS NLS NOTIFY OGG OGGSPOTS OPTIMIZED_CFLAGS OPUS PNG PULSEAUDIO \
QT5 REALRTSP RUNROOT SAMPLERATE SIDPLAY \
- SDL SHOUTCAST SMB SNDIO STREAM SPEEX TAGLIB THEORA \
+ SDL SHOUTCAST SKINS SMB SNDIO STREAM SPEEX TAGLIB THEORA \
TWOLAME UPNP V4L VAAPI VCD VDPAU VPX VORBIS WAYLAND X11 X264 X265 ZVBI
OPTIONS_DEFINE_powerpc= ALTIVEC
OPTIONS_DEFINE_powerpc64= ALTIVEC
@@ -106,6 +106,7 @@ OGGSPOTS_DESC= Experimental OggSpots codec
REALRTSP_DESC= Real RTSP access module
RUNROOT_DESC= Enable running as root
SIDPLAY_DESC= C64 sid demux support
+SKINS_DESC= Build skins2 interface module (implies QT5)
STREAM_DESC= stream output
TAGLIB_DESC= ID3 tag and Ogg comment support
VCD_DESC= Audio/Video CD support
@@ -135,6 +136,7 @@ CACA_CONFIGURE_ENABLE= caca
CHROMECAST_LIB_DEPENDS= libprotobuf-lite.so:devel/protobuf
CHROMECAST_CONFIGURE_ENABLE= chromecast
+CHROMECAST_USE= cxxstd=c++17
DAV1D_LIB_DEPENDS= libdav1d.so:multimedia/dav1d
DAV1D_CONFIGURE_ENABLE= dav1d
@@ -300,6 +302,11 @@ CONFIGURE_ARGS+= --disable-sid
SHOUTCAST_LIB_DEPENDS= libshout.so:audio/libshout
SHOUTCAST_CONFIGURE_ENABLE= shout
+SKINS_USE= XORG=xext,xinerama,xpm
+SKINS_USES= xorg
+SKINS_CONFIGURE_ENABLE= skins2
+SKINS_IMPLIES= QT5
+
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
SNDIO_CONFIGURE_ENABLE= sndio
diff --git a/multimedia/vlc/pkg-plist b/multimedia/vlc/pkg-plist
index 1fdcf86b45af..4b4388bacfdd 100644
--- a/multimedia/vlc/pkg-plist
+++ b/multimedia/vlc/pkg-plist
@@ -2,6 +2,7 @@ bin/cvlc
%%NCURSES%%bin/nvlc
%%QT5%%bin/qvlc
bin/rvlc
+%%SKINS%%bin/svlc
bin/vlc
bin/vlc-wrapper
include/vlc/deprecated.h