aboutsummaryrefslogtreecommitdiff
path: root/news
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2022-09-07 21:06:12 +0000
committerStefan Eßer <se@FreeBSD.org>2022-09-07 21:10:59 +0000
commitb7f05445c00f2625aa19b4154ebcbce5ed2daa52 (patch)
treec3b04fc0b07c55f849072e9b35e694f3d8ccf871 /news
parent6c266c9c9e7b0ac1a35b05fbdeddbc330e4c5f43 (diff)
downloadports-b7f05445c00f2625aa19b4154ebcbce5ed2daa52.tar.gz
ports-b7f05445c00f2625aa19b4154ebcbce5ed2daa52.zip
Add WWW entries to port Makefiles
It has been common practice to have one or more URLs at the end of the ports' pkg-descr files, one per line and prefixed with "WWW:". These URLs should point at a project website or other relevant resources. Access to these URLs required processing of the pkg-descr files, and they have often become stale over time. If more than one such URL was present in a pkg-descr file, only the first one was tarnsfered into the port INDEX, but for many ports only the last line did contain the port specific URL to further information. There have been several proposals to make a project URL available as a macro in the ports' Makefiles, over time. This commit implements such a proposal and moves one of the WWW: entries of each pkg-descr file into the respective port's Makefile. A heuristic attempts to identify the most relevant URL in case there is more than one WWW: entry in some pkg-descr file. URLs that are not moved into the Makefile are prefixed with "See also:" instead of "WWW:" in the pkg-descr files in order to preserve them. There are 1256 ports that had no WWW: entries in pkg-descr files. These ports will not be touched in this commit. The portlint port has been adjusted to expect a WWW entry in each port Makefile, and to flag any remaining "WWW:" lines in pkg-descr files as deprecated. Approved by: portmgr (tcberner)
Diffstat (limited to 'news')
-rw-r--r--news/aub/Makefile1
-rw-r--r--news/c-nocem/Makefile1
-rw-r--r--news/cg/Makefile1
-rw-r--r--news/cnews/Makefile1
-rw-r--r--news/diablo/Makefile1
-rw-r--r--news/fidogate/Makefile1
-rw-r--r--news/fidogate4/Makefile1
-rw-r--r--news/golded+/Makefile1
-rw-r--r--news/husky-areafix/Makefile1
-rw-r--r--news/husky-fidoconf/Makefile1
-rw-r--r--news/husky-hpt/Makefile1
-rw-r--r--news/husky-htick/Makefile1
-rw-r--r--news/husky-huskylib/Makefile1
-rw-r--r--news/husky-smapi/Makefile1
-rw-r--r--news/husky-sqpack/Makefile1
-rw-r--r--news/husky/Makefile1
-rw-r--r--news/ifmail/Makefile1
-rw-r--r--news/inn-current/Makefile2
-rw-r--r--news/inn/Makefile1
-rw-r--r--news/leafnode/Makefile1
-rw-r--r--news/mail2nntp/Makefile1
-rw-r--r--news/mmail/Makefile1
-rw-r--r--news/multisuck/Makefile1
-rw-r--r--news/newsfish/Makefile1
-rw-r--r--news/newsgrab/Makefile1
-rw-r--r--news/newspost/Makefile1
-rw-r--r--news/newsstar/Makefile1
-rw-r--r--news/newsx/Makefile1
-rw-r--r--news/nget/Makefile1
-rw-r--r--news/nn/Makefile1
-rw-r--r--news/nntpcache/Makefile1
-rw-r--r--news/noffle/Makefile1
-rw-r--r--news/nzbget/Makefile1
-rw-r--r--news/nzbhydra2/Makefile1
-rw-r--r--news/nzbperl/Makefile1
-rw-r--r--news/p5-NNTPClient/Makefile1
-rw-r--r--news/p5-News-Article-NoCeM/Makefile1
-rw-r--r--news/p5-News-Newsrc/Makefile1
-rw-r--r--news/p5-POE-Component-Client-NNTP/Makefile1
-rw-r--r--news/p5-POE-Component-Server-NNTP/Makefile1
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pgpmoose/Makefile1
-rw-r--r--news/py-pynzb/Makefile1
-rw-r--r--news/py-sabyenc3/Makefile1
-rw-r--r--news/rntrack/Makefile1
-rw-r--r--news/s-news/Makefile1
-rw-r--r--news/sabnzbdplus/Makefile1
-rw-r--r--news/slrn/Makefile1
-rw-r--r--news/slrnface/Makefile1
-rw-r--r--news/suck/Makefile1
-rw-r--r--news/tin/Makefile1
-rw-r--r--news/trn4/Makefile1
-rw-r--r--news/yencode/Makefile1
-rw-r--r--news/yydecode/Makefile1
54 files changed, 55 insertions, 0 deletions
diff --git a/news/aub/Makefile b/news/aub/Makefile
index 986ab5e08a0d..c928f5bd5816 100644
--- a/news/aub/Makefile
+++ b/news/aub/Makefile
@@ -7,6 +7,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Assemble usenet binaries
+WWW= https://yukidoke.org/~mako/projects/aub/
USES= shebangfix
SHEBANG_FILES= aub
diff --git a/news/c-nocem/Makefile b/news/c-nocem/Makefile
index 87bee1dda479..670a16307222 100644
--- a/news/c-nocem/Makefile
+++ b/news/c-nocem/Makefile
@@ -7,6 +7,7 @@ MASTER_SITES= http://sites.inka.de/~bigred/sw/ \
MAINTAINER= dinoex@FreeBSD.org
COMMENT= NoCeM for C News and INN
+WWW= http://sites.inka.de/~bigred/sw/c-nocem.html
LICENSE= PD
diff --git a/news/cg/Makefile b/news/cg/Makefile
index 9f15c15aa90d..714e3181881b 100644
--- a/news/cg/Makefile
+++ b/news/cg/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= http://www.nih.at/cg/
MAINTAINER= ports@FreeBSD.org
COMMENT= Semi-automatic newsgroup binary downloader
+WWW= https://www.nih.at/cg/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/cnews/Makefile b/news/cnews/Makefile
index 7c94bd46ebca..683729401240 100644
--- a/news/cnews/Makefile
+++ b/news/cnews/Makefile
@@ -27,6 +27,7 @@ PATCHFILES= c-news-patch-fileart.c c-news-patch-namelen \
MAINTAINER= dinoex@FreeBSD.org
COMMENT= News server
+WWW= https://www.dinoex.net/c-news.html
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
diff --git a/news/diablo/Makefile b/news/diablo/Makefile
index 8b4f2cccb623..e63c0d0819fc 100644
--- a/news/diablo/Makefile
+++ b/news/diablo/Makefile
@@ -7,6 +7,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION}-REL
MAINTAINER= ports@FreeBSD.org
COMMENT= Comprehensive newsfeeding and newsreading software package
+WWW= https://www.openusenet.org/diablo/
LICENSE= BSD3CLAUSE
diff --git a/news/fidogate/Makefile b/news/fidogate/Makefile
index 1eebaad17868..535713826121 100644
--- a/news/fidogate/Makefile
+++ b/news/fidogate/Makefile
@@ -6,6 +6,7 @@ CATEGORIES= news mail
MAINTAINER= admin@5034.ru
COMMENT= Fido-Internet Gateway and Tosser
+WWW= https://github.com/ykaliuta/fidogate
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/fidogate4/Makefile b/news/fidogate4/Makefile
index f57ee1131841..49bae6c0a77f 100644
--- a/news/fidogate4/Makefile
+++ b/news/fidogate4/Makefile
@@ -8,6 +8,7 @@ PKGNAMESUFFIX?= 4${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Fido-Internet Gateway and Tosser
+WWW= http://fidogate.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/golded+/Makefile b/news/golded+/Makefile
index 650e765ac874..14e8b2bc398e 100644
--- a/news/golded+/Makefile
+++ b/news/golded+/Makefile
@@ -6,6 +6,7 @@ DISTNAME= gpsrc-115-${SNAPDATE}
MAINTAINER= ports@FreeBSD.org
COMMENT= GoldEd+ (FTN message editor)
+WWW= http://golded-plus.sourceforge.net/
LICENSE= GPLv2 LGPL20
LICENSE_COMB= multi
diff --git a/news/husky-areafix/Makefile b/news/husky-areafix/Makefile
index 554c13e91c42..0d434c5050bb 100644
--- a/news/husky-areafix/Makefile
+++ b/news/husky-areafix/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-areafix
COMMENT= Husky FTN areafix library
+WWW= http://husky.sourceforge.net/
LICENSE= LGPL20
diff --git a/news/husky-fidoconf/Makefile b/news/husky-fidoconf/Makefile
index e0f1095ffb9c..af863bec2ed5 100644
--- a/news/husky-fidoconf/Makefile
+++ b/news/husky-fidoconf/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-fidoconf
COMMENT= Husky FTN configuration library
+WWW= http://husky.sourceforge.net/
LICENSE= LGPL20
diff --git a/news/husky-hpt/Makefile b/news/husky-hpt/Makefile
index bcdcf49714a9..10d7eff7f43a 100644
--- a/news/husky-hpt/Makefile
+++ b/news/husky-hpt/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-hpt
COMMENT= Husky FTN tosser
+WWW= http://husky.sourceforge.net/
LICENSE= GPLv2
diff --git a/news/husky-htick/Makefile b/news/husky-htick/Makefile
index 0f8dd5ec5c8e..252dc2e0d7fa 100644
--- a/news/husky-htick/Makefile
+++ b/news/husky-htick/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-htick
COMMENT= Husky FTN file ticker
+WWW= http://husky.sourceforge.net/
LICENSE= GPLv2
diff --git a/news/husky-huskylib/Makefile b/news/husky-huskylib/Makefile
index 384776bfa431..a297ed786c03 100644
--- a/news/husky-huskylib/Makefile
+++ b/news/husky-huskylib/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-huskylib
COMMENT= Husky generic FTN library
+WWW= http://husky.sourceforge.net/
LICENSE= LGPL21
diff --git a/news/husky-smapi/Makefile b/news/husky-smapi/Makefile
index 405457e862b1..8cac837d1637 100644
--- a/news/husky-smapi/Makefile
+++ b/news/husky-smapi/Makefile
@@ -2,6 +2,7 @@ PORTNAME= husky-smapi
PORTEPOCH= 1
COMMENT= Husky FTN MSGAPI library
+WWW= http://husky.sourceforge.net/
LICENSE= LGPL21
diff --git a/news/husky-sqpack/Makefile b/news/husky-sqpack/Makefile
index 9bf0f2120b81..5a009830caaa 100644
--- a/news/husky-sqpack/Makefile
+++ b/news/husky-sqpack/Makefile
@@ -1,6 +1,7 @@
PORTNAME= husky-sqpack
COMMENT= Husky FTN msgbase packer
+WWW= http://husky.sourceforge.net/
LICENSE= GPLv2
diff --git a/news/husky/Makefile b/news/husky/Makefile
index 084cb3ef20e2..e9639f1180f8 100644
--- a/news/husky/Makefile
+++ b/news/husky/Makefile
@@ -7,6 +7,7 @@ DISTNAME= husky-all-1.9-source-20191207
MAINTAINER?= osharoiko@gmail.com
COMMENT?= Husky full featured highly portable FTN Tosser
+WWW= http://husky.sourceforge.net/
.if ${PORTNAME} == "husky"
RUN_DEPENDS= hpt:news/husky-hpt \
diff --git a/news/ifmail/Makefile b/news/ifmail/Makefile
index 6d6c7abd00cc..2157138c440d 100644
--- a/news/ifmail/Makefile
+++ b/news/ifmail/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SUNSITE/system/fido
MAINTAINER= dinoex@FreeBSD.org
COMMENT= FidoNet(tm) support package for UN*X platform
+WWW= http://ifmail.sourceforge.net/
LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/README
diff --git a/news/inn-current/Makefile b/news/inn-current/Makefile
index bb229f1e257d..a6c3223ae3a5 100644
--- a/news/inn-current/Makefile
+++ b/news/inn-current/Makefile
@@ -3,6 +3,8 @@ PORTVERSION= ${SNAPSHOT}
MASTER_SITE_SUBDIR= inn/snapshots
DISTNAME= inn-${BRANCH}-${SNAPSHOT}
+WWW= https://www.eyrie.org/~eagle/software/inn/
+
BRANCH= 2.8
SNAPSHOT= 20220812
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 9e5fe5e783f4..d2d767f14bb5 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -7,6 +7,7 @@ MASTER_SITE_SUBDIR?= ${PORTNAME}
MAINTAINER= kbowling@FreeBSD.org
COMMENT= InterNetNews -- the Internet meets Netnews
+WWW= https://www.eyrie.org/~eagle/software/inn/
BUILD_DEPENDS= p5-GD>=0:graphics/p5-GD \
p5-MIME-Tools>=0:mail/p5-MIME-Tools
diff --git a/news/leafnode/Makefile b/news/leafnode/Makefile
index 638bdb6b33b6..a64dcc7056ec 100644
--- a/news/leafnode/Makefile
+++ b/news/leafnode/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SF \
MAINTAINER= mandree@FreeBSD.org
COMMENT= NNTP package for offline news caching and reading
+WWW= https://www.leafnode.org/
LICENSE= GPLv2+
diff --git a/news/mail2nntp/Makefile b/news/mail2nntp/Makefile
index e7b64cf101fd..0f9998430faa 100644
--- a/news/mail2nntp/Makefile
+++ b/news/mail2nntp/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/Stable%201.0/
MAINTAINER= gary@hayers.org
COMMENT= Simple mail to news gateway
+WWW= https://sourceforge.net/projects/mail2nntp/
LICENSE= GPLv2
diff --git a/news/mmail/Makefile b/news/mmail/Makefile
index 37b8f785be10..63420a1e8fd6 100644
--- a/news/mmail/Makefile
+++ b/news/mmail/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= SF/multimail/MultiMail/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Offline BBS mail packet reader supporting QWK/OMEN/SOUP/OPX/BLUEWAVE
+WWW= http://multimail.sourceforge.net/
RUN_DEPENDS= zip:archivers/zip
diff --git a/news/multisuck/Makefile b/news/multisuck/Makefile
index 8fa35887e3d5..d7dfa09ee543 100644
--- a/news/multisuck/Makefile
+++ b/news/multisuck/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Multi-server/conn news suck
+WWW= http://multisuck.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/newsfish/Makefile b/news/newsfish/Makefile
index 046adcc0586f..d01ff73f4f3b 100644
--- a/news/newsfish/Makefile
+++ b/news/newsfish/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Batch USENET news reader with filter capabilities
+WWW= https://www.saddi.com/software/newsfish/
USES= gmake
GNU_CONFIGURE= yes
diff --git a/news/newsgrab/Makefile b/news/newsgrab/Makefile
index 48e56f3b6a04..4dcd424ee4ed 100644
--- a/news/newsgrab/Makefile
+++ b/news/newsgrab/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Download and uudecode binary files from USENET using regexps
+WWW= http://newsgrab.sourceforge.net/
RUN_DEPENDS= p5-NNTPClient>=0:news/p5-NNTPClient \
p5-Term-ReadKey>=0:devel/p5-Term-ReadKey \
diff --git a/news/newspost/Makefile b/news/newspost/Makefile
index d4fbee6079b5..ba112b2a6ed1 100644
--- a/news/newspost/Makefile
+++ b/news/newspost/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= http://newspost.unixcab.org/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Full-featured Usenet binary autoposter
+WWW= http://newspost.unixcab.org/
LICENSE= GPLv2
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 21c075cd3db7..e6ee878a88b4 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SF
MAINTAINER= mandree@FreeBSD.org
COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
+WWW= http://newsstar.sourceforge.net/
LICENSE= GPLv3
diff --git a/news/newsx/Makefile b/news/newsx/Makefile
index a84eb4e3643c..3e9a32d9e267 100644
--- a/news/newsx/Makefile
+++ b/news/newsx/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= LOCAL/thierry
MAINTAINER= thierry@FreeBSD.org
COMMENT= Program to fetch news from and post news to a remote NNTP server
+WWW= http://www.kvaleberg.no/newsx.html
LICENSE= GPLv2
diff --git a/news/nget/Makefile b/news/nget/Makefile
index 68ebbb69edec..61633e461783 100644
--- a/news/nget/Makefile
+++ b/news/nget/Makefile
@@ -7,6 +7,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Auto-resuming command line NNTP file grabber
+WWW= http://nget.sourceforge.net/
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/nn/Makefile b/news/nn/Makefile
index db6b54b39393..ce6bb9b93480 100644
--- a/news/nn/Makefile
+++ b/news/nn/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= ftp://ftp.nndev.org/pub/nn-${PORTVERSION:R}/
MAINTAINER= ports@FreeBSD.org
COMMENT= Menu based USENET newsreader
+WWW= http://www.nndev.org/
BROKEN_aarch64= Fails to link: missing sbrk
BROKEN_riscv64= Fails to link: missing sbrk
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 04e96322e85e..2f7f95a2166a 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= http://www.xs4all.nl/~suelette/
MAINTAINER= ports@FreeBSD.org
COMMENT= News caching/anti-spam/server-merging system
+WWW= http://iq.org/~proff/nntpcache.org/
# Converted from NO_CDROM
LICENSE= nttpcache
diff --git a/news/noffle/Makefile b/news/noffle/Makefile
index 845e115a5673..1a24168118b4 100644
--- a/news/noffle/Makefile
+++ b/news/noffle/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28devel%29/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= News server for low speed dial-up connections
+WWW= http://noffle.sourceforge.net/
LIB_DEPENDS= libgdbm.so:databases/gdbm
diff --git a/news/nzbget/Makefile b/news/nzbget/Makefile
index eb156db9b04e..178efbc5df4d 100644
--- a/news/nzbget/Makefile
+++ b/news/nzbget/Makefile
@@ -6,6 +6,7 @@ CATEGORIES= news
MAINTAINER= alexis.praga@free.fr
COMMENT= Binary newsreader supporting NZB files
+WWW= http://nzbget.net/
LICENSE= GPLv2
diff --git a/news/nzbhydra2/Makefile b/news/nzbhydra2/Makefile
index 5614b598d651..b9e0e6b4b240 100644
--- a/news/nzbhydra2/Makefile
+++ b/news/nzbhydra2/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= https://github.com/theotherp/${PORTNAME}/releases/download/v${DIST
MAINTAINER= daniel@shafer.cc
COMMENT= Usenet meta search
+WWW= https://github.com/theotherp/nzbhydra2
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
diff --git a/news/nzbperl/Makefile b/news/nzbperl/Makefile
index 8ba1033bbbca..0832cf3a565f 100644
--- a/news/nzbperl/Makefile
+++ b/news/nzbperl/Makefile
@@ -10,6 +10,7 @@ EXTRACT_SUFX=
MAINTAINER= ports@thepentagon.org
COMMENT= Perl script for downloading nzb files
+WWW= https://noisybox.net/computers/nzbperl/
RUN_DEPENDS= p5-XML-DOM>=0:textproc/p5-XML-DOM \
p5-Term-ReadKey>=0:devel/p5-Term-ReadKey \
diff --git a/news/p5-NNTPClient/Makefile b/news/p5-NNTPClient/Makefile
index 7f95dcadcab8..ef4626eccc46 100644
--- a/news/p5-NNTPClient/Makefile
+++ b/news/p5-NNTPClient/Makefile
@@ -7,6 +7,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gary@hayers.org
COMMENT= Client interface to NNTP (RFC977)
+WWW= https://metacpan.org/release/NNTPClient
USES= perl5
USE_PERL5= configure
diff --git a/news/p5-News-Article-NoCeM/Makefile b/news/p5-News-Article-NoCeM/Makefile
index d695139f030b..940a339d6bda 100644
--- a/news/p5-News-Article-NoCeM/Makefile
+++ b/news/p5-News-Article-NoCeM/Makefile
@@ -6,6 +6,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Module to generate accurate NoCeM notices
+WWW= https://metacpan.org/release/News-Article-NoCeM
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
diff --git a/news/p5-News-Newsrc/Makefile b/news/p5-News-Newsrc/Makefile
index 86cf3c9da0e1..369f5e62bfff 100644
--- a/news/p5-News-Newsrc/Makefile
+++ b/news/p5-News-Newsrc/Makefile
@@ -7,6 +7,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Manage newsrc files
+WWW= https://metacpan.org/release/News-Newsrc
BUILD_DEPENDS= ${RUN_DEPENDS}
RUN_DEPENDS= p5-Set-IntSpan>=0:math/p5-Set-IntSpan
diff --git a/news/p5-POE-Component-Client-NNTP/Makefile b/news/p5-POE-Component-Client-NNTP/Makefile
index 495b97f7cb3b..daba1897f78e 100644
--- a/news/p5-POE-Component-Client-NNTP/Makefile
+++ b/news/p5-POE-Component-Client-NNTP/Makefile
@@ -7,6 +7,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= POE component for non-blocking NNTP access
+WWW= https://metacpan.org/release/POE-Component-Client-NNTP
BUILD_DEPENDS= p5-POE>=0.999.9:devel/p5-POE \
p5-POE-Component-Pluggable>=0.03:devel/p5-POE-Component-Pluggable \
diff --git a/news/p5-POE-Component-Server-NNTP/Makefile b/news/p5-POE-Component-Server-NNTP/Makefile
index bb6bd2189400..c32e704e259c 100644
--- a/news/p5-POE-Component-Server-NNTP/Makefile
+++ b/news/p5-POE-Component-Server-NNTP/Makefile
@@ -6,6 +6,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Component that provides NNTP server functionality
+WWW= https://metacpan.org/release/POE-Component-Server-NNTP
LICENSE= ART10 GPLv1+
LICENSE_COMB= dual
diff --git a/news/pan/Makefile b/news/pan/Makefile
index df814a3326db..ca7acd23c59c 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -7,6 +7,7 @@ DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Threaded GTK+ newsreader based on Agent for Windows
+WWW= https://pan.rebelbase.com/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/pgpmoose/Makefile b/news/pgpmoose/Makefile
index efe3b3eb66be..539631f88e40 100644
--- a/news/pgpmoose/Makefile
+++ b/news/pgpmoose/Makefile
@@ -9,6 +9,7 @@ DISTNAME= PGPMoose
MAINTAINER= dinoex@FreeBSD.org
COMMENT= PGP Moose - signatures for moderated newsgroups
+WWW= http://seer-grog.net/pgpmoose.html
USES= tar:Z shebangfix
NO_WRKSUBDIR= yes
diff --git a/news/py-pynzb/Makefile b/news/py-pynzb/Makefile
index 362425b6b314..01948f4ebc23 100644
--- a/news/py-pynzb/Makefile
+++ b/news/py-pynzb/Makefile
@@ -7,6 +7,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Unified API for parsing NZB files
+WWW= https://pypi.org/project/pynzb/
LICENSE= BSD3CLAUSE
diff --git a/news/py-sabyenc3/Makefile b/news/py-sabyenc3/Makefile
index 8efbb1ef7032..06ed48f3a283 100644
--- a/news/py-sabyenc3/Makefile
+++ b/news/py-sabyenc3/Makefile
@@ -6,6 +6,7 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Python yEnc package optimized for use within SABnzbd
+WWW= https://github.com/sabnzbd/sabyenc
LICENSE= LGPL3
LICENSE_FILE= ${WRKSRC}/LICENSE.md
diff --git a/news/rntrack/Makefile b/news/rntrack/Makefile
index 7185eddbeca8..6e9d763bab9f 100644
--- a/news/rntrack/Makefile
+++ b/news/rntrack/Makefile
@@ -8,6 +8,7 @@ DISTNAME= rntrack-2_1_10-src
MAINTAINER= admin@5034.ru
COMMENT= FTN Messages tracker
+WWW= https://sourceforge.net/projects/ftrack-as/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
diff --git a/news/s-news/Makefile b/news/s-news/Makefile
index 84ec6368c125..8a1c5172ac45 100644
--- a/news/s-news/Makefile
+++ b/news/s-news/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= http://www.lost.org.uk/
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple news server for hosts with one or two users
+WWW= https://www.lost.org.uk/snews.html
LIB_DEPENDS= libgdbm.so:databases/gdbm
diff --git a/news/sabnzbdplus/Makefile b/news/sabnzbdplus/Makefile
index 9e6f0fadb945..8c82f9f598d6 100644
--- a/news/sabnzbdplus/Makefile
+++ b/news/sabnzbdplus/Makefile
@@ -7,6 +7,7 @@ DISTNAME= SABnzbd-${DISTVERSION}-src
MAINTAINER= james@french.id.au
COMMENT= Web-interface based binary newsgrabber in python, with nzb support
+WWW= https://sabnzbd.org/
LICENSE= BSD2CLAUSE BSD3CLAUSE GPLv2+ ISCL MIT PSFL
LICENSE_COMB= multi
diff --git a/news/slrn/Makefile b/news/slrn/Makefile
index f4ae50d28c72..6db14d081029 100644
--- a/news/slrn/Makefile
+++ b/news/slrn/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= http://www.jedsoft.org/releases/slrn/
MAINTAINER= ports@FreeBSD.org
COMMENT= SLang-based newsreader
+WWW= http://slrn.sourceforge.net/
LICENSE= GPLv2+
diff --git a/news/slrnface/Makefile b/news/slrnface/Makefile
index 08cbc52cb30a..39343930aed1 100644
--- a/news/slrnface/Makefile
+++ b/news/slrnface/Makefile
@@ -7,6 +7,7 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
MAINTAINER= ports@FreeBSD.org
COMMENT= Shows X-Faces from slrn in X11 terminal emulator
+WWW= http://dave.willfork.com/slrnface/
LIB_DEPENDS= libcompface.so:mail/faces
diff --git a/news/suck/Makefile b/news/suck/Makefile
index 7d6b48e6bd49..e7f56f7f402c 100644
--- a/news/suck/Makefile
+++ b/news/suck/Makefile
@@ -5,6 +5,7 @@ PKGNAMESUFFIX?= ${CNEWS_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Receives/sends news to/from localhost via NNTP
+WWW= https://github.com/lazarus-pkgs/suck
LICENSE= PD
diff --git a/news/tin/Makefile b/news/tin/Makefile
index 14c078c03bee..1cabb3976a35 100644
--- a/news/tin/Makefile
+++ b/news/tin/Makefile
@@ -17,6 +17,7 @@ MASTER_SITES= ftp://ftp.tin.org/pub/news/clients/tin/v${PORTVERSION:R}/ \
MAINTAINER?= kbowling@FreeBSD.org
COMMENT= Easy-to-use threaded newsreader with NOV/NNTP support
+WWW= http://www.tin.org/
LICENSE= BSD3CLAUSE
diff --git a/news/trn4/Makefile b/news/trn4/Makefile
index 1fa5e3cfc5b7..9f9ef51aa7c5 100644
--- a/news/trn4/Makefile
+++ b/news/trn4/Makefile
@@ -7,6 +7,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/-test/}
MAINTAINER= ports@FreeBSD.org
COMMENT= Version 4.0 of the threaded readnews newsreader
+WWW= https://sourceforge.net/projects/trn/
CONFLICTS_INSTALL= trn cnews s-news
diff --git a/news/yencode/Makefile b/news/yencode/Makefile
index 292a960611f2..299713741bd2 100644
--- a/news/yencode/Makefile
+++ b/news/yencode/Makefile
@@ -6,6 +6,7 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Free (GPL) encoder and decoder for the yEnc Usenet file format
+WWW= http://www.yencode.org/
USES= gettext
GNU_CONFIGURE= yes
diff --git a/news/yydecode/Makefile b/news/yydecode/Makefile
index ae7429f3ba8a..a41ce07aedd2 100644
--- a/news/yydecode/Makefile
+++ b/news/yydecode/Makefile
@@ -5,6 +5,7 @@ MASTER_SITES= SF
MAINTAINER= miki@ceti.pl
COMMENT= Tool to decode yEnc encoded files
+WWW= http://yydecode.sf.net/
USES= gmake
GNU_CONFIGURE= yes