aboutsummaryrefslogtreecommitdiff
path: root/ports-mgmt
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2022-02-09 12:52:30 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2022-02-09 12:52:30 +0000
commit200987777b69cc702aca712c216050145668bbf5 (patch)
treee0d35ca5d02181950caf5bbe4523fca868a03b9e /ports-mgmt
parentefd75db88f4630ea464d33e6e8ee00964af13e1d (diff)
downloadports-200987777b69cc702aca712c216050145668bbf5.tar.gz
ports-200987777b69cc702aca712c216050145668bbf5.zip
ports-mgmt/sccache-overlay: Disable idle timeout by default
It seems like it is too easy to hit during Firefox builds and then the server is gone and builds fail with: sccache: error: Connection to server timed out Since Firefox disables it itself do the same here. Tested by: jrm
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/sccache-overlay/Makefile2
-rw-r--r--ports-mgmt/sccache-overlay/files/Mk/bsd.overlay.mk5
-rw-r--r--ports-mgmt/sccache-overlay/files/pkg-message.in6
3 files changed, 7 insertions, 6 deletions
diff --git a/ports-mgmt/sccache-overlay/Makefile b/ports-mgmt/sccache-overlay/Makefile
index 791f931c6de0..c77cf19785ce 100644
--- a/ports-mgmt/sccache-overlay/Makefile
+++ b/ports-mgmt/sccache-overlay/Makefile
@@ -1,7 +1,7 @@
PORTNAME= sccache
DISTVERSIONPREFIX= v
DISTVERSION= 0.2.15
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= ports-mgmt
PKGNAMESUFFIX= -overlay
diff --git a/ports-mgmt/sccache-overlay/files/Mk/bsd.overlay.mk b/ports-mgmt/sccache-overlay/files/Mk/bsd.overlay.mk
index 90f590b701fc..0dbb885d4e65 100644
--- a/ports-mgmt/sccache-overlay/files/Mk/bsd.overlay.mk
+++ b/ports-mgmt/sccache-overlay/files/Mk/bsd.overlay.mk
@@ -2,6 +2,7 @@
_SCCACHE_OVERLAY_INCLUDED= yes
SCCACHE_SIZE?= 16G
+SCCACHE_IDLE_TIMEOUT?= 0
SCCACHE_UNIX_LISTEN?= /tmp/sccache-overlay.socket
_SCCACHE_LIBS= ${LOCALBASE}/share/sccache/overlay/lib
@@ -26,6 +27,7 @@ IGNORE= SCCACHE_DIR not set
_SCCACHE_ENV= RUSTC_WRAPPER="${SCCACHE_BIN}" \
SCCACHE_CACHE_SIZE="${SCCACHE_SIZE}" \
SCCACHE_DIR="${SCCACHE_DIR}" \
+ SCCACHE_IDLE_TIMEOUT="${SCCACHE_IDLE_TIMEOUT}" \
SCCACHE_MAX_FRAME_LENGTH=104857600 \
SCCACHE_UNIX_LISTEN="${SCCACHE_UNIX_LISTEN}"
CONFIGURE_ENV+= ${_SCCACHE_ENV}
@@ -45,8 +47,7 @@ sccache-stats:
@${SETENV} ${_SCCACHE_ENV} ${SCCACHE_BIN} --show-stats || ${TRUE}
# We let Poudriere clean up the server. Users who build locally
-# can stop the server with `make sccache-stop` manually or wait
-# 10 minutes after the build until it shuts down automatically.
+# can stop the server with `make sccache-stop` manually.
sccache-stop:
@${ECHO_MSG} "==> Stopping sccache"
@${SETENV} ${_SCCACHE_ENV} ${SCCACHE_BIN} --stop-server
diff --git a/ports-mgmt/sccache-overlay/files/pkg-message.in b/ports-mgmt/sccache-overlay/files/pkg-message.in
index d84fccb4eceb..02e397e4800c 100644
--- a/ports-mgmt/sccache-overlay/files/pkg-message.in
+++ b/ports-mgmt/sccache-overlay/files/pkg-message.in
@@ -10,9 +10,9 @@ SCCACHE_DIR= ${HOME}/.sccache
OVERLAYS+= %%DATADIR%%/overlay
During the build a sccache server is started, bound to
-${SCCACHE_UNIX_LISTEN} (default /tmp/sccache-overlay.socket). It
-automatically shuts down after 600 seconds if nothing is using
-it. To cleanly shut it down earlier use
+${SCCACHE_UNIX_LISTEN} (default /tmp/sccache-overlay.socket).
+Idle timeout has been disabled to make builds more reliable. To
+cleanly shut down the server after the build use
$ make sccache-stop