aboutsummaryrefslogtreecommitdiff
path: root/print
diff options
context:
space:
mode:
authorMichael Osipov <michael.osipov@siemens.com>2023-03-29 11:54:23 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-03-29 11:55:19 +0000
commitd6b46695f33749aa9c8217f976149c6850c573ca (patch)
tree06d77ebe069b3dad51cb37ba093513763e70c83a /print
parentc2d137d0f014073026f0bdff87f87f8241dc33ca (diff)
downloadports-d6b46695f33749aa9c8217f976149c6850c573ca.tar.gz
ports-d6b46695f33749aa9c8217f976149c6850c573ca.zip
print/ghostscript10: New port: Import new major version
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/ghostscript10/Makefile101
-rw-r--r--print/ghostscript10/distinfo3
-rw-r--r--print/ghostscript10/files/patch-configure16
-rw-r--r--print/ghostscript10/files/patch-man_gs.1126
-rw-r--r--print/ghostscript10/files/patch-psi_imainarg.c44
-rw-r--r--print/ghostscript10/files/patch-tesseract_src_arch_simddetect.cpp34
-rw-r--r--print/ghostscript10/pkg-descr3
-rw-r--r--print/ghostscript10/pkg-message8
-rw-r--r--print/ghostscript10/pkg-plist341
10 files changed, 677 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index b20e01b15ae9..dd79be191a0e 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -56,6 +56,7 @@
SUBDIR += fpdf
SUBDIR += freetype2
SUBDIR += ft2demos
+ SUBDIR += ghostscript10
SUBDIR += ghostscript7-base
SUBDIR += ghostscript7-commfont
SUBDIR += ghostscript7-jpnfont
diff --git a/print/ghostscript10/Makefile b/print/ghostscript10/Makefile
new file mode 100644
index 000000000000..5553abfefe18
--- /dev/null
+++ b/print/ghostscript10/Makefile
@@ -0,0 +1,101 @@
+PORTNAME= ghostscript
+DISTVERSION= 10.01.0
+CATEGORIES= print
+MASTER_SITES= https://github.com/ArtifexSoftware/ghostpdl-downloads/releases/download/gs${DISTVERSION:S/.//g}/
+
+MAINTAINER= michael.osipov@siemens.com
+COMMENT= PostScript and PDF interpreter
+WWW= https://ghostscript.com/
+
+LICENSE= AGPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
+ libidn.so:dns/libidn \
+ libjbig2dec.so:graphics/jbig2dec \
+ liblcms2.so:graphics/lcms2 \
+ libopenjp2.so:graphics/openjpeg \
+ libpaper.so:print/libpaper \
+ libpng16.so:graphics/png \
+ libtiff.so:graphics/tiff
+RUN_DEPENDS= poppler-data>=0.4.9:graphics/poppler-data \
+ urw-base35-fonts>=20200910:x11-fonts/urw-base35-fonts
+
+USES= cpe gmake iconv jpeg localbase pkgconfig tar:xz
+CPE_VENDOR= artifex
+
+CONFLICTS_INSTALL= ghostscript[789]-base \
+ ghostscript[789]-x11 \
+ ghostscript9-agpl-base \
+ ghostscript9-agpl-x11
+EXTRACT_AFTER_ARGS= --exclude cups/libs \
+ --exclude freetype \
+ --exclude ijs \
+ --exclude jbig2dec \
+ --exclude jpeg \
+ --exclude lcms2mt \
+ --exclude libpng \
+ --exclude openjpeg \
+ --exclude tiff \
+ --exclude zlib
+
+DATADIR= ${PREFIX}/share/${PORTNAME}/${DISTVERSION}
+
+GNU_CONFIGURE= yes
+
+CONFIGURE_ARGS= --disable-compile-inits \
+ --disable-dbus \
+ --disable-gtk \
+ --disable-dynamic \
+ --enable-contrib \
+ --enable-fontconfig \
+ --enable-freetype \
+ --enable-openjpeg \
+ --with-fontpath=${LOCALBASE}/share/fonts \
+ --with-jbig2dec \
+ --with-libiconv=maybe \
+ --with-libidn \
+ --with-libpaper \
+ --with-system-libtiff \
+ --without-x
+
+OPTIONS_DEFINE= CUPS IJS TESSERACT
+OPTIONS_DEFAULT=CUPS
+
+IJS_DESC= Support libijs based Ghostscript devices
+TESSERACT_DESC= Enable bundled Tesseract OCR engine
+
+CUPS_LIB_DEPENDS= libcups.so:print/cups
+CUPS_CONFIGURE_ENABLE= cups
+
+IJS_LIB_DEPENDS= libijs.so:print/libijs
+IJS_CONFIGURE_WITH= ijs
+
+TESSERACT_USES= compiler:c++17-lang
+TESSERACT_CONFIGURE_WITH= tesseract
+# No TESSERACT_LIB_DEPENDS= libtesseract.so:graphics/tesseract
+# See https://bugs.ghostscript.com/show_bug.cgi?id=706490
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${PATCH_WRKSRC}/man/gs.1
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/gs
+ ${RM} ${STAGEDIR}${PREFIX}/bin/lprsetup.sh
+ ${RM} ${STAGEDIR}${PREFIX}/bin/unix-lpr.sh
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/color/icc
+ ${MV} ${STAGEDIR}${DATADIR}/iccprofiles \
+ ${STAGEDIR}${PREFIX}/share/color/icc/ghostscript
+ ${RLN} ${STAGEDIR}${PREFIX}/share/color/icc/ghostscript \
+ ${STAGEDIR}${DATADIR}/iccprofiles
+ ${RM} -r ${STAGEDIR}${PREFIX}/share/doc/${PORTNAME}
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/cmap
+ ${MV} ${STAGEDIR}${DATADIR}/Resource/CMap/Identity* \
+ ${STAGEDIR}${PREFIX}/share/cmap
+ ${RM} -r ${STAGEDIR}${DATADIR}/Resource/CMap
+ ${RLN} ${STAGEDIR}${PREFIX}/share/cmap \
+ ${STAGEDIR}${DATADIR}/Resource/CMap
+
+.include <bsd.port.mk>
diff --git a/print/ghostscript10/distinfo b/print/ghostscript10/distinfo
new file mode 100644
index 000000000000..be62df9fa552
--- /dev/null
+++ b/print/ghostscript10/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1679593975
+SHA256 (ghostscript-10.01.0.tar.xz) = dfc8c3180546ebd5550c71d4ac68b04eed0f14186d93d35abc9324364bd3eac4
+SIZE (ghostscript-10.01.0.tar.xz) = 67564800
diff --git a/print/ghostscript10/files/patch-configure b/print/ghostscript10/files/patch-configure
new file mode 100644
index 000000000000..9f99249c05b1
--- /dev/null
+++ b/print/ghostscript10/files/patch-configure
@@ -0,0 +1,16 @@
+--- configure.orig 2022-04-04 13:48:49 UTC
++++ configure
+@@ -11629,7 +11629,12 @@ if test "${enable_dynamic+set}" = set; then :
+ DBG_CFLAGS="$DYNAMIC_CFLAGS $DBG_CFLAGS"
+ ;;
+ *bsd*)
+- DYNAMIC_DEVS="\$(GLOBJDIR)/X11.so"
++ INSTALL_SHARED="install-shared"
++ if test "x$X_DEVS" != x; then
++ DYNAMIC_DEVS="\$(GLOBJDIR)/X11.so"
++ else
++ DYNAMIC_DEVS=""
++ fi
+ DYNAMIC_FLAGS="-DGS_DEVS_SHARED -DGS_DEVS_SHARED_DIR=\\\"\$(gssharedir)\\\""
+ X11_DEVS=""
+ OPT_CFLAGS="$DYNAMIC_CFLAGS $OPT_CFLAGS"
diff --git a/print/ghostscript10/files/patch-man_gs.1 b/print/ghostscript10/files/patch-man_gs.1
new file mode 100644
index 000000000000..0bf1a1f6925a
--- /dev/null
+++ b/print/ghostscript10/files/patch-man_gs.1
@@ -0,0 +1,126 @@
+--- man/gs.1.orig 2023-03-21 15:07:46 UTC
++++ man/gs.1
+@@ -2,20 +2,14 @@
+ .SH NAME
+ gs \- Ghostscript (PostScript and PDF language interpreter and previewer)
+ .SH SYNOPSIS
+-\fBgs\fR [ \fIoptions\fR ] [ \fIfiles\fR ] ... \fB(Unix, VMS)\fR
+-.br
+-\fBgswin32c\fR [ \fIoptions\fR ] [ \fIfiles\fR ] ... \fB(MS Windows)\fR
+-.br
+-\fBgswin32\fR [ \fIoptions\fR ] [ \fIfiles\fR ] ... \fB(MS Windows 3.1)\fR
+-.br
+-\fBgsos2\fR [ \fIoptions\fR ] [ \fIfiles\fR ] ... \fB(OS/2)\fR
++\fBgs\fR [ \fIoptions\fR ] [ \fIfiles\fR ] ...
+ .de TQ
+ .br
+ .ns
+ .TP \\$1
+ ..
+ .SH DESCRIPTION
+-The \fBgs\fR (\fBgswin32c\fR, \fBgswin32\fR, \fBgsos2\fR)
++The \fBgs\fR
+ command invokes \fBGhostscript\fR, an interpreter of Adobe Systems'
+ \fBPostScript\fR(tm) and \fBPortable Document Format\fR (PDF) languages.
+ \fBgs\fR reads "files" in sequence and executes them as Ghostscript
+@@ -32,8 +26,7 @@ below. Please see the usage documentation for complete
+ may appear anywhere in the command line and apply to all files thereafter.
+ Invoking Ghostscript with the \fB\-h\fR or \fB\-?\fR switch produces a
+ message which shows several useful switches, all the devices known to
+-that executable, and the search path for fonts; on Unix it also shows the
+-location of detailed documentation.
++that executable, and the search path for fonts.
+ .PP
+ Ghostscript may be built to use many different output devices. To see
+ which devices your executable includes, run "\fBgs -h\fR".
+@@ -104,8 +97,8 @@ and the highest-density (best output quality) mode wit
+ .fi
+ .PP
+ If you select a printer as the output device, Ghostscript also allows you
+-to choose where Ghostscript sends the output \-\- on Unix systems, usually
+-to a temporary file. To send the output to a file "foo.xyz",
++to choose where Ghostscript sends the output.
++To send the output to a file "foo.xyz",
+ use the switch
+ .PP
+ .nf
+@@ -124,17 +117,13 @@ Each resulting file receives one page of output, and t
+ in sequence. "%d" is a printf format specification; you can also use a
+ variant like "%02d".
+ .PP
+-On Unix and MS Windows systems you can also send output to a pipe. For example, to
+-pipe output to the "\fBlpr\fR" command (which, on many Unix systems,
+-directs it to a printer), use the option
++You can also send output to a pipe. For example, to
++pipe output to the "\fBlpr\fR" command, use the option
+ .PP
+ .nf
+ \-sOutputFile=%pipe%lpr
+ .fi
+ .PP
+-Note that the '%' characters need to be doubled on MS Windows to avoid
+-mangling by the command interpreter.
+-.PP
+ You can also send output to standard output:
+ .PP
+ .nf
+@@ -316,31 +305,21 @@ and strongly NOT recommended in any other circumstance
+ .SH FILES
+ .PP
+ The locations of many Ghostscript run-time files are compiled into the
+-executable when it is built. On Unix these are typically based in
+-\fB/usr/local\fR, but this may be different on your system. Under DOS they
+-are typically based in \fBC:\\GS\fR, but may be elsewhere, especially if
+-you install Ghostscript with \fBGSview\fR. Run "\fBgs -h\fR" to find the
+-location of Ghostscript documentation on your system, from which you can
+-get more details.
++executable when it is built. Typically based in
++\fB%%LOCALBASE%%\fR.
+ .TP
+-.B /usr/local/share/ghostscript/#.##/*
++.B %%LOCALBASE%%/share/ghostscript/#.##/*
+ Startup files, utilities, and basic font definitions
+ .TP
+-.B /usr/local/share/ghostscript/fonts/*
++.B %%LOCALBASE%%/share/ghostscript/fonts/*
+ More font definitions
+-.TP
+-.B /usr/local/share/ghostscript/#.##/examples/*
+-Ghostscript demonstration files
+-.TP
+-.B /usr/local/share/ghostscript/#.##/doc/*
+-Diverse document files
+ .SH "INITIALIZATION FILES"
+ When looking for the initialization files "gs_*.ps", the files related to
+ fonts, or the file for the "run" operator, Ghostscript first tries to open
+ the file with the name as given, using the current working directory if no
+ directory is specified. If this fails, and the file name doesn't specify
+-an explicit directory or drive (for instance, doesn't contain "/" on Unix
+-systems or "\\" on MS Windows systems), Ghostscript tries directories in this
++an explicit directory,
++Ghostscript tries directories in this
+ order:
+ .TP 4
+ 1.
+@@ -353,9 +332,9 @@ if any;
+ .TP
+ 3.
+ the directories specified by the \fBGS_LIB_DEFAULT\fR macro in the
+-Ghostscript makefile when the executable was built. When \fBgs\fR is built
+-on Unix, \fBGS_LIB_DEFAULT\fR is usually
+-"/usr/local/share/ghostscript/#.##:/usr/local/share/ghostscript/fonts"
++Ghostscript makefile when the executable was built.
++Usually
++"%%LOCALBASE%%/share/ghostscript/#.##:%%LOCALBASE%%/share/ghostscript/fonts"
+ where "#.##" represents the Ghostscript version number.
+ .PP
+ Each of these (\fBGS_LIB_DEFAULT\fR, \fBGS_LIB\fR, and \fB\-I\fR parameter)
+@@ -417,8 +396,6 @@ Then merge these resources into the X server's resourc
+ .nf
+ % xrdb \-merge ~/.Xresources
+ .fi
+-.SH SEE ALSO
+-The various Ghostscript document files (above), especially \fBUse.htm\fR.
+ .SH BUGS
+ See http://bugs.ghostscript.com/ and the Usenet news group
+ comp.lang.postscript.
diff --git a/print/ghostscript10/files/patch-psi_imainarg.c b/print/ghostscript10/files/patch-psi_imainarg.c
new file mode 100644
index 000000000000..65a9daf1d421
--- /dev/null
+++ b/print/ghostscript10/files/patch-psi_imainarg.c
@@ -0,0 +1,44 @@
+--- psi/imainarg.c.orig 2023-03-21 14:58:42 UTC
++++ psi/imainarg.c
+@@ -109,7 +109,6 @@ static void print_usage(const gs_main_instance *);
+ static void print_devices(const gs_main_instance *);
+ static void print_emulators(const gs_main_instance *);
+ static void print_paths(gs_main_instance *);
+-static void print_help_trailer(const gs_main_instance *);
+
+ /* ------ Main program ------ */
+
+@@ -1262,7 +1261,6 @@ static const char help_debug[] = "\
+ --debug list debugging options\n";
+ #endif
+ static const char help_trailer[] = "\
+-For more information, see %s.\n\
+ Please report bugs to bugs.ghostscript.com.\n";
+ static const char help_devices[] = "Available devices:";
+ static const char help_default_device[] = "Default output device:";
+@@ -1305,7 +1303,7 @@ print_help(gs_main_instance * minst)
+ if (have_rom_device) {
+ outprintf(minst->heap, "Initialization files are compiled into the executable.\n");
+ }
+- print_help_trailer(minst);
++ outprintf(minst->heap, "%s", help_trailer);
+ }
+
+ /* Print the revision, revision date, and copyright. */
+@@ -1450,16 +1448,3 @@ print_paths(gs_main_instance * minst)
+ outprintf(minst->heap, "%s", help_fontconfig);
+ }
+
+-/* Print the help trailer. */
+-static void
+-print_help_trailer(const gs_main_instance *minst)
+-{
+- char buffer[gp_file_name_sizeof];
+- const char *use_htm = "Use.htm", *p = buffer;
+- uint blen = sizeof(buffer);
+-
+- if (gp_file_name_combine(gs_doc_directory, strlen(gs_doc_directory),
+- use_htm, strlen(use_htm), false, buffer, &blen) != gp_combine_success)
+- p = use_htm;
+- outprintf(minst->heap, help_trailer, p);
+-}
diff --git a/print/ghostscript10/files/patch-tesseract_src_arch_simddetect.cpp b/print/ghostscript10/files/patch-tesseract_src_arch_simddetect.cpp
new file mode 100644
index 000000000000..85afcf5d10f9
--- /dev/null
+++ b/print/ghostscript10/files/patch-tesseract_src_arch_simddetect.cpp
@@ -0,0 +1,34 @@
+--- tesseract/src/arch/simddetect.cpp.orig 2021-09-27 07:44:02 UTC
++++ tesseract/src/arch/simddetect.cpp
+@@ -40,10 +40,13 @@
+ #if defined(HAVE_NEON) && !defined(__aarch64__)
+ #ifdef ANDROID
+ #include <cpu-features.h>
+-#else
++#elif defined(__linux__)
+ /* Assume linux */
+ #include <sys/auxv.h>
+ #include <asm/hwcap.h>
++#elif defined(__FreeBSD__)
++#include <sys/auxv.h>
++#include <sys/elf.h>
+ #endif
+ #endif
+
+@@ -188,9 +191,15 @@ SIMDDetect::SIMDDetect() {
+ neon_available_ = (android_getCpuFeatures() &
+ ANDROID_CPU_ARM_FEATURE_NEON);
+ }
+-#else
++#elif defined(__linux__)
+ /* Assume linux */
+ neon_available_ = getauxval(AT_HWCAP) & HWCAP_NEON;
++#elif defined(__FreeBSD__)
++ unsigned long hwcap = 0;
++ elf_aux_info(AT_HWCAP, &hwcap, sizeof hwcap);
++ neon_available_ = hwcap & HWCAP_NEON;
++#else
++ neon_available_ = 0;
+ #endif
+ #endif
+
diff --git a/print/ghostscript10/pkg-descr b/print/ghostscript10/pkg-descr
new file mode 100644
index 000000000000..11df3a22f52f
--- /dev/null
+++ b/print/ghostscript10/pkg-descr
@@ -0,0 +1,3 @@
+Ghostscript is an interpreter for PostScript and Portable Document
+Format (PDF) files. It allows you to manipulate such files and to
+convert them to various printer, image and other formats.
diff --git a/print/ghostscript10/pkg-message b/print/ghostscript10/pkg-message
new file mode 100644
index 000000000000..b8b347553512
--- /dev/null
+++ b/print/ghostscript10/pkg-message
@@ -0,0 +1,8 @@
+[
+{ type: install
+ message: <<EOM
+This package installs a script named dvipdf that depends on dvips. If you
+want to use this script you need to install print/tex-dvipsk.
+EOM
+}
+]
diff --git a/print/ghostscript10/pkg-plist b/print/ghostscript10/pkg-plist
new file mode 100644
index 000000000000..861f38d4d3e3
--- /dev/null
+++ b/print/ghostscript10/pkg-plist
@@ -0,0 +1,341 @@
+bin/dvipdf
+bin/eps2eps
+bin/gs
+bin/gsbj
+bin/gsdj
+bin/gsdj500
+bin/gslj
+bin/gslp
+bin/gsnd
+bin/pdf2dsc
+bin/pdf2ps
+bin/pf2afm
+bin/pfbtopfa
+bin/pphs
+bin/printafm
+bin/ps2ascii
+bin/ps2epsi
+bin/ps2pdf
+bin/ps2pdf12
+bin/ps2pdf13
+bin/ps2pdf14
+bin/ps2pdfwr
+bin/ps2ps
+bin/ps2ps2
+man/man1/dvipdf.1.gz
+man/man1/eps2eps.1.gz
+man/man1/gs.1.gz
+man/man1/gsbj.1.gz
+man/man1/gsdj.1.gz
+man/man1/gsdj500.1.gz
+man/man1/gslj.1.gz
+man/man1/gslp.1.gz
+man/man1/gsnd.1.gz
+man/man1/pdf2dsc.1.gz
+man/man1/pdf2ps.1.gz
+man/man1/pf2afm.1.gz
+man/man1/pfbtopfa.1.gz
+man/man1/printafm.1.gz
+man/man1/ps2ascii.1.gz
+man/man1/ps2epsi.1.gz
+man/man1/ps2pdf.1.gz
+man/man1/ps2pdf12.1.gz
+man/man1/ps2pdf13.1.gz
+man/man1/ps2pdf14.1.gz
+man/man1/ps2pdfwr.1.gz
+man/man1/ps2ps.1.gz
+share/cmap/Identity-H
+share/cmap/Identity-UTF16-H
+share/cmap/Identity-V
+share/color/icc/ghostscript/a98.icc
+share/color/icc/ghostscript/default_cmyk.icc
+share/color/icc/ghostscript/default_gray.icc
+share/color/icc/ghostscript/default_rgb.icc
+share/color/icc/ghostscript/esrgb.icc
+share/color/icc/ghostscript/gray_to_k.icc
+share/color/icc/ghostscript/lab.icc
+share/color/icc/ghostscript/ps_cmyk.icc
+share/color/icc/ghostscript/ps_gray.icc
+share/color/icc/ghostscript/ps_rgb.icc
+share/color/icc/ghostscript/rommrgb.icc
+share/color/icc/ghostscript/scrgb.icc
+share/color/icc/ghostscript/sgray.icc
+share/color/icc/ghostscript/srgb.icc
+%%DATADIR%%/Resource/CIDFSubst/DroidSansFallback.ttf
+%%DATADIR%%/Resource/CIDFont/ArtifexBullet
+%%DATADIR%%/Resource/CMap
+%%DATADIR%%/Resource/ColorSpace/DefaultCMYK
+%%DATADIR%%/Resource/ColorSpace/DefaultGray
+%%DATADIR%%/Resource/ColorSpace/DefaultRGB
+%%DATADIR%%/Resource/ColorSpace/TrivialCMYK
+%%DATADIR%%/Resource/ColorSpace/sGray
+%%DATADIR%%/Resource/ColorSpace/sRGB
+%%DATADIR%%/Resource/Decoding/FCO_Dingbats
+%%DATADIR%%/Resource/Decoding/FCO_Symbol
+%%DATADIR%%/Resource/Decoding/FCO_Unicode
+%%DATADIR%%/Resource/Decoding/FCO_Wingdings
+%%DATADIR%%/Resource/Decoding/Latin1
+%%DATADIR%%/Resource/Decoding/StandardEncoding
+%%DATADIR%%/Resource/Decoding/Unicode
+%%DATADIR%%/Resource/Encoding/CEEncoding
+%%DATADIR%%/Resource/Encoding/ExpertEncoding
+%%DATADIR%%/Resource/Encoding/ExpertSubsetEncoding
+%%DATADIR%%/Resource/Encoding/NotDefEncoding
+%%DATADIR%%/Resource/Encoding/Wingdings
+%%DATADIR%%/Resource/Font/C059-BdIta
+%%DATADIR%%/Resource/Font/C059-Bold
+%%DATADIR%%/Resource/Font/C059-Italic
+%%DATADIR%%/Resource/Font/C059-Roman
+%%DATADIR%%/Resource/Font/D050000L
+%%DATADIR%%/Resource/Font/NimbusMonoPS-Bold
+%%DATADIR%%/Resource/Font/NimbusMonoPS-BoldItalic
+%%DATADIR%%/Resource/Font/NimbusMonoPS-Italic
+%%DATADIR%%/Resource/Font/NimbusMonoPS-Regular
+%%DATADIR%%/Resource/Font/NimbusRoman-Bold
+%%DATADIR%%/Resource/Font/NimbusRoman-BoldItalic
+%%DATADIR%%/Resource/Font/NimbusRoman-Italic
+%%DATADIR%%/Resource/Font/NimbusRoman-Regular
+%%DATADIR%%/Resource/Font/NimbusSans-Bold
+%%DATADIR%%/Resource/Font/NimbusSans-BoldItalic
+%%DATADIR%%/Resource/Font/NimbusSans-Italic
+%%DATADIR%%/Resource/Font/NimbusSans-Regular
+%%DATADIR%%/Resource/Font/NimbusSansNarrow-Bold
+%%DATADIR%%/Resource/Font/NimbusSansNarrow-BoldOblique
+%%DATADIR%%/Resource/Font/NimbusSansNarrow-Oblique
+%%DATADIR%%/Resource/Font/NimbusSansNarrow-Regular
+%%DATADIR%%/Resource/Font/P052-Bold
+%%DATADIR%%/Resource/Font/P052-BoldItalic
+%%DATADIR%%/Resource/Font/P052-Italic
+%%DATADIR%%/Resource/Font/P052-Roman
+%%DATADIR%%/Resource/Font/StandardSymbolsPS
+%%DATADIR%%/Resource/Font/URWBookman-Demi
+%%DATADIR%%/Resource/Font/URWBookman-DemiItalic
+%%DATADIR%%/Resource/Font/URWBookman-Light
+%%DATADIR%%/Resource/Font/URWBookman-LightItalic
+%%DATADIR%%/Resource/Font/URWGothic-Book
+%%DATADIR%%/Resource/Font/URWGothic-BookOblique
+%%DATADIR%%/Resource/Font/URWGothic-Demi
+%%DATADIR%%/Resource/Font/URWGothic-DemiOblique
+%%DATADIR%%/Resource/Font/Z003-MediumItalic
+%%DATADIR%%/Resource/IdiomSet/Pscript5Idiom
+%%DATADIR%%/Resource/IdiomSet/PPI_CUtils
+%%DATADIR%%/Resource/Init/FAPIcidfmap
+%%DATADIR%%/Resource/Init/FAPIconfig
+%%DATADIR%%/Resource/Init/FAPIfontmap
+%%DATADIR%%/Resource/Init/FCOfontmap-PCLPS2
+%%DATADIR%%/Resource/Init/Fontmap
+%%DATADIR%%/Resource/Init/Fontmap.GS
+%%DATADIR%%/Resource/Init/cidfmap
+%%DATADIR%%/Resource/Init/gs_agl.ps
+%%DATADIR%%/Resource/Init/gs_btokn.ps
+%%DATADIR%%/Resource/Init/gs_cet.ps
+%%DATADIR%%/Resource/Init/gs_cff.ps
+%%DATADIR%%/Resource/Init/gs_cidcm.ps
+%%DATADIR%%/Resource/Init/gs_ciddc.ps
+%%DATADIR%%/Resource/Init/gs_cidfm.ps
+%%DATADIR%%/Resource/Init/gs_cidfn.ps
+%%DATADIR%%/Resource/Init/gs_cidtt.ps
+%%DATADIR%%/Resource/Init/gs_cmap.ps
+%%DATADIR%%/Resource/Init/gs_cspace.ps
+%%DATADIR%%/Resource/Init/gs_dbt_e.ps
+%%DATADIR%%/Resource/Init/gs_diskn.ps
+%%DATADIR%%/Resource/Init/gs_dps1.ps
+%%DATADIR%%/Resource/Init/gs_dps2.ps
+%%DATADIR%%/Resource/Init/gs_dscp.ps
+%%DATADIR%%/Resource/Init/gs_epsf.ps
+%%DATADIR%%/Resource/Init/gs_fapi.ps
+%%DATADIR%%/Resource/Init/gs_fntem.ps
+%%DATADIR%%/Resource/Init/gs_fonts.ps
+%%DATADIR%%/Resource/Init/gs_frsd.ps
+%%DATADIR%%/Resource/Init/gs_icc.ps
+%%DATADIR%%/Resource/Init/gs_il1_e.ps
+%%DATADIR%%/Resource/Init/gs_img.ps
+%%DATADIR%%/Resource/Init/gs_init.ps
+%%DATADIR%%/Resource/Init/gs_lev2.ps
+%%DATADIR%%/Resource/Init/gs_ll3.ps
+%%DATADIR%%/Resource/Init/gs_mex_e.ps
+%%DATADIR%%/Resource/Init/gs_mgl_e.ps
+%%DATADIR%%/Resource/Init/gs_mro_e.ps
+%%DATADIR%%/Resource/Init/gs_pdf_e.ps
+%%DATADIR%%/Resource/Init/gs_pdfwr.ps
+%%DATADIR%%/Resource/Init/gs_res.ps
+%%DATADIR%%/Resource/Init/gs_resmp.ps
+%%DATADIR%%/Resource/Init/gs_setpd.ps
+%%DATADIR%%/Resource/Init/gs_statd.ps
+%%DATADIR%%/Resource/Init/gs_std_e.ps
+%%DATADIR%%/Resource/Init/gs_sym_e.ps
+%%DATADIR%%/Resource/Init/gs_trap.ps
+%%DATADIR%%/Resource/Init/gs_ttf.ps
+%%DATADIR%%/Resource/Init/gs_typ32.ps
+%%DATADIR%%/Resource/Init/gs_typ42.ps
+%%DATADIR%%/Resource/Init/gs_type1.ps
+%%DATADIR%%/Resource/Init/gs_wan_e.ps
+%%DATADIR%%/Resource/Init/pdf_base.ps
+%%DATADIR%%/Resource/Init/pdf_draw.ps
+%%DATADIR%%/Resource/Init/pdf_font.ps
+%%DATADIR%%/Resource/Init/pdf_main.ps
+%%DATADIR%%/Resource/Init/pdf_ops.ps
+%%DATADIR%%/Resource/Init/pdf_rbld.ps
+%%DATADIR%%/Resource/Init/pdf_sec.ps
+%%DATADIR%%/Resource/Init/xlatmap
+%%DATADIR%%/Resource/SubstCID/CNS1-WMode
+%%DATADIR%%/Resource/SubstCID/GB1-WMode
+%%DATADIR%%/Resource/SubstCID/Japan1-WMode
+%%DATADIR%%/Resource/SubstCID/Korea1-WMode
+%%DATADIR%%/iccprofiles
+%%DATADIR%%/lib/PDFA_def.ps
+%%DATADIR%%/lib/PDFX_def.ps
+%%DATADIR%%/lib/PM760p.upp
+%%DATADIR%%/lib/PM760pl.upp
+%%DATADIR%%/lib/PM820p.upp
+%%DATADIR%%/lib/PM820pl.upp
+%%DATADIR%%/lib/Stc670p.upp
+%%DATADIR%%/lib/Stc670pl.upp
+%%DATADIR%%/lib/Stc680p.upp
+%%DATADIR%%/lib/Stc680pl.upp
+%%DATADIR%%/lib/Stc740p.upp
+%%DATADIR%%/lib/Stc740pl.upp
+%%DATADIR%%/lib/Stc760p.upp
+%%DATADIR%%/lib/Stc760pl.upp
+%%DATADIR%%/lib/Stc777p.upp
+%%DATADIR%%/lib/Stc777pl.upp
+%%DATADIR%%/lib/Stp720p.upp
+%%DATADIR%%/lib/Stp720pl.upp
+%%DATADIR%%/lib/Stp870p.upp
+%%DATADIR%%/lib/Stp870pl.upp
+%%DATADIR%%/lib/acctest.ps
+%%DATADIR%%/lib/align.ps
+%%DATADIR%%/lib/bj8.rpd
+%%DATADIR%%/lib/bj8gc12f.upp
+%%DATADIR%%/lib/bj8hg12f.upp
+%%DATADIR%%/lib/bj8oh06n.upp
+%%DATADIR%%/lib/bj8pa06n.upp
+%%DATADIR%%/lib/bj8pp12f.upp
+%%DATADIR%%/lib/bj8ts06n.upp
+%%DATADIR%%/lib/bjc6000a1.upp
+%%DATADIR%%/lib/bjc6000b1.upp
+%%DATADIR%%/lib/bjc610a0.upp
+%%DATADIR%%/lib/bjc610a1.upp
+%%DATADIR%%/lib/bjc610a2.upp
+%%DATADIR%%/lib/bjc610a3.upp
+%%DATADIR%%/lib/bjc610a4.upp
+%%DATADIR%%/lib/bjc610a5.upp
+%%DATADIR%%/lib/bjc610a6.upp
+%%DATADIR%%/lib/bjc610a7.upp
+%%DATADIR%%/lib/bjc610a8.upp
+%%DATADIR%%/lib/bjc610b1.upp
+%%DATADIR%%/lib/bjc610b2.upp
+%%DATADIR%%/lib/bjc610b3.upp
+%%DATADIR%%/lib/bjc610b4.upp
+%%DATADIR%%/lib/bjc610b6.upp
+%%DATADIR%%/lib/bjc610b7.upp
+%%DATADIR%%/lib/bjc610b8.upp
+%%DATADIR%%/lib/caption.ps
+%%DATADIR%%/lib/cbjc600.ppd
+%%DATADIR%%/lib/cbjc800.ppd
+%%DATADIR%%/lib/cdj550.upp
+%%DATADIR%%/lib/cdj690.upp
+%%DATADIR%%/lib/cdj690ec.upp
+%%DATADIR%%/lib/cid2code.ps
+%%DATADIR%%/lib/dnj750c.upp
+%%DATADIR%%/lib/dnj750m.upp
+%%DATADIR%%/lib/docie.ps
+%%DATADIR%%/lib/font2pcl.ps
+%%DATADIR%%/lib/ghostpdf.ppd
+%%DATADIR%%/lib/gs_ce_e.ps
+%%DATADIR%%/lib/gs_css_e.ps
+%%DATADIR%%/lib/gs_il2_e.ps
+%%DATADIR%%/lib/gs_kanji.ps
+%%DATADIR%%/lib/gs_ksb_e.ps
+%%DATADIR%%/lib/gs_l.xbm
+%%DATADIR%%/lib/gs_l.xpm
+%%DATADIR%%/lib/gs_l_m.xbm
+%%DATADIR%%/lib/gs_lgo_e.ps
+%%DATADIR%%/lib/gs_lgx_e.ps
+%%DATADIR%%/lib/gs_m.xbm
+%%DATADIR%%/lib/gs_m.xpm
+%%DATADIR%%/lib/gs_m_m.xbm
+%%DATADIR%%/lib/gs_s.xbm
+%%DATADIR%%/lib/gs_s.xpm
+%%DATADIR%%/lib/gs_s_m.xbm
+%%DATADIR%%/lib/gs_t.xbm
+%%DATADIR%%/lib/gs_t.xpm
+%%DATADIR%%/lib/gs_t_m.xbm
+%%DATADIR%%/lib/gs_wl1_e.ps
+%%DATADIR%%/lib/gs_wl2_e.ps
+%%DATADIR%%/lib/gs_wl5_e.ps
+%%DATADIR%%/lib/gslp.ps
+%%DATADIR%%/lib/gsnup.ps
+%%DATADIR%%/lib/ht_ccsto.ps
+%%DATADIR%%/lib/image-qa.ps
+%%DATADIR%%/lib/jispaper.ps
+%%DATADIR%%/lib/landscap.ps
+%%DATADIR%%/lib/lines.ps
+%%DATADIR%%/lib/mkcidfm.ps
+%%DATADIR%%/lib/necp2x.upp
+%%DATADIR%%/lib/necp2x6.upp
+%%DATADIR%%/lib/pdf_info.ps
+%%DATADIR%%/lib/pdf2dsc.ps
+%%DATADIR%%/lib/pf2afm.ps
+%%DATADIR%%/lib/pfbtopfa.ps
+%%DATADIR%%/lib/ppath.ps
+%%DATADIR%%/lib/pphs.ps
+%%DATADIR%%/lib/prfont.ps
+%%DATADIR%%/lib/printafm.ps
+%%DATADIR%%/lib/ps2ai.ps
+%%DATADIR%%/lib/ps2epsi.ps
+%%DATADIR%%/lib/ras1.upp
+%%DATADIR%%/lib/ras24.upp
+%%DATADIR%%/lib/ras3.upp
+%%DATADIR%%/lib/ras32.upp
+%%DATADIR%%/lib/ras4.upp
+%%DATADIR%%/lib/ras8m.upp
+%%DATADIR%%/lib/rollconv.ps
+%%DATADIR%%/lib/s400a1.upp
+%%DATADIR%%/lib/s400b1.upp
+%%DATADIR%%/lib/sharp.upp
+%%DATADIR%%/lib/sipixa6.upp
+%%DATADIR%%/lib/st640ih.upp
+%%DATADIR%%/lib/st640ihg.upp
+%%DATADIR%%/lib/st640p.upp
+%%DATADIR%%/lib/st640pg.upp
+%%DATADIR%%/lib/st640pl.upp
+%%DATADIR%%/lib/st640plg.upp
+%%DATADIR%%/lib/stc.upp
+%%DATADIR%%/lib/stc1520h.upp
+%%DATADIR%%/lib/stc2.upp
+%%DATADIR%%/lib/stc200_h.upp
+%%DATADIR%%/lib/stc2_h.upp
+%%DATADIR%%/lib/stc2s_h.upp
+%%DATADIR%%/lib/stc300.upp
+%%DATADIR%%/lib/stc300bl.upp
+%%DATADIR%%/lib/stc300bm.upp
+%%DATADIR%%/lib/stc500p.upp
+%%DATADIR%%/lib/stc500ph.upp
+%%DATADIR%%/lib/stc600ih.upp
+%%DATADIR%%/lib/stc600p.upp
+%%DATADIR%%/lib/stc600pl.upp
+%%DATADIR%%/lib/stc640p.upp
+%%DATADIR%%/lib/stc740ih.upp
+%%DATADIR%%/lib/stc800ih.upp
+%%DATADIR%%/lib/stc800p.upp
+%%DATADIR%%/lib/stc800pl.upp
+%%DATADIR%%/lib/stc_h.upp
+%%DATADIR%%/lib/stc_l.upp
+%%DATADIR%%/lib/stcany.upp
+%%DATADIR%%/lib/stcany_h.upp
+%%DATADIR%%/lib/stcinfo.ps
+%%DATADIR%%/lib/stcolor.ps
+%%DATADIR%%/lib/stocht.ps
+%%DATADIR%%/lib/traceimg.ps
+%%DATADIR%%/lib/traceop.ps
+%%DATADIR%%/lib/uninfo.ps
+%%DATADIR%%/lib/viewcmyk.ps
+%%DATADIR%%/lib/viewgif.ps
+%%DATADIR%%/lib/viewjpeg.ps
+%%DATADIR%%/lib/viewmiff.ps
+%%DATADIR%%/lib/viewpbm.ps
+%%DATADIR%%/lib/viewpcx.ps
+%%DATADIR%%/lib/viewps2a.ps
+%%DATADIR%%/lib/winmaps.ps
+%%DATADIR%%/lib/zeroline.ps