aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-08-23 05:57:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-08-23 06:09:02 +0000
commit76d1dd518eb6ddb6404872e3d74ab222ad1045aa (patch)
treebb7c8ed456ba14ead0afa6d5efe29f938fd7a6cf /science
parent59574ee10098c85b9fba6a8e43afa51b0ba127e2 (diff)
downloadports-76d1dd518eb6ddb6404872e3d74ab222ad1045aa.tar.gz
ports-76d1dd518eb6ddb6404872e3d74ab222ad1045aa.zip
science/cantera: update 2.6.0 → 3.0.0
Reported by: portscout
Diffstat (limited to 'science')
-rw-r--r--science/cantera/Makefile19
-rw-r--r--science/cantera/distinfo6
-rw-r--r--science/cantera/files/patch-SConstruct51
-rw-r--r--science/cantera/files/patch-platform_posix_SConscript11
-rw-r--r--science/cantera/files/patch-src_matlab_SConscript4
-rw-r--r--science/cantera/pkg-plist126
6 files changed, 95 insertions, 122 deletions
diff --git a/science/cantera/Makefile b/science/cantera/Makefile
index b85c41e74d4f..c25ad53ef304 100644
--- a/science/cantera/Makefile
+++ b/science/cantera/Makefile
@@ -1,7 +1,6 @@
PORTNAME= cantera
DISTVERSIONPREFIX= v
-DISTVERSION= 2.6.0
-PORTREVISION= 3
+DISTVERSION= 3.0.0
CATEGORIES= science # chemistry physics
MAINTAINER= yuri@FreeBSD.org
@@ -12,11 +11,14 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/License.txt
BUILD_DEPENDS= googletest>0:devel/googletest \
- ${LOCALBASE}/include/boost/algorithm/string.hpp:devel/boost-libs
+ ${LOCALBASE}/include/boost/algorithm/string.hpp:devel/boost-libs \
+ highfive>0:science/highfive
LIB_DEPENDS= libfmt.so:devel/libfmt \
+ libhdf5.so:science/hdf5 \
+ libopenblas.so:math/openblas \
libyaml-cpp.so:devel/yaml-cpp
-USES= compiler:c++11-lang eigen:3 localbase scons
+USES= compiler:c++17-lang eigen:3 localbase scons
USE_LDCONFIG= yes
USE_GITHUB= yes
@@ -34,12 +36,13 @@ MAKE_ARGS= system_eigen='y' \
debug='no' \
cc_flags="${CXXFLAGS}" \
prefix="${PREFIX}"
+MAKE_ENV= INSTALL_MANPAGES=y
ALL_TARGET= build
TEST_TARGET= test # some tests fail, see https://github.com/Cantera/cantera/issues/1095
OPTIONS_DEFINE= OCTAVE PYTHON
-OPTIONS_DEFAULT= # PYTHON is broken; OCTAVE is off by default because Octave interface is not as frequently requested feature
+OPTIONS_DEFAULT= # PYTHON is broken; OCTAVE is off by default because Octave interface is not a frequently requested feature
OPTIONS_SUB= yes
OCTAVE_DESC= Octave support
@@ -48,6 +51,7 @@ OCTAVE_CXXFLAGS= -I${LOCALBASE}/include/octave-${OCTAVE_VERSION}/octave
OCTAVE_LIB_DEPENDS= liboctave.so:math/octave
OCTAVE_SUB_FILES= pkg-message-octave
OCTAVE_USES= octave:env
+OCTAVE_BROKEN= Octave support needs to be updated
PYTHON_USES= python
PYTHON_USE= PYTHON=cython
@@ -60,15 +64,16 @@ PYTHON_RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ruamel.yaml>0:devel/py-ruamel.yaml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scipy>0:science/py-scipy@${PY_FLAVOR}
-PYTHON_BROKEN= https://github.com/Cantera/cantera/issues/1269
+PYTHON_BROKEN= https://github.com/Cantera/cantera/issues/1601
do-install:
cd ${WRKSRC} && \
${MAKE_CMD} install \
stage_dir="${STAGEDIR}"
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcantera_shared.so.2.6.0
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcantera_shared.so.${PORTVERSION}
do-install-PYTHON-on:
+ # strip
@${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cantera/_cantera.cpython-${PYTHON_SUFFIX}.so
post-patch-OCTAVE-on: # adjust Octave version in SConscript (python styled os.environ['OCTAVE_VERSION'] somehow doesn't work for this)
diff --git a/science/cantera/distinfo b/science/cantera/distinfo
index cee52c83d2f5..4fa9a5607568 100644
--- a/science/cantera/distinfo
+++ b/science/cantera/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1651506700
-SHA256 (Cantera-cantera-v2.6.0_GH0.tar.gz) = 7273622ea76a53373cee820f939613b15eea3dd83db6e1b127c5ed043f77dc5b
-SIZE (Cantera-cantera-v2.6.0_GH0.tar.gz) = 2586243
+TIMESTAMP = 1692765950
+SHA256 (Cantera-cantera-v3.0.0_GH0.tar.gz) = 6d17cdef21dae9deaf91351260b68ccf7e264c37c6030c9d4bf26a2cefb2b905
+SIZE (Cantera-cantera-v3.0.0_GH0.tar.gz) = 2451103
SHA256 (LLNL-sundials-887af43_GH0.tar.gz) = 147919c4887c93157c9975f195e8d45903285b61303d42f9dfdee251468abdb7
SIZE (LLNL-sundials-887af43_GH0.tar.gz) = 18888776
diff --git a/science/cantera/files/patch-SConstruct b/science/cantera/files/patch-SConstruct
index cbccdcef24f3..1220b2aedf5c 100644
--- a/science/cantera/files/patch-SConstruct
+++ b/science/cantera/files/patch-SConstruct
@@ -1,17 +1,18 @@
- the first part is fixing the configure failure, see https://github.com/Cantera/cantera/issues/1536
---- SConstruct.orig 2022-05-01 15:31:54 UTC
+--- SConstruct.orig 2023-08-22 21:34:46 UTC
+++ SConstruct
-@@ -191,7 +191,7 @@ config_options = [
- {
- "cl": "/EHsc",
- "Cygwin": "-std=gnu++11", # See http://stackoverflow.com/questions/18784112
-- "default": "-std=c++11"
-+ "default": "-std=c++14"
- }),
- Option(
- "CC",
-@@ -805,6 +805,9 @@ elif "icx" in env.subst("$CC"):
+@@ -846,6 +846,9 @@ if os.name == "nt":
+ for key,val in env["ENV"].items():
+ env["ENV"][key] = str(val)
+
++elif "cc" in env.subst("$CC"):
++ config.select("clang")
++
+ else:
+ env["INSTALL_MANPAGES"] = True
+
+@@ -880,6 +883,9 @@ elif "icx" in env.subst("$CC"):
elif "clang" in env.subst("$CC"):
config.select("clang")
@@ -19,36 +20,38 @@
+ config.select("clang")
+
else:
- print(f"WARNING: Unrecognized C compiler '{env['CC']}'")
-
-@@ -869,10 +872,10 @@ if "sdist" in COMMAND_LINE_TARGETS:
+ logger.error(f"Unrecognized C compiler {env['CC']!r}")
+ sys.exit(1)
+@@ -945,10 +951,10 @@ if "sdist" in COMMAND_LINE_TARGETS:
logger.info("'sdist' target was specified. Setting 'use_pch' to False.")
env["use_pch"] = False
-for arg in ARGUMENTS:
- if arg not in config:
-- logger.error(f"Encountered unexpected command line option: '{arg}'")
+- logger.error(f"Encountered unexpected command line option: {arg!r}")
- sys.exit(1)
+#for arg in ARGUMENTS:
+# if arg not in config:
-+# logger.error(f"Encountered unexpected command line option: '{arg}'")
++# logger.error(f"Encountered unexpected command line option: {arg!r}")
+# sys.exit(1)
- env["cantera_version"] = "2.6.0"
+ env["cantera_version"] = "3.0.0"
# For use where pre-release tags are not permitted (MSI, sonames)
-@@ -1673,11 +1676,11 @@ if env["matlab_toolbox"] == "y":
+@@ -2002,12 +2008,12 @@ if env["matlab_toolbox"] == "y":
"SUNDIALS libraries and skip building the Matlab toolbox.")
sys.exit(1)
-- if not (os.path.isdir(matlab_path) and
-- os.path.isdir(pjoin(matlab_path, "extern"))):
+- matlab_path = Path(matlab_path)
+- env["matlab_path"] = matlab_path.as_posix()
+- if not matlab_path.is_dir() and (matlab_path / "extern").is_dir():
- logger.error(
-- f"Path set for 'matlab_path' is not correct. Path was '{matlab_path}'")
+- f"Path set for 'matlab_path' is not correct. Path was {matlab_path!r}")
- sys.exit(1)
-+ #if not (os.path.isdir(matlab_path) and
-+ # os.path.isdir(pjoin(matlab_path, "extern"))):
++ #matlab_path = Path(matlab_path)
++ #env["matlab_path"] = matlab_path.as_posix()
++ #if not matlab_path.is_dir() and (matlab_path / "extern").is_dir():
+ # logger.error(
-+ # f"Path set for 'matlab_path' is not correct. Path was '{matlab_path}'")
++ # f"Path set for 'matlab_path' is not correct. Path was {matlab_path!r}")
+ # sys.exit(1)
diff --git a/science/cantera/files/patch-platform_posix_SConscript b/science/cantera/files/patch-platform_posix_SConscript
new file mode 100644
index 000000000000..e3578795504e
--- /dev/null
+++ b/science/cantera/files/patch-platform_posix_SConscript
@@ -0,0 +1,11 @@
+--- platform/posix/SConscript.orig 2023-08-23 04:54:38 UTC
++++ platform/posix/SConscript
+@@ -6,7 +6,7 @@ Import('env', 'build', 'install')
+ localenv = env.Clone()
+
+ # Copy man pages
+-if env['INSTALL_MANPAGES']:
++if True or env['INSTALL_MANPAGES']:
+ install('$inst_mandir', multi_glob(localenv, '#platform/posix/man', '*'))
+
+ ### Generate customized scripts ###
diff --git a/science/cantera/files/patch-src_matlab_SConscript b/science/cantera/files/patch-src_matlab_SConscript
index 300ee07c6df6..c192ea9fb1b7 100644
--- a/science/cantera/files/patch-src_matlab_SConscript
+++ b/science/cantera/files/patch-src_matlab_SConscript
@@ -1,6 +1,6 @@
---- src/matlab/SConscript.orig 2022-05-01 15:31:54 UTC
+--- src/matlab/SConscript.orig 2023-08-22 21:34:46 UTC
+++ src/matlab/SConscript
-@@ -42,7 +42,7 @@ elif localenv['OS'] == 'Darwin':
+@@ -48,7 +48,7 @@ elif localenv['OS'] == 'Darwin':
elif os.name == 'posix':
linklibs = list(env['cantera_libs'])
diff --git a/science/cantera/pkg-plist b/science/cantera/pkg-plist
index a5aecda50a5f..a48fdd351667 100644
--- a/science/cantera/pkg-plist
+++ b/science/cantera/pkg-plist
@@ -3,17 +3,19 @@
%%PYTHON%%bin/cti2yaml
%%PYTHON%%bin/ctml2yaml
%%PYTHON%%bin/ctml_writer
-bin/setup_cantera
-bin/setup_cantera.csh
-include/cantera/Cantera.mak
include/cantera/base/AnyMap.h
include/cantera/base/AnyMap.inl.h
include/cantera/base/Array.h
include/cantera/base/Delegator.h
+include/cantera/base/ExtensionManager.h
+include/cantera/base/ExtensionManagerFactory.h
+include/cantera/base/ExternalLogger.h
include/cantera/base/FactoryBase.h
include/cantera/base/Interface.h
include/cantera/base/NoExitLogger.h
include/cantera/base/Solution.h
+include/cantera/base/SolutionArray.h
+include/cantera/base/Storage.h
include/cantera/base/Units.h
include/cantera/base/ValueCache.h
include/cantera/base/YamlWriter.h
@@ -22,14 +24,11 @@ include/cantera/base/config.h
include/cantera/base/config.h.in
include/cantera/base/ct_defs.h
include/cantera/base/ctexceptions.h
-include/cantera/base/ctml.h
include/cantera/base/fmt.h
include/cantera/base/global.h
include/cantera/base/logger.h
-include/cantera/base/plots.h
include/cantera/base/stringUtils.h
include/cantera/base/utilities.h
-include/cantera/base/xml.h
include/cantera/base/yaml.h
include/cantera/clib/clib_defs.h
include/cantera/clib/ct.h
@@ -40,8 +39,12 @@ include/cantera/clib/ctonedim.h
include/cantera/clib/ctreactor.h
include/cantera/clib/ctrpath.h
include/cantera/clib/ctsurf.h
-include/cantera/clib/ctxml.h
+include/cantera/core.h
include/cantera/cython/funcWrapper.h
+include/cantera/cython/kinetics_utils.h
+include/cantera/cython/thermo_utils.h
+include/cantera/cython/transport_utils.h
+include/cantera/cython/utils_utils.h
include/cantera/cython/wrappers.h
include/cantera/equil/ChemEquil.h
include/cantera/equil/MultiPhase.h
@@ -60,11 +63,11 @@ include/cantera/ext/cvodes/cvodes_diag.h
include/cantera/ext/cvodes/cvodes_direct.h
include/cantera/ext/cvodes/cvodes_ls.h
include/cantera/ext/cvodes/cvodes_spils.h
-include/cantera/ext/ida/ida.h
-include/cantera/ext/ida/ida_bbdpre.h
-include/cantera/ext/ida/ida_direct.h
-include/cantera/ext/ida/ida_ls.h
-include/cantera/ext/ida/ida_spils.h
+include/cantera/ext/idas/idas.h
+include/cantera/ext/idas/idas_bbdpre.h
+include/cantera/ext/idas/idas_direct.h
+include/cantera/ext/idas/idas_ls.h
+include/cantera/ext/idas/idas_spils.h
include/cantera/ext/nvector/nvector_cuda.h
include/cantera/ext/nvector/nvector_manyvector.h
include/cantera/ext/nvector/nvector_mpimanyvector.h
@@ -116,6 +119,8 @@ include/cantera/ext/sunmatrix/sunmatrix_sparse.h
include/cantera/ext/sunnonlinsol/sunnonlinsol_fixedpoint.h
include/cantera/ext/sunnonlinsol/sunnonlinsol_newton.h
include/cantera/ext/sunnonlinsol/sunnonlinsol_petscsnes.h
+include/cantera/extensions/PythonExtensionManager.h
+include/cantera/extensions/PythonHandle.h
include/cantera/kinetics.h
include/cantera/kinetics/Arrhenius.h
include/cantera/kinetics/BlowersMaselRate.h
@@ -124,8 +129,6 @@ include/cantera/kinetics/ChebyshevRate.h
include/cantera/kinetics/Custom.h
include/cantera/kinetics/EdgeKinetics.h
include/cantera/kinetics/Falloff.h
-include/cantera/kinetics/FalloffFactory.h
-include/cantera/kinetics/FalloffMgr.h
include/cantera/kinetics/GasKinetics.h
include/cantera/kinetics/Group.h
include/cantera/kinetics/ImplicitSurfChem.h
@@ -136,28 +139,28 @@ include/cantera/kinetics/KineticsFactory.h
include/cantera/kinetics/MultiRate.h
include/cantera/kinetics/MultiRateBase.h
include/cantera/kinetics/PlogRate.h
-include/cantera/kinetics/RateCoeffMgr.h
include/cantera/kinetics/Reaction.h
include/cantera/kinetics/ReactionData.h
include/cantera/kinetics/ReactionPath.h
include/cantera/kinetics/ReactionRate.h
+include/cantera/kinetics/ReactionRateDelegator.h
include/cantera/kinetics/ReactionRateFactory.h
-include/cantera/kinetics/RxnRates.h
include/cantera/kinetics/StoichManager.h
include/cantera/kinetics/ThirdBodyCalc.h
include/cantera/kinetics/TwoTempPlasmaRate.h
-include/cantera/kinetics/importKinetics.h
-include/cantera/kinetics/reaction_defs.h
include/cantera/kinetics/solveSP.h
+include/cantera/numerics/AdaptivePreconditioner.h
include/cantera/numerics/BandMatrix.h
include/cantera/numerics/CVodesIntegrator.h
-include/cantera/numerics/DAE_Solver.h
include/cantera/numerics/DenseMatrix.h
include/cantera/numerics/Func1.h
+include/cantera/numerics/Func1Factory.h
include/cantera/numerics/FuncEval.h
include/cantera/numerics/GeneralMatrix.h
-include/cantera/numerics/IDA_Solver.h
+include/cantera/numerics/IdasIntegrator.h
include/cantera/numerics/Integrator.h
+include/cantera/numerics/PreconditionerBase.h
+include/cantera/numerics/PreconditionerFactory.h
include/cantera/numerics/ResidEval.h
include/cantera/numerics/ResidJacEval.h
include/cantera/numerics/SundialsContext.h
@@ -166,9 +169,10 @@ include/cantera/numerics/eigen_dense.h
include/cantera/numerics/eigen_sparse.h
include/cantera/numerics/funcs.h
include/cantera/numerics/polyfit.h
+include/cantera/numerics/sundials_headers.h
include/cantera/oneD/Boundary1D.h
include/cantera/oneD/Domain1D.h
-include/cantera/oneD/Inlet1D.h
+include/cantera/oneD/DomainFactory.h
include/cantera/oneD/IonFlow.h
include/cantera/oneD/MultiJac.h
include/cantera/oneD/MultiNewton.h
@@ -182,6 +186,7 @@ include/cantera/test/gtest_utils.h
include/cantera/thermo.h
include/cantera/thermo/BinarySolutionTabulatedThermo.h
include/cantera/thermo/ConstCpPoly.h
+include/cantera/thermo/CoverageDependentSurfPhase.h
include/cantera/thermo/DebyeHuckel.h
include/cantera/thermo/EdgePhase.h
include/cantera/thermo/Elements.h
@@ -244,17 +249,22 @@ include/cantera/transport/HighPressureGasTransport.h
include/cantera/transport/IonGasTransport.h
include/cantera/transport/MixTransport.h
include/cantera/transport/MultiTransport.h
+include/cantera/transport/Transport.h
include/cantera/transport/TransportBase.h
include/cantera/transport/TransportData.h
include/cantera/transport/TransportFactory.h
include/cantera/transport/UnityLewisTransport.h
include/cantera/transport/WaterTransport.h
+include/cantera/zeroD/ConstPressureMoleReactor.h
include/cantera/zeroD/ConstPressureReactor.h
include/cantera/zeroD/FlowDevice.h
include/cantera/zeroD/FlowDeviceFactory.h
include/cantera/zeroD/FlowReactor.h
+include/cantera/zeroD/IdealGasConstPressureMoleReactor.h
include/cantera/zeroD/IdealGasConstPressureReactor.h
+include/cantera/zeroD/IdealGasMoleReactor.h
include/cantera/zeroD/IdealGasReactor.h
+include/cantera/zeroD/MoleReactor.h
include/cantera/zeroD/Reactor.h
include/cantera/zeroD/ReactorBase.h
include/cantera/zeroD/ReactorDelegator.h
@@ -607,8 +617,8 @@ include/cantera/zerodim.h
%%OCTAVE%%lib/cantera/matlab/toolbox/useLegacyRateConstants.m
lib/libcantera.a
lib/libcantera_shared.so
-lib/libcantera_shared.so.2
-lib/libcantera_shared.so.2.6.0
+lib/libcantera_shared.so.3
+lib/libcantera_shared.so.3.0.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/Cantera-2.6.0a3-py%%PYTHON_VER%%.egg-info/PKG-INFO
%%PYTHON%%%%PYTHON_SITELIBDIR%%/Cantera-2.6.0a3-py%%PYTHON_VER%%.egg-info/SOURCES.txt
%%PYTHON%%%%PYTHON_SITELIBDIR%%/Cantera-2.6.0a3-py%%PYTHON_VER%%.egg-info/dependency_links.txt
@@ -984,124 +994,69 @@ lib/libcantera_shared.so.2.6.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/cantera/test/utilities.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/cantera/utils.py
libdata/pkgconfig/cantera.pc
-%%DATADIR%%/data/KOH.cti
-%%DATADIR%%/data/KOH.xml
%%DATADIR%%/data/KOH.yaml
-%%DATADIR%%/data/air.cti
-%%DATADIR%%/data/air.xml
+%%DATADIR%%/data/SiF4_NH3_mec.yaml
+%%DATADIR%%/data/YZA.yaml
%%DATADIR%%/data/air.yaml
-%%DATADIR%%/data/airNASA9.cti
-%%DATADIR%%/data/airNASA9.xml
%%DATADIR%%/data/airNASA9.yaml
-%%DATADIR%%/data/argon.cti
-%%DATADIR%%/data/argon.xml
+%%DATADIR%%/data/covdepsurf.yaml
%%DATADIR%%/data/critical-properties.yaml
-%%DATADIR%%/data/diamond.cti
-%%DATADIR%%/data/diamond.xml
%%DATADIR%%/data/diamond.yaml
%%DATADIR%%/data/element-standard-entropies.yaml
-%%DATADIR%%/data/elements.xml
-%%DATADIR%%/data/graphite.cti
-%%DATADIR%%/data/graphite.xml
%%DATADIR%%/data/graphite.yaml
-%%DATADIR%%/data/gri30.cti
-%%DATADIR%%/data/gri30.xml
%%DATADIR%%/data/gri30.yaml
-%%DATADIR%%/data/gri30_highT.cti
-%%DATADIR%%/data/gri30_highT.xml
%%DATADIR%%/data/gri30_highT.yaml
-%%DATADIR%%/data/gri30_ion.cti
-%%DATADIR%%/data/gri30_ion.xml
%%DATADIR%%/data/gri30_ion.yaml
-%%DATADIR%%/data/h2o2.cti
-%%DATADIR%%/data/h2o2.xml
%%DATADIR%%/data/h2o2.yaml
-%%DATADIR%%/data/liquidvapor.cti
-%%DATADIR%%/data/liquidvapor.xml
%%DATADIR%%/data/liquidvapor.yaml
-%%DATADIR%%/data/lithium_ion_battery.cti
-%%DATADIR%%/data/lithium_ion_battery.xml
%%DATADIR%%/data/lithium_ion_battery.yaml
-%%DATADIR%%/data/methane_pox_on_pt.cti
-%%DATADIR%%/data/methane_pox_on_pt.xml
%%DATADIR%%/data/methane_pox_on_pt.yaml
-%%DATADIR%%/data/nDodecane_Reitz.cti
-%%DATADIR%%/data/nDodecane_Reitz.xml
%%DATADIR%%/data/nDodecane_Reitz.yaml
-%%DATADIR%%/data/nasa.cti
-%%DATADIR%%/data/nasa.xml
-%%DATADIR%%/data/nasa_condensed.cti
-%%DATADIR%%/data/nasa_condensed.xml
%%DATADIR%%/data/nasa_condensed.yaml
-%%DATADIR%%/data/nasa_gas.cti
-%%DATADIR%%/data/nasa_gas.xml
%%DATADIR%%/data/nasa_gas.yaml
-%%DATADIR%%/data/ohn.cti
-%%DATADIR%%/data/ohn.xml
%%DATADIR%%/data/ohn.yaml
-%%DATADIR%%/data/ptcombust.cti
-%%DATADIR%%/data/ptcombust.xml
%%DATADIR%%/data/ptcombust.yaml
-%%DATADIR%%/data/silane.cti
-%%DATADIR%%/data/silane.xml
-%%DATADIR%%/data/silane.yaml
-%%DATADIR%%/data/silicon.cti
-%%DATADIR%%/data/silicon.xml
%%DATADIR%%/data/silicon.yaml
-%%DATADIR%%/data/silicon_carbide.cti
-%%DATADIR%%/data/silicon_carbide.xml
%%DATADIR%%/data/silicon_carbide.yaml
-%%DATADIR%%/data/sofc.cti
-%%DATADIR%%/data/sofc.xml
%%DATADIR%%/data/sofc.yaml
-%%DATADIR%%/data/water.cti
-%%DATADIR%%/data/water.xml
%%DATADIR%%/data/water.yaml
%%DATADIR%%/doc/LICENSE.txt
+%%DATADIR%%/samples/clib/CMakeLists.txt
+%%DATADIR%%/samples/clib/SConstruct
+%%DATADIR%%/samples/clib/demo.c
%%DATADIR%%/samples/cxx/LiC6_electrode/CMakeLists.txt
%%DATADIR%%/samples/cxx/LiC6_electrode/LiC6_electrode.cpp
-%%DATADIR%%/samples/cxx/LiC6_electrode/Makefile
%%DATADIR%%/samples/cxx/LiC6_electrode/SConstruct
%%DATADIR%%/samples/cxx/bvp/BoundaryValueProblem.h
%%DATADIR%%/samples/cxx/bvp/CMakeLists.txt
-%%DATADIR%%/samples/cxx/bvp/Makefile
%%DATADIR%%/samples/cxx/bvp/SConstruct
%%DATADIR%%/samples/cxx/bvp/blasius.cpp
%%DATADIR%%/samples/cxx/combustor/CMakeLists.txt
-%%DATADIR%%/samples/cxx/combustor/Makefile
%%DATADIR%%/samples/cxx/combustor/SConstruct
%%DATADIR%%/samples/cxx/combustor/combustor.cpp
%%DATADIR%%/samples/cxx/custom/CMakeLists.txt
-%%DATADIR%%/samples/cxx/custom/Makefile
%%DATADIR%%/samples/cxx/custom/SConstruct
%%DATADIR%%/samples/cxx/custom/custom.cpp
%%DATADIR%%/samples/cxx/demo/CMakeLists.txt
-%%DATADIR%%/samples/cxx/demo/Makefile
%%DATADIR%%/samples/cxx/demo/SConstruct
%%DATADIR%%/samples/cxx/demo/demo.cpp
%%DATADIR%%/samples/cxx/flamespeed/CMakeLists.txt
-%%DATADIR%%/samples/cxx/flamespeed/Makefile
%%DATADIR%%/samples/cxx/flamespeed/SConstruct
%%DATADIR%%/samples/cxx/flamespeed/flamespeed.cpp
%%DATADIR%%/samples/cxx/gas_transport/CMakeLists.txt
-%%DATADIR%%/samples/cxx/gas_transport/Makefile
%%DATADIR%%/samples/cxx/gas_transport/SConstruct
%%DATADIR%%/samples/cxx/gas_transport/gas_transport.cpp
%%DATADIR%%/samples/cxx/jacobian/CMakeLists.txt
-%%DATADIR%%/samples/cxx/jacobian/Makefile
%%DATADIR%%/samples/cxx/jacobian/SConstruct
%%DATADIR%%/samples/cxx/jacobian/derivative_speed.cpp
%%DATADIR%%/samples/cxx/kinetics1/CMakeLists.txt
-%%DATADIR%%/samples/cxx/kinetics1/Makefile
%%DATADIR%%/samples/cxx/kinetics1/SConstruct
%%DATADIR%%/samples/cxx/kinetics1/example_utils.h
%%DATADIR%%/samples/cxx/kinetics1/kinetics1.cpp
%%DATADIR%%/samples/cxx/openmp_ignition/CMakeLists.txt
-%%DATADIR%%/samples/cxx/openmp_ignition/Makefile
%%DATADIR%%/samples/cxx/openmp_ignition/SConstruct
%%DATADIR%%/samples/cxx/openmp_ignition/openmp_ignition.cpp
%%DATADIR%%/samples/cxx/rankine/CMakeLists.txt
-%%DATADIR%%/samples/cxx/rankine/Makefile
%%DATADIR%%/samples/cxx/rankine/SConstruct
%%DATADIR%%/samples/cxx/rankine/rankine.cpp
%%OCTAVE%%%%DATADIR%%/samples/matlab/PFR_solver.m
@@ -1135,8 +1090,7 @@ libdata/pkgconfig/cantera.pc
%%OCTAVE%%%%DATADIR%%/samples/matlab/tut5.m
%%OCTAVE%%%%DATADIR%%/samples/matlab/tut6.m
%%OCTAVE%%%%DATADIR%%/samples/matlab/tut7.m
-share/man/man1/ck2cti.1.gz
share/man/man1/ck2yaml.1.gz
share/man/man1/cti2yaml.1.gz
share/man/man1/ctml2yaml.1.gz
-share/man/man1/ctml_writer.1.gz
+share/man/man1/yaml2ck.1.gz