aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2023-10-31 22:07:56 +0000
committerRenato Botelho <garga@FreeBSD.org>2023-11-01 12:08:44 +0000
commit005d8c15b8027330dd27d66caaf97dc8a85f034a (patch)
tree7c2f57f7bb72e777e7ab15b4129413d66b9591d7 /security
parent36d4fac554c8179ed617724ea6c1c80921f4d788 (diff)
downloadports-005d8c15b8027330dd27d66caaf97dc8a85f034a.tar.gz
ports-005d8c15b8027330dd27d66caaf97dc8a85f034a.zip
security/sudo: Fix build with openssl from ports
Since SSL support is being changed and sudo can be built without it, add a new SSL option, on by default. When option is enabled, use --enable-openssl=${OPENSSLBASE} to make sure it consumes desired OpenSSL implementation. Also add pkgconfig dependency because configure script rely on it to detect openssl details. PR: 274753 Reported by: tburns@hrsd.com Sponsored by: Rubicon Communications, LLC ("Netgate") (cherry picked from commit dbc4e4daf752173acb868fc595ae9fa42f972aef)
Diffstat (limited to 'security')
-rw-r--r--security/sudo/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/sudo/Makefile b/security/sudo/Makefile
index 35419c29ad14..c3267fce9a29 100644
--- a/security/sudo/Makefile
+++ b/security/sudo/Makefile
@@ -1,5 +1,6 @@
PORTNAME= sudo
PORTVERSION= 1.9.14p3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= SUDO
@@ -12,7 +13,7 @@ LICENSE_NAME= Sudo license
LICENSE_FILE= ${WRKSRC}/LICENSE.md
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
-USES= cpe libtool
+USES= cpe libtool pkgconfig
CPE_VENDOR= todd_miller
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
@@ -29,8 +30,8 @@ LDFLAGS+= -lgcc
PORTSCOUT= ignore:1
OPTIONS_DEFINE= AUDIT DISABLE_AUTH DISABLE_ROOT_SUDO DOCS EXAMPLES \
- INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON
-OPTIONS_DEFAULT= AUDIT PAM
+ INSULTS LDAP NLS NOARGS_SHELL OPIE PAM PYTHON SSL
+OPTIONS_DEFAULT= AUDIT PAM SSL
OPTIONS_RADIO= KERBEROS SSSD
OPTIONS_RADIO_KERBEROS= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
OPTIONS_RADIO_SSSD= SSSD SSSD_DEVEL
@@ -44,6 +45,7 @@ KERBEROS_DESC= Enable Kerberos 5 authentication (no PAM support)
NOARGS_SHELL_DESC= Run a shell if no arguments are given
OPIE_DESC= Enable one-time passwords (no PAM support)
PYTHON_DESC= Enable python plugin support
+SSL_DESC= Use OpenSSL TLS and SHA2 functions
SSSD_DESC= Enable SSSD backend support.
SSSD_DEVEL_DESC= Enable SSSD-devel backend support.
@@ -81,6 +83,9 @@ PAM_CONFIGURE_ON= --with-pam
PYTHON_USES= python
PYTHON_CONFIGURE_ENABLE=python
+SSL_USES= ssl
+SSL_CONFIGURE_ON= --enable-openssl=${OPENSSLBASE}
+
SSSD_RUN_DEPENDS= sssd:security/sssd
SSSD_CONFIGURE_ON= --with-sssd