aboutsummaryrefslogtreecommitdiff
path: root/shells
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2023-06-07 15:52:22 +0000
committerCy Schubert <cy@FreeBSD.org>2023-06-07 15:52:22 +0000
commit141cb5d09e5f712300a3b16527afd91ce4a73341 (patch)
treea2d02df1104673c24d0adf71d395806c80e90e46 /shells
parent5948df8b32c3c507a0960f14e646d9d0d484da68 (diff)
downloadports-141cb5d09e5f712300a3b16527afd91ce4a73341.tar.gz
ports-141cb5d09e5f712300a3b16527afd91ce4a73341.zip
shells/ksh: Update 1.0.4 --> 1.0.5
The release email outlined the following changes: This release has a large amount of bugfixes compared to 93u+m/1.0.4. In summary: - Fixed various bugs causing crashes. - Fixed many bugs in the emacs and vi line editors, in command completion, and in file name completion. - Fixed various bugs in the handling of quotes, backslash escapes and braces when processing shell glob patterns (e.g. in pathname expansion and 'case'). - ksh now throws a panic and exits if a read error (such as an I/O error) occurs while trying to read the next command(s) from a running script. - Fixed many bugs in 'printf' and 'print -f' built-in commands, including: . Multiple bugs causing incorrect output for relative date specifications, e.g., printf %T\\n 'exactly 20 months ago' now outputs a correct result. . More printf bugs with mix and match of % and %x$. . A data corruption bug when using %B with 'printf -v varname'. . A bug causing double evaluation of arithmetic expressions. - Fixed a bug where 'unset -f commandname', executed in a subshell, hides any built-in command by the same name for the duration of that subshell. - Fixed ${var/#/string} and ${var/%/string} (with anchored empty pattern) to work as on mksh, bash and zsh; these are no longer ineffective. - Fixed incorrect result of array slicing ${array[@]:offset:length} where 'length' is a nested expansion involving an array. - Command names can now end in ':' as they can on other shells. - Fixed a spurious syntax error in compound assignments upon encountering a pair of repeated opening parentheses '(('. - Fixed spurious syntax error in ${parameter:offset:length}: the arithmetic expressions 'offset' and 'length' may now contain the operators ( ) & |. - Fixed a parsing bug in the declaration of .sh.math.* arithmetic functions. - Fixed nameref self-reference loop detection for more than two namerefs. - Several improvements to the POSIX compatibility mode. - Many more minor and/or esoteric bugfixes.
Diffstat (limited to 'shells')
-rw-r--r--shells/ksh/Makefile2
-rw-r--r--shells/ksh/distinfo6
-rw-r--r--shells/ksh/files/patch-src_lib_libast_aso_aso.c11
3 files changed, 4 insertions, 15 deletions
diff --git a/shells/ksh/Makefile b/shells/ksh/Makefile
index ba60f82e33f3..26617ec47ba0 100644
--- a/shells/ksh/Makefile
+++ b/shells/ksh/Makefile
@@ -10,7 +10,7 @@
DISTVERSIONPREFIX= v
PORTNAME= ksh
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.5
CATEGORIES= shells
MAINTAINER= cy@FreeBSD.org
diff --git a/shells/ksh/distinfo b/shells/ksh/distinfo
index d95ba35240aa..79ffc223ac8f 100644
--- a/shells/ksh/distinfo
+++ b/shells/ksh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1666457964
-SHA256 (ksh93-ksh-v1.0.4_GH0.tar.gz) = 7ab7785a277f96acd8b645dc70769adf0cc92546dac356639852bff1d708275f
-SIZE (ksh93-ksh-v1.0.4_GH0.tar.gz) = 2127036
+TIMESTAMP = 1686152726
+SHA256 (ksh93-ksh-v1.0.5_GH0.tar.gz) = 940d6dd6b4204f4965cf87cbba5bdf2d2c5153975100ee242038425f9470c0fe
+SIZE (ksh93-ksh-v1.0.5_GH0.tar.gz) = 2109689
diff --git a/shells/ksh/files/patch-src_lib_libast_aso_aso.c b/shells/ksh/files/patch-src_lib_libast_aso_aso.c
deleted file mode 100644
index 891c022d470e..000000000000
--- a/shells/ksh/files/patch-src_lib_libast_aso_aso.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/lib/libast/aso/aso.c.orig 2022-10-21 20:05:14.000000000 -0700
-+++ src/lib/libast/aso/aso.c 2023-02-15 06:39:08.156515000 -0800
-@@ -836,7 +836,7 @@
-
- #if defined(_aso_casptr)
- if (!state.lockf)
-- return _aso_casptr((void**)p, o, n);
-+ return _aso_cas64((void**)p, o, n);
- #endif
- k = lock(state.data, 0, p);
- if (*(void* volatile*)p == o)