aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorDaniel Engberg <diizzy@FreeBSD.org>2023-07-27 20:03:35 +0000
committerDaniel Engberg <diizzy@FreeBSD.org>2023-07-27 20:06:07 +0000
commit1c28eaa80ed5e0f8a750005ffbdf2798aac6c38b (patch)
tree542ea413b386b52e7437ad40487a17dc96ea7238 /www
parent9c85dbfe47abfa3c3025dd9bda79c0f058f47f37 (diff)
downloadports-1c28eaa80ed5e0f8a750005ffbdf2798aac6c38b.tar.gz
ports-1c28eaa80ed5e0f8a750005ffbdf2798aac6c38b.zip
www/nghttp2: Update to 1.55.1
* Refresh CMake args * Rearrange to follow Porters Handbook more closely and better readbility Changelog: https://github.com/nghttp2/nghttp2/releases/tag/v1.55.1 PR: 272215 Approved by: portmgr (maintainer timeout, 2+ weeks) Sponsored by: Blinkinblox
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile40
-rw-r--r--www/nghttp2/distinfo6
2 files changed, 34 insertions, 12 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index 3dbfe6a50cb3..57df4af6ec18 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -1,7 +1,7 @@
PORTNAME= nghttp2
-PORTVERSION= 1.54.0
+DISTVERSION= 1.55.1
CATEGORIES= www net
-MASTER_SITES= https://github.com/nghttp2/nghttp2/releases/download/v${PORTVERSION}/
+MASTER_SITES= https://github.com/${PORTNAME}/${PORTNAME}/releases/download/v${DISTVERSION}/
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= HTTP/2.0 C Library
@@ -10,14 +10,28 @@ WWW= https://nghttp2.org/
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-BUILD_DEPENDS= libnghttp2>=${PORTVERSION}:www/libnghttp2
+BUILD_DEPENDS= libnghttp2>=${DISTVERSION}:www/libnghttp2
LIB_DEPENDS= libnghttp2.so:www/libnghttp2
-USES= cmake compiler:c++14-lang cpe localbase:ldflags pathfix pkgconfig python:env shebangfix ssl tar:xz
+USES= cmake compiler:c++14-lang cpe localbase:ldflags pathfix \
+ pkgconfig python:env shebangfix ssl tar:xz
CMAKE_ARGS= -DCMAKE_INSTALL_MANDIR=share/man
-CMAKE_OFF= ENABLE_DEBUG ENABLE_HTTP3 ENABLE_LIB_ONLY ENABLE_STATIC_CRT ENABLE_WERROR WITH_LIBBPF WITH_MRUBY WITH_NEVERBLEED
-CMAKE_ON= ENABLE_DOC ENABLE_FAILMALLOC ENABLE_THREADS
+CMAKE_OFF= ENABLE_DEBUG \
+ ENABLE_HTTP3 \
+ ENABLE_LIB_ONLY \
+ ENABLE_STATIC_CRT \
+ ENABLE_WERROR \
+ WITH_LIBBPF \
+ WITH_MRUBY \
+ WITH_NEVERBLEED
+CMAKE_ON= ENABLE_DOC \
+ ENABLE_FAILMALLOC \
+ ENABLE_THREADS \
+ CMAKE_DISABLE_FIND_PACKAGE_Jemalloc \
+ CMAKE_DISABLE_FIND_PACKAGE_Libnghttp3 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2 \
+ CMAKE_DISABLE_FIND_PACKAGE_Libngtcp2_crypto_openssl
USE_RC_SUBR= nghttpx
SHEBANG_FILES= script/fetch-ocsp-response
@@ -25,21 +39,29 @@ SHEBANG_FILES= script/fetch-ocsp-response
OPTIONS_DEFINE= APP EXAMPLES HPACK
OPTIONS_DEFAULT=APP HPACK
OPTIONS_SUB= yes
+
APP_DESC= Build h2load, nghttp, nghttpd and nghttpx
APP_BUILD_DEPENDS= c-ares>=1.7.5:dns/c-ares \
libev>=4.11:devel/libev
-APP_CMAKE_BOOL= ENABLE_APP
APP_LIB_DEPENDS= libcares.so:dns/c-ares \
libev.so:devel/libev
APP_USE= GNOME=libxml2
APP_USES= gnome
-EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
+APP_CMAKE_BOOL= ENABLE_APP
+APP_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Libcares:BOOL=True \
+ -DCMAKE_DISABLE_FIND_PACKAGE_Libev:BOOL=True \
+ -DCMAKE_DISABLE_FIND_PACKAGE_LibXml2:BOOL=True
+
EXAMPLES_BUILD_DEPENDS= libevent>=2.0.8:devel/libevent
EXAMPLES_LIB_DEPENDS= libevent_openssl.so:devel/libevent
+EXAMPLES_CMAKE_BOOL= ENABLE_EXAMPLES
+EXAMPLES_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Libevent:BOOL=True
+
HPACK_BUILD_DEPENDS= jansson>=2.5:devel/jansson
-HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
HPACK_LIB_DEPENDS= libjansson.so:devel/jansson
+HPACK_CMAKE_BOOL= ENABLE_HPACK_TOOLS
+HPACK_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Jansson:BOOL=True
post-install:
${MKDIR} ${STAGEDIR}${PREFIX}/etc/nghttpx/
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index a2449a12f6f1..b13d32bd3fe8 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1688166098
-SHA256 (nghttp2-1.54.0.tar.xz) = 20533c9354fbb6aa689b6aa0ddb77f91da1d242587444502832e1864308152df
-SIZE (nghttp2-1.54.0.tar.xz) = 1541460
+TIMESTAMP = 1689456136
+SHA256 (nghttp2-1.55.1.tar.xz) = 19490b7c8c2ded1cf7c3e3a54ef4304e3a7876ae2d950d60a81d0dc6053be419
+SIZE (nghttp2-1.55.1.tar.xz) = 1541884