aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/shutter/Makefile2
-rw-r--r--deskutils/shutter/files/patch-CVE-2015-085412
2 files changed, 13 insertions, 1 deletions
diff --git a/deskutils/shutter/Makefile b/deskutils/shutter/Makefile
index 16b2844c58f1..82bf7c5f1932 100644
--- a/deskutils/shutter/Makefile
+++ b/deskutils/shutter/Makefile
@@ -3,7 +3,7 @@
PORTNAME= shutter
PORTVERSION= 0.93.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils
MASTER_SITES= http://shutter-project.org/wp-content/uploads/releases/tars/
diff --git a/deskutils/shutter/files/patch-CVE-2015-0854 b/deskutils/shutter/files/patch-CVE-2015-0854
new file mode 100644
index 000000000000..58e82b0a88ff
--- /dev/null
+++ b/deskutils/shutter/files/patch-CVE-2015-0854
@@ -0,0 +1,12 @@
+--- share/shutter/resources/modules/Shutter/App/HelperFunctions.pm.orig 2015-09-17 16:09:58 UTC
++++ share/shutter/resources/modules/Shutter/App/HelperFunctions.pm
+@@ -53,7 +53,8 @@ sub new {
+
+ sub xdg_open {
+ my ( $self, $dialog, $link, $user_data ) = @_;
+- system("xdg-open $link");
++ @args = ("xdg-open", "$link");
++ system(@args);
+ if($?){
+ my $response = $self->{_dialogs}->dlg_error_message(
+ sprintf( $self->{_d}->get("Error while executing %s."), "'xdg-open'"),