aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--lang/phantomjs/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/lang/phantomjs/Makefile b/lang/phantomjs/Makefile
index c837ab1de13c..a31cf7b6e72c 100644
--- a/lang/phantomjs/Makefile
+++ b/lang/phantomjs/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libpng.so:graphics/png
PROJECTHOST= phantomjs
-USES= bison:build compiler gmake gperf jpeg perl5 pkgconfig python:build zip
+USES= bison:build compiler:c++11-lang gmake gperf jpeg perl5 pkgconfig python:build zip
USE_PERL5= build
USE_RUBY= yes
RUBY_NO_RUN_DEPENDS= yes
@@ -31,11 +31,6 @@ NO_CCACHE= yes
USE_XORG= x11
-# Hack for FreeBSD 9. Without it mysteriously switches from
-# clang++ to c++ which ends in build failure.
-CC=clang
-CXX=clang++
-
# NOTE:
# build.sh --qtwebkit=system requires Qt 5.3.x. We cannot use it.