aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/py-netbox-secretstore/Makefile1
-rw-r--r--security/py-netbox-secretstore/files/patch-netbox__secretstore_____init____.py15
2 files changed, 16 insertions, 0 deletions
diff --git a/security/py-netbox-secretstore/Makefile b/security/py-netbox-secretstore/Makefile
index 58701b03503a..351f839a944b 100644
--- a/security/py-netbox-secretstore/Makefile
+++ b/security/py-netbox-secretstore/Makefile
@@ -1,5 +1,6 @@
PORTNAME= netbox-secretstore
DISTVERSION= 1.3.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-netbox-secretstore/files/patch-netbox__secretstore_____init____.py b/security/py-netbox-secretstore/files/patch-netbox__secretstore_____init____.py
new file mode 100644
index 000000000000..69fa9877125a
--- /dev/null
+++ b/security/py-netbox-secretstore/files/patch-netbox__secretstore_____init____.py
@@ -0,0 +1,15 @@
+Adjust version check to allow NetBox 3.3.10
+
+https://github.com/DanSheps/netbox-secretstore/pull/106
+
+--- netbox_secretstore/__init__.py.orig 2022-12-14 09:03:13 UTC
++++ netbox_secretstore/__init__.py
+@@ -18,7 +18,7 @@ class NetBoxSecretStore(PluginConfig):
+ author_email = metadata.get('Author-email')
+ base_url = 'netbox_secretstore'
+ min_version = '3.3.0beta1'
+- max_version = '3.3.9'
++ max_version = '3.3.10'
+ required_settings = []
+ default_settings = {
+ 'public_key_size': 2048