aboutsummaryrefslogtreecommitdiff
path: root/games/linux-enemyterritory-omni-bot-0660/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/linux-enemyterritory-omni-bot-0660/Makefile')
-rw-r--r--games/linux-enemyterritory-omni-bot-0660/Makefile51
1 files changed, 0 insertions, 51 deletions
diff --git a/games/linux-enemyterritory-omni-bot-0660/Makefile b/games/linux-enemyterritory-omni-bot-0660/Makefile
deleted file mode 100644
index cda953dae027..000000000000
--- a/games/linux-enemyterritory-omni-bot-0660/Makefile
+++ /dev/null
@@ -1,51 +0,0 @@
-# New ports collection makefile for: omni-bot
-# Date created: 7 May 2006
-# Whom: alepulver
-#
-# $FreeBSD$
-#
-
-PORTNAME= omni-bot
-PORTVERSION= 0.531
-CATEGORIES= games linux
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alepulver
-PKGNAMEPREFIX= linux-enemyterritory-
-
-MAINTAINER= alepulver@FreeBSD.org
-COMMENT= Omni-Bot is a bot for Enemy Territory
-
-RUN_DEPENDS= et:${PORTSDIR}/games/linux-enemyterritory
-
-USE_ZIP= yes
-USE_LINUX= yes
-NO_WRKSUBDIR= yes
-
-DATADIR= ${PREFIX}/lib/enemyterritory
-DOCSDIR= ${PREFIX}/share/doc/enemyterritory-${PORTNAME}
-
-do-build:
-.for f in et etded
- @(${ECHO} "#!/bin/sh"; \
- ${ECHO} 'exec ${PREFIX}/bin/${f} +set fs_game ${PORTNAME} "$$@"') > \
- ${WRKSRC}/${f}-${PORTNAME}
-.endfor
-
-do-install:
-.for f in et etded
- ${INSTALL_SCRIPT} ${WRKSRC}/${f}-${PORTNAME} ${PREFIX}/bin
-.endfor
- ${MKDIR} ${DATADIR}/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/omni-bot/omnibot_et.so ${DATADIR}/${PORTNAME}
- ${CP} -R ${WRKSRC}/omni-bot/et ${DATADIR}/${PORTNAME}
- ${INSTALL_PROGRAM} ${WRKSRC}/omnibot/qagame.mp.i386.so ${DATADIR}/${PORTNAME}
- ${INSTALL_DATA} ${WRKSRC}/omnibot/omnibot_et.pk3 ${DATADIR}/${PORTNAME}
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-. for f in *.txt omni-bot/*.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
-. endfor
- ${CP} -R ${WRKSRC}/omni-bot/docs ${DOCSDIR}
-.endif
-
-.include <bsd.port.mk>