aboutsummaryrefslogtreecommitdiff
path: root/graphics/freeglut/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/freeglut/Makefile')
-rw-r--r--graphics/freeglut/Makefile76
1 files changed, 0 insertions, 76 deletions
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
deleted file mode 100644
index 5c5b2a185131..000000000000
--- a/graphics/freeglut/Makefile
+++ /dev/null
@@ -1,76 +0,0 @@
-# New ports collection makefile for: freeglut
-# Date created: Wed Apr 23 2003
-# Whom: thierry@pompo.net
-#
-# $FreeBSD$
-#
-
-PORTNAME= freeglut
-PORTVERSION= 2.2.0
-CATEGORIES= x11-toolkits
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= An alternative to the OpenGL Utility Toolkit (GLUT) library
-
-USE_AUTOMAKE_VER= 14
-USE_AUTOCONF_VER= 213
-USE_AUTOHEADER_VER= 213
-USE_INC_LIBTOOL_VER= 13
-HAS_CONFIGURE= yes
-INSTALLS_SHLIB= yes
-USE_XLIB= yes
-CONFIGURE_ARGS= --x-includes=${X11BASE}/include \
- --x-libraries=${X11BASE}/lib \
- --enable-replace-glut
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include"
-
-USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-DOCS= download.html freeglut.html freeglut_logo.png \
- freeglut_user_interface.html index.html ogl_sm.png \
- progress.html structure.html
-BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
-
-post-patch:
- @${REINPLACE_CMD} -e "s|/usr/X11R6|${X11BASE}|g" \
- -e "s|/usr/local|${LOCALBASE}|g" \
- ${WRKSRC}/aclocal.m4
-.for fract in /fractals.c _random/fractals_random.c
- @${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
- ${WRKSRC}/progs/demos/Fractals${fract}
-.endfor
-
-post-build:
- @${MV} ${WRKSRC}/progs/demos/CallbackMaker/.libs/CallbackMaker \
- ${WRKSRC}/progs/demos/CallbackMaker/.libs/callbackmaker
- @${CAT} pkg-message | ${SED} 's|%%X11BASE%%|${X11BASE}| ; \
- s|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/doc/${FILE} ${DOCSDIR}
-.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/progs/demos/Fractals/fractals.dat \
- ${EXAMPLESDIR}
-.for prog in ${BINS}
- @${INSTALL_PROGRAM} ${WRKSRC}/progs/demos/${prog}/.libs/${prog:L} \
- ${EXAMPLESDIR}
-.endfor
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
-.endif
- @${ECHO_MSG}
- @${CAT} ${PKGMESSAGE} | \
- ${SED} -e "s|/usr/local|${PREFIX}|" \
- -e "s|/usr/X11R6|${X11BASE}|"
- @${ECHO_MSG}
-
-.include <bsd.port.mk>