aboutsummaryrefslogtreecommitdiff
path: root/graphics/mesa-libs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/mesa-libs/Makefile')
-rw-r--r--graphics/mesa-libs/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/graphics/mesa-libs/Makefile b/graphics/mesa-libs/Makefile
index f8be1f1ef6db..a3d6cfd472e4 100644
--- a/graphics/mesa-libs/Makefile
+++ b/graphics/mesa-libs/Makefile
@@ -1,5 +1,6 @@
PORTNAME= mesa-libs
PORTVERSION= ${MESAVERSION}
+PORTREVISION= 1
CATEGORIES= graphics
COMMENT= OpenGL libraries that support GLX and EGL clients
@@ -10,7 +11,7 @@ LICENSE_FILE= ${WRKSRC}/docs/license.rst
USES= llvm:noexport
-LIB_DEPENDS= libOpenGL.so:graphics/libglvnd
+BUILD_DEPENDS= libglvnd>=0:graphics/libglvnd
OPTIONS_GROUP= PLATFORM
OPTIONS_GROUP_PLATFORM= PLATFORM_X11 PLATFORM_WAYLAND
@@ -24,7 +25,7 @@ OPTIONS_SUB= yes
WAYLAND_DESC= Enable support for the Wayland platform in EGL
WAYLAND_BUILD_DEPENDS= wayland-protocols>=1.8:graphics/wayland-protocols
-WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/wayland
+WAYLAND_LIB_DEPENDS= libwayland-server.so:graphics/wayland
WAYLAND_IMPLIES= PLATFORM_WAYLAND
ZSTD_DESC= Use ZSTD for shader cache