aboutsummaryrefslogtreecommitdiff
path: root/irc/xchat2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/xchat2/Makefile')
-rw-r--r--irc/xchat2/Makefile78
1 files changed, 0 insertions, 78 deletions
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
deleted file mode 100644
index 57edd91041fc..000000000000
--- a/irc/xchat2/Makefile
+++ /dev/null
@@ -1,78 +0,0 @@
-# New ports collection makefile for: xchat
-# Date created: 17 Nov 1998
-# Whom: Jim Mock <jim@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xchat
-PORTVERSION= 1.8.3
-CATEGORIES+= irc gnome ipv6
-MASTER_SITES= http://xchat.org/files/source/1.8/ \
- http://xchat.linuxpower.org/files/source/1.8/
-
-MAINTAINER?= jim@FreeBSD.org
-
-BUILD_DEPENDS= msgfmt-new:${PORTSDIR}/devel/gettext-devel
-LIB_DEPENDS= giconv.2:${PORTSDIR}/converters/libiconv
-
-# This port has a slave port japanese/xchat. Do not carelessly overwrite
-# the variables or the targets defined in it. When you need to, please
-# contact its maintainer.
-
-USE_X_PREFIX= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_PERL5= yes
-USE_IMLIB= yes
-WANT_GNOME= yes
-GNU_CONFIGURE= yes
-# Assign with `+=' for slave ports
-CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib -lintl -lgiconv" \
- MSGFMT=${LOCALBASE}/bin/msgfmt-new
-CONFIGURE_ARGS+= --disable-python \
- --without-included-gettext \
- --enable-nls \
- --enable-ipv6 \
- --datadir="${PREFIX}/share"
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_SOCKS)
-# Assign with `+=' for slave ports
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libsocks5.a:${PORTSDIR}/net/socks5
-CONFIGURE_ARGS+= --enable-socks
-.endif
-
-.if defined(WITH_SSL)
-USE_OPENSSL= YES
-CONFIGURE_ARGS+= --enable-openssl
-.endif
-
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
-CONFIGURE_ARGS+= --enable-gnome --enable-panel --enable-gdk-pixbuf
-MAKE_ARGS= icondir="${PREFIX}/share/gnome/pixmaps"
-.else
-CONFIGURE_ARGS+= --disable-gnome --disable-gdk-pixbuf
-.endif
-
-post-patch:
- @${PERL} -pi \
- -e 's|-lpthread|${PTHREAD_LIBS}|g;' \
- -e 's|iconv|giconv|;' \
- ${WRKSRC}/configure
- @${PERL} -pi -e 's|iconv\.h|giconv.h|;' \
- ${WRKSRC}/src/common/jcode.c
-
-post-install:
-.if !defined(NOPORTDOCS)
- @${ECHO_MSG} "===> Installing xchat docs in ${PREFIX}/share/doc/xchat"
- @${MKDIR} ${PREFIX}/share/doc/xchat && ${CHMOD} a+rx ${PREFIX}/share/doc/xchat
- ${INSTALL_DATA} ${WRKSRC}/doc/*.* ${PREFIX}/share/doc/xchat
- ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xchat
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${PREFIX}/share/doc/xchat
-.endif
-
-.include <bsd.port.post.mk>