aboutsummaryrefslogtreecommitdiff
path: root/lang/python27/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'lang/python27/Makefile')
-rw-r--r--lang/python27/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index 44c4fa1ed2c1..9f8d453d4424 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -121,7 +121,8 @@ post-patch:
# openssl/opensslv.h so setup.py just detects the string as 00000000
# However care should be taken for the OSVERSION. If OpenSSL 3.0.9
# lands later the OSVERSION string should be fixed accordingly
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || ${SSL_DEFAULT:Mopenssl3*} )
+.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1400092 && (${SSL_DEFAULT} == base || \
+ ${SSL_DEFAULT} == openssl || ${SSL_DEFAULT:Mopenssl3*} )
@${REINPLACE_CMD} -e 's|00907000|00000000|' \
${WRKSRC}/setup.py
.endif