aboutsummaryrefslogtreecommitdiff
path: root/mail/claws-mail-notification/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'mail/claws-mail-notification/Makefile')
-rw-r--r--mail/claws-mail-notification/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/mail/claws-mail-notification/Makefile b/mail/claws-mail-notification/Makefile
index 2ec26d68d14b..b8a03a68b144 100644
--- a/mail/claws-mail-notification/Makefile
+++ b/mail/claws-mail-notification/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= notification
-PORTVERSION= 0.12.1
-PORTREVISION= 2
+PORTVERSION= 0.15
CATEGORIES= mail
MASTER_SITES= http://www.claws-mail.org/downloads/plugins/
PKGNAMEPREFIX= claws-mail-
@@ -17,12 +16,14 @@ MAINTAINER= c0rn@o2.pl
COMMENT= New/unread mail notification plugin for claws-mail
LIB_DEPENDS= notify:${PORTSDIR}/devel/libnotify
-BUILD_DEPENDS= claws-mail>=3.0.0:${PORTSDIR}/mail/claws-mail
-RUN_DEPENDS= claws-mail>=3.0.0:${PORTSDIR}/mail/claws-mail
+BUILD_DEPENDS= claws-mail>=3.3.0:${PORTSDIR}/mail/claws-mail
+RUN_DEPENDS= claws-mail>=3.3.0:${PORTSDIR}/mail/claws-mail
USE_GMAKE= yes
USE_XLIB= yes
USE_AUTOTOOLS= autoconf:261
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
--with-libintl-prefix=${LOCALBASE}
@@ -35,6 +36,7 @@ PLIST_FILES= lib/claws-mail/plugins/notification_plugin.a \
share/locale/hu/LC_MESSAGES/notification_plugin.mo \
share/locale/pt_BR/LC_MESSAGES/notification_plugin.mo \
share/locale/zh_CN/LC_MESSAGES/notification_plugin.mo \
- share/locale/fi/LC_MESSAGES/notification_plugin.mo
+ share/locale/fi/LC_MESSAGES/notification_plugin.mo \
+ share/locale/it/LC_MESSAGES/notification_plugin.mo
.include <bsd.port.mk>