aboutsummaryrefslogtreecommitdiff
path: root/math/R/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/R/Makefile')
-rw-r--r--math/R/Makefile89
1 files changed, 0 insertions, 89 deletions
diff --git a/math/R/Makefile b/math/R/Makefile
deleted file mode 100644
index 41a2b4c47d33..000000000000
--- a/math/R/Makefile
+++ /dev/null
@@ -1,89 +0,0 @@
-# ex: ts=8 sts=0 noet
-# New ports collection makefile for: R
-# Date created: Fri Feb 9 10:50:25 EST 2001
-# Whom: Maurice Castro <maurice@serc.rmit.edu.au>
-#
-# $FreeBSD$
-#
-
-PORTNAME= R
-PORTVERSION= 1.9.0
-CATEGORIES= math
-MASTER_SITES= http://cran.r-project.org/src/base/ \
- ftp://cran.r-project.org/pub/R/src/base/ \
- http://cran.at.r-project.org/src/base/ \
- http://cran.au.r-project.org/src/base/ \
- http://cran.br.r-project.org/src/base/ \
- http://cran.ch.r-project.org/src/base/ \
- http://cran.es.r-project.org/src/base/ \
- http://cran.dk.r-project.org/src/base/ \
- http://cran.hu.r-project.org/src/base/ \
- http://cran.uk.r-project.org/src/base/ \
- http://cran.us.r-project.org/src/base/ \
- http://cran.za.r-project.org/src/base/ \
- ftp://ftp.u-aizu.ac.jp/pub/lang/R/CRAN/src/base/ \
- http://lib.stat.cmu.edu/R/CRAN/src/base/ \
- http://cran.stat.ucla.edu/src/base/ \
- http://probability.ca/cran/src/base/ \
- http://www.ibiblio.org/pub/languages/R/CRAN/src/base/ \
- http://www.bioconductor.org/CRAN/src/base/
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= vangyzen@stat.duke.edu
-COMMENT= A language for statistical computing and graphics
-
-LIB_DEPENDS= tcl84:${PORTSDIR}/lang/tcl84 \
- tk84:${PORTSDIR}/x11-toolkits/tk84 \
- jpeg.9:${PORTSDIR}/graphics/jpeg \
- png.5:${PORTSDIR}/graphics/png \
- pcre.0:${PORTSDIR}/devel/pcre
-
-.if defined(WITH_ATLAS)
-LIB_DEPENDS+= f77blas.1:${PORTSDIR}/math/atlas
-CONFIGURE_ARGS= --with-lapack="-lalapack -lcblas" --with-blas="-lf77blas"
-.else
-LIB_DEPENDS+= lapack.3:${PORTSDIR}/math/lapack
-CONFIGURE_ARGS= --with-lapack="-llapack" --with-blas="-lblas"
-.endif
-
-MAN1= R.1
-
-GNU_CONFIGURE= yes
-USE_XLIB= yes
-USE_PERL5= yes
-CONFIGURE_ENV= FFLAGS="${FFLAGS}" \
- INSTALL_DATA="${INSTALL} ${COPY} ${_SHROWNGRP} -m 644"
-CONFIGURE_ARGS+=--enable-R-shlib --with-bzlib --with-pcre --with-zlib
-
-# NB: R 1.9.0 requires zlib 1.2.1, but the system zlib is currently
-# only 1.1.4. Thus, R compiles its own bundled version of zlib
-# despite configuring with --with-zlib.
-
-.include <bsd.port.pre.mk>
-
-pre-fetch:
-.if !defined(PAPERSIZE)
- @${ECHO}
- @${ECHO} " The default paper size for printing from R is A4."
- @${ECHO} " You can change it by setting the PAPERSIZE"
- @${ECHO} " make variable to one of:"
- @${ECHO} " a4 letter legal executive"
- @${ECHO} " For example:"
- @${ECHO} " # make PAPERSIZE=letter install clean"
- @${ECHO}
-.else
-CONFIGURE_ENV+= R_PAPERSIZE=${PAPERSIZE}
-.endif
-
-# Build the four documentation formats sequentially (instead of simultaneously)
-# to prevent perl 5.8 from using too much memory (> 512 MB) and being killed.
-.if ${PERL_LEVEL} >= 500800
-ALL_TARGET= Makefile Makeconf R help html latex examples docs stamp-recommended
-.endif
-
-test check: build
- @(cd ${WRKSRC}; ${MAKE} check)
-check-all: build
- @(cd ${WRKSRC}; ${MAKE} check-all)
-
-.include <bsd.port.post.mk>