aboutsummaryrefslogtreecommitdiff
path: root/misc/arrow-datafusion/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'misc/arrow-datafusion/Makefile')
-rw-r--r--misc/arrow-datafusion/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/misc/arrow-datafusion/Makefile b/misc/arrow-datafusion/Makefile
index 5533183dd026..924197bcb192 100644
--- a/misc/arrow-datafusion/Makefile
+++ b/misc/arrow-datafusion/Makefile
@@ -10,6 +10,8 @@ WWW= https://arrow.apache.org/datafusion
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE.txt
+BROKEN_i386= compilation fails: this arithmetic operation will overflow, see https://github.com/purpleprotocol/mimalloc_rust/issues/116
+
LIB_DEPENDS= libzstd.so:archivers/zstd
USES= cargo
@@ -19,6 +21,8 @@ GH_ACCOUNT= apache
WRKSRC_SUBDIR= datafusion-cli
+RUSTFLAGS= ${ARCH:S/i386/YES/:C/^[a-z].*//:S/YES/-C target-feature=+sse,+sse2/} # add sse sse2 target-features only on i386
+
CARGO_CRATES= addr2line-0.21.0 \
adler-1.0.2 \
adler32-1.2.0 \