aboutsummaryrefslogtreecommitdiff
path: root/net/gnet2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/gnet2/Makefile')
-rw-r--r--net/gnet2/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
deleted file mode 100644
index ad79ea436ec5..000000000000
--- a/net/gnet2/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: gnet
-# Date created: 16 February 2000
-# Whom: Yukihiro Nakai <nakai@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= gnet
-PORTVERSION= 1.1.4
-CATEGORIES= net
-MASTER_SITES= http://www.gnetlibrary.org/src/
-
-MAINTAINER= nakai@FreeBSD.org
-
-USE_REINPLACE= yes
-USE_GNOMENG= yes
-USE_GNOME= gnomehack glib12
-USE_LIBTOOL= yes
-INSTALLS_SHLIB= yes
-
-MAN1= gnet-config.1
-
-post-patch:
-# fix pthreads detection
- @${REINPLACE_CMD} -E -e 's,-lpthread|-lc_r,${PTHREAD_LIBS},' \
- ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
-# remove "release" information from lib name
- @${REINPLACE_CMD} -E -e 's|-release[ ]+\$$\(LT_RELEASE\)||g' \
- ${WRKSRC}/src/Makefile.in
-# don't install gnet-config script with odd name. We will install it ourselves
- @${REINPLACE_CMD} -E -e 's|^(install-exec-am:).+$$|\1|' \
- ${WRKSRC}/Makefile.in
-# install gnet-config.1 man (not another name). Revise at EVERY port update
- @${REINPLACE_CMD} -e 's|\$$\$$inst|\$$\$$file|g' \
- ${WRKSRC}/doc/Makefile.in
-# install configincludedir correctly
- @${REINPLACE_CMD} -E -e 's|^(configincludedir).+$$|\1=\$$\(pkgincludedir\)|' \
- ${WRKSRC}/Makefile.in
-
-post-install:
- @${INSTALL_SCRIPT} ${WRKSRC}/gnet-config ${PREFIX}/bin
-
-.include <bsd.port.mk>