aboutsummaryrefslogtreecommitdiff
path: root/security/php-Auth_OpenID2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/php-Auth_OpenID2/Makefile')
-rw-r--r--security/php-Auth_OpenID2/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/security/php-Auth_OpenID2/Makefile b/security/php-Auth_OpenID2/Makefile
deleted file mode 100644
index 61c6995c17d6..000000000000
--- a/security/php-Auth_OpenID2/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# New ports collection makefile for: php-Auth_OpenID
-# Date created: 2007-04-24
-# Whom: Gea-Suan Lin <gslin@gslin.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= Auth_OpenID
-PORTVERSION= 1.2.2
-CATEGORIES= security www pear
-MASTER_SITES= http://www.openidenabled.com/resources/downloads/php-openid/pear/
-PKGNAMEPREFIX= php-
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= gslin@gslin.org
-COMMENT= PHP OpenID library
-
-RUN_DEPENDS= pear:${PORTSDIR}/devel/pear
-BUILD_DEPENDS= ${RUN_DEPENDS}
-
-NO_BUILD= yes
-OPTIONS= BCMATH "Use bcmath instead of libgmp" off \
- MYSQL "Use mysql" off \
- PGSQL "Use pgsql" off \
- SQLITE "Use sqlite" off
-
-USE_PHP= curl
-
-.include <bsd.port.pre.mk>
-
-.ifdef(WITH_BCMATH)
-USE_PHP+= bcmath
-.else
-USE_PHP+= gmp
-.endif
-
-.ifdef(WITH_MYSQL)
-USE_PHP+= mysql
-.endif
-
-.ifdef(WITH_PGSQL)
-USE_PHP+= pgsql
-.endif
-
-.ifdef(WITH_SQLITE)
-USE_PHP+= sqlite
-.endif
-
-do-install:
- ${MKDIR} ${PREFIX}/share/pear/Auth/OpenID
- ${CP} ${WRKSRC}/Auth/OpenID.php ${PREFIX}/share/pear/Auth
- ${CP} ${WRKSRC}/Auth/OpenID/* ${PREFIX}/share/pear/Auth/OpenID
- ${MKDIR} ${PREFIX}/share/pear/Services/Yadis
- ${CP} ${WRKSRC}/Services/Yadis/* ${PREFIX}/share/pear/Services/Yadis
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/examples/ ${EXAMPLESDIR}
-
-.include <bsd.port.post.mk>