aboutsummaryrefslogtreecommitdiff
path: root/sysutils/munin-master/files/patch-Makefile.config
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/munin-master/files/patch-Makefile.config')
-rw-r--r--sysutils/munin-master/files/patch-Makefile.config85
1 files changed, 0 insertions, 85 deletions
diff --git a/sysutils/munin-master/files/patch-Makefile.config b/sysutils/munin-master/files/patch-Makefile.config
deleted file mode 100644
index dd3aa61849df..000000000000
--- a/sysutils/munin-master/files/patch-Makefile.config
+++ /dev/null
@@ -1,85 +0,0 @@
---- munin-1.2.5.orig/Makefile.config Tue Oct 17 14:27:35 2006
-+++ munin-1.2.5/Makefile.config Thu Nov 2 12:09:09 2006
-@@ -7,52 +7,56 @@
- #
- # the base of the Munin installation.
- #
--PREFIX = $(DESTDIR)/opt/munin
-+ifdef PREFIX
-+UPREFIX=$(PREFIX)
-+else
-+UPREFIX=/usr
-+endif
-
- # Where Munin keeps its configurations (server.conf, client.conf, ++)
--CONFDIR = $(DESTDIR)/etc/opt/munin
-+CONFDIR = $(PREFIX)/etc/munin
-
- # Server only - where to put munin-cron
--BINDIR = $(PREFIX)/bin
-+BINDIR = $(UPREFIX)/bin
-
- # Client only - where to put munin-node, munin-node-configure, and munin-run
--SBINDIR = $(PREFIX)/sbin
-+SBINDIR = $(UPREFIX)/sbin
-
- # Where to put text and html documentation
--DOCDIR = $(PREFIX)/doc
-+DOCDIR = $(UPREFIX)/doc
-
- # Where to put man pages
--MANDIR = $(PREFIX)/man
-+MANDIR = $(UPREFIX)/man
-
- # Where to put internal binaries and plugin repository
--LIBDIR = $(PREFIX)/lib
-+LIBDIR = $(DATADIR)
-
- # Server only - Output directory
--HTMLDIR = $(PREFIX)/var/www
--CGIDIR = $(HTMLDIR)/cgi
-+HTMLDIR = $(PREFIX)/www/munin
-+CGIDIR = $(PREFIX)/www/cgi-bin
-
- # Client only - Where to put RRD files and other intenal data
--DBDIR = $(DESTDIR)/var/opt/munin
-+DBDIR = $(PREFIX)/var/munin
-
- # Client only - Where plugins should put their states. Must be writable by
- # group "munin", and should be preserved between reboots
- PLUGSTATE = $(DBDIR)/plugin-state
-
- # Where Munin should place its logs.
--LOGDIR = $(DESTDIR)/var/log/munin
-+LOGDIR = /var/log/munin-main
-
- # Location of PID files and other statefiles. On the server, must be
- # writable by the user "munin".
--STATEDIR = $(DESTDIR)/var/run/munin
-+STATEDIR = /var/run/munin
-
- # The perl interpreter to use
--PERL = $(shell which perl)
-+# Passed in from FreeBSD port Makefile.
-
- # The python interpreter to use (used by some plugins)
- PYTHON = /usr/bin/env python
-
- # Server only - Where to install the perl libraries
--PERLLIB = $(DESTDIR)$(shell $(PERL) -V:sitelib | cut -d= -f2 | sed "s/[\';]//g")
-+PERLLIB = $(PREFIX)/$(SITE_PERL_REL)
-
- # Client only - Install plugins for this architecture
- OSTYPE = $(shell uname | tr '[A-Z]' '[a-z]')
-@@ -77,9 +81,8 @@
- PLUGINUSER = nobody
-
- # Which command to use to check if the USER and GROUP to run Munin as, exists.
--GETENT = $(shell which getent || which true 2>/dev/null)
--CHECKUSER = $(shell $(GETENT) passwd $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
--CHECKGROUP = $(shell $(GETENT) group $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-+CHECKUSER:= $(shell /usr/sbin/pw user show $(USER) >/dev/null 2>/dev/null || (echo "echo User $(USER) nonexistant. Create the user and retry; exit 2"))
-+CHECKGROUP:= $(shell /usr/sbin/pw group show $(GROUP) >/dev/null 2>/dev/null || (echo "echo Group $(GROUP) nonexistant. Create the group and retry; exit 2"))
-
- CHOWN = chown
- CHMOD = chmod