aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-HaXml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-HaXml/Makefile')
-rw-r--r--textproc/hs-HaXml/Makefile47
1 files changed, 0 insertions, 47 deletions
diff --git a/textproc/hs-HaXml/Makefile b/textproc/hs-HaXml/Makefile
deleted file mode 100644
index 9c0377c1ac8f..000000000000
--- a/textproc/hs-HaXml/Makefile
+++ /dev/null
@@ -1,47 +0,0 @@
-# New ports collection makefile for: HaXml
-# Date created: 01 June 2002
-# Whom: Oliver Braun <obraun@informatik.unibw-muenchen.de>
-#
-# $FreeBSD$
-
-PORTNAME= haxml
-PORTVERSION= 1.13
-PORTREVISION= 2
-CATEGORIES= textproc haskell
-MASTER_SITES= http://www.haskell.org/HaXml/ \
- ftp://ftp.cs.york.ac.uk/pub/haskell/HaXml/
-PKGNAMEPREFIX= hs-
-DISTNAME= HaXml-${PORTVERSION}
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= A collection of utilities for using Haskell and XML together
-
-BUILD_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
-
-HAS_CONFIGURE= yes
-USE_GMAKE= yes
-
-CONFIGURE_ARGS+= --prefix=${PREFIX}/bin
-
-GHC_VERSION= `${LOCALBASE}/bin/ghc --numeric-version`
-PLIST_SUB+= GHC_VERSION="${GHC_VERSION}"
-
-post-patch:
- @${REINPLACE_CMD} -e 's,/bin/false,/usr/bin/false,' ${WRKSRC}/configure
-
-post-configure:
- @${REINPLACE_CMD} -e '/hugs/d' ${WRKSRC}/obj/compilers
- @${REINPLACE_CMD} -e '/nhc98/d' ${WRKSRC}/obj/compilers
-
-post-install:
- @${INSTALL_DATA} ${WRKSRC}/obj/ghc/HaXml.pkgconf \
- ${PREFIX}/lib/ghc-${GHC_VERSION}/imports/HaXml/
- @${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKSRC} && ${RM} -rf docs/HaXml/CVS)
- @(cd ${WRKSRC} && ${CP} -R docs/* ${DOCSDIR})
-.endif
-
-.include <bsd.port.mk>