aboutsummaryrefslogtreecommitdiff
path: root/www/apache20/Makefile.modules.3rd
diff options
context:
space:
mode:
Diffstat (limited to 'www/apache20/Makefile.modules.3rd')
-rw-r--r--www/apache20/Makefile.modules.3rd98
1 files changed, 0 insertions, 98 deletions
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
deleted file mode 100644
index 82e52774e654..000000000000
--- a/www/apache20/Makefile.modules.3rd
+++ /dev/null
@@ -1,98 +0,0 @@
-# Third party modules hack
-#
-# $FreeBSD$
-#
-# Author: Clement Laforet <clement@FreeBSD.org>
-# If you have questions, please contact me.
-#
-
-.ifdef(USE_APACHE)
-.error USE_APACHE and Makefile.modules.3rd can't be used together.
-.endif
-
-APXS?= ${LOCALBASE}/sbin/apxs
-MODULENAME?= ${PORTNAME}
-SHORTMODNAME?= ${MODULENAME:S/mod_//}
-SRC_FILE?= ${MODULENAME}.c
-OVERRIDABLE_VARS= SRC_FILE MODULENAME SHORTMODNAME WRKSRC \
- PKGNAMESUFFIX
-
-.if exists(${LOCALBASE}/include/apache2/http_core.h)
-WITH_APACHE2= YES
-. if defined (WANT_APACHE)
-. if ${WANT_APACHE} == 13
-BROKEN= "This module require apache13 and you have apache2 installed"
-. endif
-. endif
-.elif exists(${LOCALBASE}/include/apache/http_core.h)
-WITH_APACHE13= YES
-. if defined (WANT_APACHE)
-. if ${WANT_APACHE} == 2
-BROKEN= "This module require apache2 and you have apache13 installed"
-. endif
-. endif
-. ifdef(WITH_APACHE2)
-.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but apache13 is installed Please undefine and try again.
-. endif
-.endif
-
-.if defined (WANT_APACHE)
-. if ${WANT_APACHE} == 13
-WITH_APACHE13= YES
-. elif ${WANT_APACHE} == 2
-WITH_APACHE2= YES
-. else
-BROKEN= "Unknown apache version"
-. endif
-.endif
-
-.if defined(WITH_APACHE2)
-AP_BUILDEXT= la
-PLIST_SUB+= APACHEMODDIR="libexec/apache2"
-APACHE_PORT= www/apache2
-AP_VER= 2
-.else
-AP_BUILDEXT= so
-PLIST_SUB+= APACHEMODDIR="libexec/apache"
-APACHE_PORT?= www/apache13
-AP_VER= 13
-.endif
-
-.for VAR in ${OVERRIDABLE_VARS}
-. if defined(AP${AP_VER}_${VAR})
-${VAR}= ${AP${AP_VER}_${VAR}}
-. endif
-.endfor
-
-BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-RUN_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT}
-PLIST_SUB+= AP_NAME="${SHORTMODNAME}"
-PLIST_SUB+= AP_MODULE="${MODULENAME}.so"
-.if defined(AP_GENPLIST)
-PLIST?= ${WRKDIR}/ap-plist
-.endif
-
-.if defined(AP_INC)
-AP_EXTRAS+= -I ${AP_INC}
-.endif
-.if defined(AP_LIB)
-AP_EXTRAS+= -L ${AP_LIB}
-.endif
-
-.if defined(AP_FAST_BUILD)
-
-ap-gen-plist:
-.if defined(AP_GENPLIST)
- @${ECHO} "===> Generating apache plist"
- @${ECHO} "@unexec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%%APACHEMODDIR%%/%%AP_MODULE%%" > ${PLIST}
- @${ECHO} "%%APACHEMODDIR%%/%%AP_MODULE%%" >> ${PLIST}
- @${ECHO} "@exec %D/sbin/apxs -e -A -n %%AP_NAME%% %D/%F" >> ${PLIST}
-.else
- @${DO_NADA}
-.endif
-do-build: ap-gen-plist
- @cd ${WRKSRC} && ${APXS} -c ${AP_EXTRAS} -o ${MODULENAME}.${AP_BUILDEXT} ${SRC_FILE}
-
-do-install:
- @${APXS} -i -A -n ${SHORTMODNAME} ${WRKSRC}/${MODULENAME}.${AP_BUILDEXT}
-.endif