aboutsummaryrefslogtreecommitdiff
path: root/www/horde4-base/files/pkg-deinstall.in
diff options
context:
space:
mode:
Diffstat (limited to 'www/horde4-base/files/pkg-deinstall.in')
-rw-r--r--www/horde4-base/files/pkg-deinstall.in61
1 files changed, 0 insertions, 61 deletions
diff --git a/www/horde4-base/files/pkg-deinstall.in b/www/horde4-base/files/pkg-deinstall.in
deleted file mode 100644
index 47cbca9552a2..000000000000
--- a/www/horde4-base/files/pkg-deinstall.in
+++ /dev/null
@@ -1,61 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-PATH=/usr/sbin:/usr/bin:/bin ; export PATH
-
-handle_config() {
- # Try to restore httpd.conf when deinstalling Horde
-
- if [ -f %%APACHE_CONF%%.beforeHorde ] ; then
- echo "Restoring httpd.conf..."
- cp %%APACHE_CONF%% %%APACHE_CONF%%.deinstHorde
- sed -i.tmp -e "s:Include ${PKG_PREFIX}/etc/horde:# Include ${PKG_PREFIX}/etc/horde:g" \
- %%APACHE_CONF%%
- rm %%APACHE_CONF%%.tmp
- fi
-
- # Backup Horde config files, if needed.
-
- if [ -z "${PACKAGE_BUILDING}" ]; then
- for cf in `ls %%HORDEDIR%%/config/*php`; do
- diff -bBqw $cf $cf.dist >/dev/null 2>&1
- case $? in
- 0) # original config file, will be deleted by pkg-plist
- ;;
- 1) # config file has been updated, must be backuped
- cp -p $cf $cf.previous
- echo "===> Backing-up..."
- echo "---> $cf has been saved ***"
- echo "---> as $cf.previous ***"
- ;;
- *) # not found?
- ;;
- esac
- done
- fi
-}
-
-case $2 in
- DEINSTALL)
- handle_config
- ;;
- POST-DEINSTALL)
- if [ x%%HORDEADMUSR%% != x ]; then
- cat <<EOMSG
-The horde port has been deleted.
-If you are not upgrading and don't intend to use
-Horde any more then you may wish to delete
-the %%HORDEADMUSR%% account, which can be done with
-the following command:
-
- # pw userdel %%HORDEADMUSR%%
-EOMSG
- if [ -d %%PREFIX%%/%%MYADMDIR%% ] ; then
- echo " # rm -rf %%PREFIX%%/%%HORDEDIR%%/"
- fi
- echo
- fi
- ;;
-esac