aboutsummaryrefslogtreecommitdiff
path: root/www/limesurvey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/limesurvey/Makefile')
-rw-r--r--www/limesurvey/Makefile59
1 files changed, 0 insertions, 59 deletions
diff --git a/www/limesurvey/Makefile b/www/limesurvey/Makefile
deleted file mode 100644
index 685aea0ed4cb..000000000000
--- a/www/limesurvey/Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
-# New ports collection makefile for: phpsurveyor
-# Date created: 21 March 2005
-# Whom: janos.mohacsi@bsd.hu
-#
-# $FreeBSD$
-#
-
-PORTNAME= phpsurveyor
-PORTVERSION= 1.0
-PORTREVISION= 1
-CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= limesurvey
-DISTNAME= ${PORTNAME}-1_00
-
-MAINTAINER= janos.mohacsi@bsd.hu
-COMMENT= A PHP-based survey building and runing system
-
-USE_PHP= mysql session
-WRKSRC= ${WRKDIR}
-USE_ZIP= yes
-
-#User-configurable variables
-WWWDOCROOT?= www/
-PHPSURVEYORURL?= phpsurveyor
-#
-# End of user-configurable variables.
-
-# Set/override/append to variables from bsd.port.mk:
-#
-NO_BUILD= yes
-PKGMESSAGE= ${WRKDIR}/pkg-message
-PLIST_SUB+= PHPSURVEYORDIR=${PHPSURVEYORDIR} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
-
-# Set custom variables:
-#
-PHPSURVEYORDIR= ${WWWDOCROOT}/${PHPSURVEYORURL}
-
-post-configure:
- @ ${SED} \
- -e 's#%%PREFIX%%#${PREFIX}#g' \
- -e 's#%%PHPSURVEYORURL%%#${PHPSURVEYORURL}#g' \
- -e 's#%%PHPSURVEYORDIR%%#${PHPSURVEYORDIR}#g' \
- pkg-message > ${PKGMESSAGE}
-
-do-install:
- ${MKDIR} -m 0755 ${PREFIX}/${PHPSURVEYORDIR}
- cd ${WRKSRC} && ${FIND} * \( -name tmp -a -prune \) -o -print \
- | ${TAR} cTf - - | ${TAR} xUCf ${PREFIX}/${PHPSURVEYORDIR} -
- ${MKDIR} ${PREFIX}/${PHPSURVEYORDIR}/tmp
- ${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${PHPSURVEYORDIR}
- ${CHMOD} 755 ${PREFIX}/${PHPSURVEYORDIR}/tmp
-
-post-install:
-.if !defined(BATCH)
- @ ${CAT} ${PKGMESSAGE}
-.endif
-
-.include <bsd.port.mk>