aboutsummaryrefslogtreecommitdiff
path: root/x11-wm/hs-xmonad/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/hs-xmonad/Makefile')
-rw-r--r--x11-wm/hs-xmonad/Makefile43
1 files changed, 0 insertions, 43 deletions
diff --git a/x11-wm/hs-xmonad/Makefile b/x11-wm/hs-xmonad/Makefile
deleted file mode 100644
index aee4c7e25a77..000000000000
--- a/x11-wm/hs-xmonad/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# New ports collection makefile for: xmonad
-# Date created: 2007-10-25
-# Whom: Matthieu Guegan <matt.guegan@free.fr>
-#
-# $FreeBSD$
-#
-
-PORTNAME= xmonad
-PORTVERSION= 0.7
-PORTREVISION= 2
-CATEGORIES= x11-wm haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/xmonad/${PORTVERSION}/
-
-MAINTAINER= matt.guegan@free.fr
-COMMENT= Xmonad is a minimalist and tiling window manager for X
-
-BUILD_DEPENDS= ghc:${PORTSDIR}/lang/ghc \
- hs-x11-ghc>=1.4.1:${PORTSDIR}/x11/hs-x11-ghc
-LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-
-USE_XORG= x11
-
-CABALCMD= ${LOCALBASE}/bin/runghc Setup.lhs
-GHC_VERSION= 6.8.3
-SUBDIR= lib/${PORTNAME}-${PORTVERSION}
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- PORTVERSION=${PORTVERSION} \
- SUBDIR=${SUBDIR}
-
-MAN1= xmonad.1
-
-do-configure:
- cd ${WRKSRC} && ${CABALCMD} configure --ghc --prefix=${PREFIX}
-
-do-build:
- cd ${WRKSRC} && ${CABALCMD} build && ${CABALCMD} register --gen-script
-
-do-install:
- cd ${WRKSRC} && ${CABALCMD} install
- ${INSTALL_MAN} ${WRKSRC}/man/xmonad.1 ${MAN1PREFIX}/man/man1
- ${INSTALL_SCRIPT} ${WRKSRC}/register.sh ${PREFIX}/${SUBDIR}/register.sh
-
-.include <bsd.port.mk>