aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2018-11-01 04:13:59 +0000
committerMark Linimon <linimon@FreeBSD.org>2018-11-01 04:13:59 +0000
commit0a94f777afdec30d21aa65b4ed38123b95389abc (patch)
tree7fbdb12c904b07f0f2637115e1fb2d097f1c5b2f
parente90829c76fd6620ee3f0827df6079cc437b18e3a (diff)
downloadports-0a94f777afdec30d21aa65b4ed38123b95389abc.tar.gz
ports-0a94f777afdec30d21aa65b4ed38123b95389abc.zip
Fix build on powerpc64.
PR: 231954 Submitted by: Piotr Kubaj Approved by: portmgr (tier-2 blanket)
Notes
Notes: svn path=/head/; revision=483636
-rw-r--r--games/7kaa/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/games/7kaa/Makefile b/games/7kaa/Makefile
index b9882d8292c8..9c3b46fdecb4 100644
--- a/games/7kaa/Makefile
+++ b/games/7kaa/Makefile
@@ -20,12 +20,13 @@ BROKEN_armv7= fails to compile: OBULLET.cpp:41:9: constant expression evaluates
LIB_DEPENDS= libenet.so:net/enet \
libcurl.so:ftp/curl
-USES= compiler:c++11-lib gmake localbase openal:al pkgconfig tar:xz
+USES= compiler:c++11-lang gmake localbase openal:al pkgconfig tar:xz
GNU_CONFIGURE= yes
LLD_UNSAFE= yes
CONFIGURE_ARGS= --disable-nls # no translations ATM
USE_SDL= sdl2
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
+CXXFLAGS_powerpc64= -Wno-error=narrowing
CXXFLAGS_clang= -Wno-c++11-narrowing
PLIST_FILES= bin/${PORTNAME} \