aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-08-22 23:58:54 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-08-22 23:58:54 +0000
commit109e5dda19e0ae25a7a91cd35be52f8ec44fc258 (patch)
treefe5e5579feb4067f2ddcc219cc7a998c3f010e6d
parent3f818f2638f67618bf0b4d29b79df8863ab41466 (diff)
downloadports-109e5dda19e0ae25a7a91cd35be52f8ec44fc258.tar.gz
ports-109e5dda19e0ae25a7a91cd35be52f8ec44fc258.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Traceroute6/Makefile24
-rw-r--r--net/p5-Net-Traceroute6/distinfo1
-rw-r--r--net/p5-Net-Traceroute6/pkg-comment1
-rw-r--r--net/p5-Net-Traceroute6/pkg-descr9
-rw-r--r--net/p5-Net-Traceroute6/pkg-plist5
6 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index babc3ea6ecf6..acc051b6cb3e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -265,6 +265,7 @@
SUBDIR += p5-Net-Server
SUBDIR += p5-Net-Telnet
SUBDIR += p5-Net-Traceroute
+ SUBDIR += p5-Net-Traceroute6
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
SUBDIR += p5-Net-XWhois
diff --git a/net/p5-Net-Traceroute6/Makefile b/net/p5-Net-Traceroute6/Makefile
new file mode 100644
index 000000000000..1f2a47bacbaf
--- /dev/null
+++ b/net/p5-Net-Traceroute6/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-Net-Traceroute6
+# Date created: 13 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Traceroute6
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@FreeBSD.org
+
+USE_PERL5= yes
+
+PERL_CONFIGURE= YES
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Net::Traceroute6.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Traceroute6/distinfo b/net/p5-Net-Traceroute6/distinfo
new file mode 100644
index 000000000000..f08facf74a7a
--- /dev/null
+++ b/net/p5-Net-Traceroute6/distinfo
@@ -0,0 +1 @@
+MD5 (Net-Traceroute6-0.01.tar.gz) = 669a0dc3ba6ecf53299e4288cf3a0a03
diff --git a/net/p5-Net-Traceroute6/pkg-comment b/net/p5-Net-Traceroute6/pkg-comment
new file mode 100644
index 000000000000..b95eecfa50dd
--- /dev/null
+++ b/net/p5-Net-Traceroute6/pkg-comment
@@ -0,0 +1 @@
+Perl module to parse traceroute6(8) output
diff --git a/net/p5-Net-Traceroute6/pkg-descr b/net/p5-Net-Traceroute6/pkg-descr
new file mode 100644
index 000000000000..cac8c12a9d7c
--- /dev/null
+++ b/net/p5-Net-Traceroute6/pkg-descr
@@ -0,0 +1,9 @@
+This module implements traceroute6(8) functionality for perl5. It
+allows you to trace the path IP packets take to a destination. It
+is currently implemented as a parser around the system traceroute
+command.
+
+WWW: http://search.cpan.org/search?dist=Net-Traceroute6
+
+- Pete
+petef@FreeBSD.org
diff --git a/net/p5-Net-Traceroute6/pkg-plist b/net/p5-Net-Traceroute6/pkg-plist
new file mode 100644
index 000000000000..3b71151261df
--- /dev/null
+++ b/net/p5-Net-Traceroute6/pkg-plist
@@ -0,0 +1,5 @@
+lib/perl5/site_perl/%%PERL_VER%%/Net/Traceroute6.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Traceroute6/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net/Traceroute6
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Net 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Net 2>/dev/null || true