aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2006-09-09 05:26:46 +0000
committerRong-En Fan <rafan@FreeBSD.org>2006-09-09 05:26:46 +0000
commit12350f4e2488c48fae98f67443a1d343bcd58b1a (patch)
treed9de9348561397741c1ec430e9dc468f9b33c431
parent32b1316d4e182aa39cb6ea646039d676c53605ca (diff)
downloadports-12350f4e2488c48fae98f67443a1d343bcd58b1a.tar.gz
ports-12350f4e2488c48fae98f67443a1d343bcd58b1a.zip
Notes
-rw-r--r--devel/cc65/Makefile134
-rw-r--r--devel/cc65/distinfo6
-rw-r--r--devel/cc65/files/patch-doc_Makefile14
-rw-r--r--devel/cc65/files/patch-make_gcc.mak41
-rw-r--r--devel/cc65/files/pkg-message.in13
-rw-r--r--devel/cc65/pkg-plist254
6 files changed, 240 insertions, 222 deletions
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index dca2f0f21b81..a0ebc330aedc 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -6,14 +6,12 @@
#
PORTNAME= cc65
-PORTVERSION= 2.10.1
+PORTVERSION= 2.11.0
CATEGORIES= devel
MASTER_SITES= ftp://ftp.musoftware.de/pub/uz/cc65/ \
http://www.funet.fi/pub/cbm/programming/cc65/ \
http://www.acc.umu.se/~arvid/cc65_mirror/ \
http://bj.spline.de/cc65/
-# This mirror seems to stop at version 2.7.0
-# ftp://ftp.elysium.pl/tools/crossplatform/programming/c/cc65/ \
DISTNAME= ${PORTNAME}-sources-${PORTVERSION}
MAINTAINER= ssedov@mbsd.msk.ru
@@ -22,115 +20,43 @@ COMMENT= Cross-compiler for 6502-based systems, includes 65816 assembler
USE_SUBMAKE= yes
USE_BZIP2= yes
USE_GMAKE= yes
-CFLAGS+= -DCC65_INC=\\\"${PREFIX}/lib/cc65/include\\\" \
- -DCC65_LIB=\\\"${PREFIX}/lib/cc65/lib\\\" \
- -I${WRKSRC}/src/common -Wall -W -DSPAWN_UNIX
-
-# Need ${WRKSRC} so that the (slightly ugly) != assignments work
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
-.else
-BROKEN= "Does not install on i386"
-.endif
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2006-12-01
-
WRKSRC= ${WRKDIR}/cc65-${PORTVERSION}
+MAKEFILE= ${WRKSRC}/make/gcc.mak
-DEVNULL= ${__empty_string_for_portlint}/dev/null
-
-# These doc files can be compiled using the textproc/sgmltools port
-# XXX sgmltools port was removed, perhaps something else can be
-# used instead
-DOCFILES!= ${LS} ${WRKSRC}/doc 2> ${DEVNULL} | \
- ${SED} -E -e 's/^/doc\//' && ${ECHO_CMD} announce.txt
-
-BINFILES= \
- src/ar65/ar65 src/ca65/ca65 src/cc65/cc65 \
- src/cl65/cl65 src/da65/da65 src/grc/grc src/ld65/ld65 src/od65/od65
-
-BINSCRIPTS= src/ca65html/ca65html
+SUB_FILES= pkg-message
-ASMINCFILES!= ${LS} ${WRKSRC}/asminc 2> ${DEVNULL} | ${EGREP} '\.inc' || true
+# XXX: exists untill it will be committed to bsd.port.mk
+COPYTREE_SHARE= ${SH} -c '(${FIND} -d $$0 $$2 | ${CPIO} -dumpl $$1 >/dev/null \
+ 2>&1) && \
+ ${CHOWN} -R ${SHAREOWN}:${SHAREGRP} $$1 && \
+ ${FIND} $$1/ -type d -exec ${CHMOD} 755 {} \; && \
+ ${FIND} $$1/ -type f -exec ${CHMOD} ${SHAREMODE} {} \;' --
-CC65LIBFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.(o|lib)' \
- || true
-
-CC65EMDFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.emd' || true
+.include <bsd.port.pre.mk>
-CC65TGIFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.tgi' || true
+.if ${OSVERSION} < 500000
+BROKEN does not compile
+.endif
-do-build:
- cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
- cd ${WRKSRC}/libsrc && ${GMAKE} all
+post-patch:
+#
+# CFLAGS safety
+#
+ @(${FIND} ${WRKSRC}/ -name gcc.mak -type f|${XARGS} ${REINPLACE_CMD} -E\
+ -e "s,=[[:space:]]*-g -O2 -Wall -W(.*),+=\1,"\
+ -e "s,=[[:space:]]*-g -O2 -Wall(.*),+=\1,"\
+ -e "s,=[[:space:]]*-O2 -g -Wall -W(.*),+=\1,"\
+ -e "s,CC[[:space:]]*=.*,#&,")
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -E -e "s,(install:.*)install-docs(.*)$,\1\2," \
+ ${WRKSRC}/make/gcc.mak
+.endif
-do-install:
- ${MKDIR} ${PREFIX}/lib/cc65/emd
- ${MKDIR} ${PREFIX}/lib/cc65/lib
- ${MKDIR} ${PREFIX}/lib/cc65/tgi
- ${MKDIR} ${PREFIX}/lib/cc65/asminc
+post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/cc65
- ${INSTALL_DATA} ${DOCFILES:S,^,${WRKSRC}/,} ${PREFIX}/share/doc/cc65
- ${CP} -R ${WRKSRC}/samples ${PREFIX}/share/doc/cc65
- ${FIND} ${PREFIX}/share/doc/cc65/samples -not -type d | \
- ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- ${FIND} ${PREFIX}/share/doc/cc65/samples -not -type d | \
- ${XARGS} ${CHMOD} ${SHAREMODE}
+ ${MKDIR} ${EXAMPLESDIR}
+ @(cd ${WRKSRC}/samples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
- ${INSTALL_PROGRAM} ${BINFILES:S,^,${WRKSRC}/,} ${PREFIX}/bin
- ${INSTALL_SCRIPT} ${BINSCRIPTS:S,^,${WRKSRC}/,} ${PREFIX}/bin
- ${INSTALL_DATA} ${ASMINCFILES:S,^,${WRKSRC}/asminc/,} \
- ${PREFIX}/lib/cc65/asminc
- ${CP} -R ${WRKSRC}/include ${PREFIX}/lib/cc65
- ${FIND} ${PREFIX}/lib/cc65 -not -type d | \
- ${XARGS} ${CHOWN} ${SHAREOWN}:${SHAREGRP}
- ${FIND} ${PREFIX}/lib/cc65 -not -type d | \
- ${XARGS} ${CHMOD} ${SHAREMODE}
- ${INSTALL_DATA} ${CC65LIBFILES:S,^,${WRKSRC}/libsrc/,} \
- ${PREFIX}/lib/cc65/lib
- ${INSTALL_DATA} ${CC65EMDFILES:S,^,${WRKSRC}/libsrc/,} \
- ${PREFIX}/lib/cc65/emd
- ${INSTALL_DATA} ${CC65TGIFILES:S,^,${WRKSRC}/libsrc/,} \
- ${PREFIX}/lib/cc65/tgi
-
-plist:
- @${FIND} ${WRKSRC}/samples -not -type d | \
- ${SED} -E -e 's/^.*cc65.*\/samples/%%PORTDOCS%%share\/doc\/cc65\/samples/'
- @${FIND} ${WRKSRC}/samples -type d | ${SORT} -r | \
- ${SED} -E -e 's/^.*cc65.*\/samples/%%PORTDOCS%%@dirrm share\/doc\/cc65\/samples/'
-.for filename in ${DOCFILES}
- @${ECHO_CMD} %%PORTDOCS%%share/doc/cc65/`${BASENAME} ${filename}`
-.endfor
- @${ECHO_CMD} %%PORTDOCS%%@dirrm share/doc/cc65
-.for filename in ${BINFILES}
- @${ECHO_CMD} bin/`${BASENAME} ${filename}`
-.endfor
-.for filename in ${BINSCRIPTS}
- @${ECHO_CMD} bin/`${BASENAME} ${filename}`
-.endfor
-.for filename in ${ASMINCFILES}
- @${ECHO_CMD} lib/cc65/asminc/`${BASENAME} ${filename}`
-.endfor
- @${FIND} ${WRKSRC}/include -not -type d | \
- ${SED} -E -e 's/^.*cc65.*\/include/lib\/cc65\/include/'
- @${FIND} ${WRKSRC}/include -type d | ${SORT} -r | \
- ${SED} -E -e 's/^.*cc65.*\/include/@dirrm lib\/cc65\/include/'
-.for filename in ${CC65LIBFILES}
- @${ECHO_CMD} lib/cc65/lib/`${BASENAME} ${filename}`
-.endfor
-.for filename in ${CC65EMDFILES}
- @${ECHO_CMD} lib/cc65/emd/`${BASENAME} ${filename}`
-.endfor
-.for filename in ${CC65TGIFILES}
- @${ECHO_CMD} lib/cc65/tgi/`${BASENAME} ${filename}`
-.endfor
- @${ECHO_CMD} @dirrm lib/cc65/emd
- @${ECHO_CMD} @dirrm lib/cc65/lib
- @${ECHO_CMD} @dirrm lib/cc65/tgi
- @${ECHO_CMD} @dirrm lib/cc65/asminc
- @${ECHO_CMD} @dirrm lib/cc65
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/devel/cc65/distinfo b/devel/cc65/distinfo
index 7c25b001548c..361f80bc8af9 100644
--- a/devel/cc65/distinfo
+++ b/devel/cc65/distinfo
@@ -1,3 +1,3 @@
-MD5 (cc65-sources-2.10.1.tar.bz2) = ea600666a514a792d2a18c4af2859380
-SHA256 (cc65-sources-2.10.1.tar.bz2) = 31f99b0e9a9c02493c391ba3e30c148a60d5077151facb4a155813562db3c07b
-SIZE (cc65-sources-2.10.1.tar.bz2) = 889004
+MD5 (cc65-sources-2.11.0.tar.bz2) = 0f69e04abb640a5d644d912bcdbcf52d
+SHA256 (cc65-sources-2.11.0.tar.bz2) = a430a3d221a2364ff55282b169bf5ae78e00bf9dfc8babea9922ff8a8e16a600
+SIZE (cc65-sources-2.11.0.tar.bz2) = 1004878
diff --git a/devel/cc65/files/patch-doc_Makefile b/devel/cc65/files/patch-doc_Makefile
deleted file mode 100644
index 4c40617774ea..000000000000
--- a/devel/cc65/files/patch-doc_Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- doc/Makefile.orig Mon Sep 2 12:12:59 2002
-+++ doc/Makefile Mon Sep 2 12:13:01 2002
-@@ -1,6 +1,8 @@
- #
- # Makefile for the cc65 documentation
- #
-+# These can be built using the textproc/sgmltools port.
-+#
-
-
- # Default for the compiler lib search path as compiler define
diff --git a/devel/cc65/files/patch-make_gcc.mak b/devel/cc65/files/patch-make_gcc.mak
new file mode 100644
index 000000000000..da4f6b4e78f5
--- /dev/null
+++ b/devel/cc65/files/patch-make_gcc.mak
@@ -0,0 +1,41 @@
+--- make/gcc.mak.orig Sat Sep 10 16:45:50 2005
++++ make/gcc.mak Thu Sep 7 20:39:52 2006
+@@ -14,7 +14,7 @@
+ MAKEOVERRIDES=
+
+ # The install prefix and directories
+-prefix = /usr
++prefix = ${PREFIX}
+ exec_prefix = $(prefix)
+
+ bindir = $(exec_prefix)/bin
+@@ -37,9 +37,9 @@
+ INSTALL = install
+ #INSTALL = install-sh
+
+-INSTALL_DATA = $(INSTALL) -c -m 644
+-INSTALL_PROG = $(INSTALL) -c -m 755
+-INSTALL_STRIP = $(INSTALL_PROG) -s
++INSTALL_DATA = ${BSD_INSTALL_DATA}
++INSTALL_PROG = ${BSD_INSTALL_SCRIPT}
++INSTALL_STRIP = ${BSD_INSTALL_PROGRAM}
+
+ # Rules
+
+@@ -48,7 +48,7 @@
+ # a system on the command-line. (A user can do those rules with their
+ # defaults by putting "all samples tests" on the command-line.)
+ #
+-all: bins libs docs $(SYS:%=samples tests)
++all: bins libs $(SYS:%=samples tests)
+
+ bins:
+ @$(MAKE) -C src -f make/gcc.mak
+@@ -139,7 +139,4 @@
+ done
+ for f in readme.1st compile.txt CREDITS BUGS internal.txt newvers.txt; \
+ do $(INSTALL_DATA) doc/$$f $(CC65DOC) || exit 1; \
+- done
+- -for f in doc/*.html; \
+- do $(INSTALL_DATA) $$f $(CC65DOC) || exit 1; \
+ done
diff --git a/devel/cc65/files/pkg-message.in b/devel/cc65/files/pkg-message.in
new file mode 100644
index 000000000000..801dbe41461b
--- /dev/null
+++ b/devel/cc65/files/pkg-message.in
@@ -0,0 +1,13 @@
+===============================================================================
+
+You should exports the following enviropment variables:
+
+export CC65_INC=%%PREFIX%%/lib/cc65/include
+export CC65_LIB=%%PREFIX%%/lib/cc65/lib
+
+or for csh users:
+
+setenv CC65_INC %%PREFIX%%/lib/cc65/include
+setenv CC65_LIB %%PREFIX%%/lib/cc65/lib
+
+===============================================================================
diff --git a/devel/cc65/pkg-plist b/devel/cc65/pkg-plist
index 026b10ecfaed..6f04962ddebf 100644
--- a/devel/cc65/pkg-plist
+++ b/devel/cc65/pkg-plist
@@ -1,82 +1,9 @@
-%%PORTDOCS%%share/doc/cc65/samples/Makefile
-%%PORTDOCS%%share/doc/cc65/samples/README
-%%PORTDOCS%%share/doc/cc65/samples/ascii.c
-%%PORTDOCS%%share/doc/cc65/samples/fire.c
-%%PORTDOCS%%share/doc/cc65/samples/gunzip65.c
-%%PORTDOCS%%share/doc/cc65/samples/hello.c
-%%PORTDOCS%%share/doc/cc65/samples/mousedemo.c
-%%PORTDOCS%%share/doc/cc65/samples/nachtm.c
-%%PORTDOCS%%share/doc/cc65/samples/plasma.c
-%%PORTDOCS%%share/doc/cc65/samples/sieve.c
-%%PORTDOCS%%share/doc/cc65/samples/tgidemo.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/appfile.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/apphello1.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/apphello2.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/apprmvprot.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/appvector-demo.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/appyesno.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/dialog.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/filesel.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/geosconio.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/geosconiores.res
-%%PORTDOCS%%share/doc/cc65/samples/geos/grphstr.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/hello1.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/hello2.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/inittab.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/menu.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/rmvprot.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/vector-demo.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/yesno.c
-%%PORTDOCS%%share/doc/cc65/samples/geos/ca65-vlir/Makefile
-%%PORTDOCS%%share/doc/cc65/samples/geos/ca65-vlir/cvthead.grc
-%%PORTDOCS%%share/doc/cc65/samples/geos/ca65-vlir/vlir0.s
-%%PORTDOCS%%share/doc/cc65/samples/geos/ca65-vlir/vlir1.s
-%%PORTDOCS%%share/doc/cc65/samples/geos/ca65-vlir/vlir2.s
-%%PORTDOCS%%share/doc/cc65/samples/tutorial/hello.c
-%%PORTDOCS%%share/doc/cc65/samples/tutorial/text.s
-%%PORTDOCS%%@dirrm share/doc/cc65/samples/tutorial
-%%PORTDOCS%%@dirrm share/doc/cc65/samples/geos/ca65-vlir
-%%PORTDOCS%%@dirrm share/doc/cc65/samples/geos
-%%PORTDOCS%%@dirrm share/doc/cc65/samples
-share/doc/cc65/BUGS
-share/doc/cc65/CREDITS
-share/doc/cc65/Makefile
-share/doc/cc65/Makefile.orig
-share/doc/cc65/announce.txt
-share/doc/cc65/apple2.sgml
-share/doc/cc65/ar65.sgml
-share/doc/cc65/atari.sgml
-share/doc/cc65/c128.sgml
-share/doc/cc65/c16.sgml
-share/doc/cc65/c64.sgml
-share/doc/cc65/ca65.sgml
-share/doc/cc65/ca65html.sgml
-share/doc/cc65/cbm610.sgml
-share/doc/cc65/cc65.sgml
-share/doc/cc65/cl65.sgml
-share/doc/cc65/co65.sgml
-share/doc/cc65/coding.sgml
-share/doc/cc65/compile.txt
-share/doc/cc65/da65.sgml
-share/doc/cc65/debugging.sgml
-share/doc/cc65/dio.sgml
-share/doc/cc65/funcref.sgml
-share/doc/cc65/geos.sgml
-share/doc/cc65/grc.txt
-share/doc/cc65/index.sgml
-share/doc/cc65/internal.txt
-share/doc/cc65/intro.sgml
-share/doc/cc65/ld65.sgml
-share/doc/cc65/library.sgml
-share/doc/cc65/newvers.txt
-share/doc/cc65/plus4.sgml
-share/doc/cc65/readme.1st
-%%PORTDOCS%%@dirrm share/doc/cc65
bin/ar65
bin/ca65
bin/ca65html
bin/cc65
bin/cl65
+bin/co65
bin/da65
bin/grc
bin/ld65
@@ -89,9 +16,12 @@ lib/cc65/asminc/em-error.inc
lib/cc65/asminc/em-kernel.inc
lib/cc65/asminc/errno.inc
lib/cc65/asminc/fcntl.inc
+lib/cc65/asminc/get_tv.inc
lib/cc65/asminc/joy-error.inc
lib/cc65/asminc/joy-kernel.inc
+lib/cc65/asminc/lynx.inc
lib/cc65/asminc/modload.inc
+lib/cc65/asminc/mouse-kernel.inc
lib/cc65/asminc/o65.inc
lib/cc65/asminc/rs232.inc
lib/cc65/asminc/ser-error.inc
@@ -104,6 +34,7 @@ lib/cc65/asminc/tgi-mode.inc
lib/cc65/asminc/utsname.inc
lib/cc65/asminc/zeropage.inc
lib/cc65/emd/a2.lc.emd
+lib/cc65/emd/a2e.lc.emd
lib/cc65/emd/c128-georam.emd
lib/cc65/emd/c128-ram.emd
lib/cc65/emd/c128-ramcart.emd
@@ -119,6 +50,7 @@ lib/cc65/emd/cbm510-ram.emd
lib/cc65/emd/cbm610-ram.emd
lib/cc65/emd/geos-vdc.emd
lib/cc65/include/6502.h
+lib/cc65/include/_6522.h
lib/cc65/include/_6525.h
lib/cc65/include/_6526.h
lib/cc65/include/_6545.h
@@ -136,6 +68,7 @@ lib/cc65/include/_vic.h
lib/cc65/include/_vic2.h
lib/cc65/include/ace.h
lib/cc65/include/apple2.h
+lib/cc65/include/apple2enh.h
lib/cc65/include/assert.h
lib/cc65/include/atari.h
lib/cc65/include/atmos.h
@@ -150,16 +83,33 @@ lib/cc65/include/conio.h
lib/cc65/include/ctype.h
lib/cc65/include/dbg.h
lib/cc65/include/dio.h
+lib/cc65/include/dirent.h
lib/cc65/include/em.h
+lib/cc65/include/em/em-kernel.h
lib/cc65/include/errno.h
lib/cc65/include/fcntl.h
lib/cc65/include/geos.h
+lib/cc65/include/geos/gconst.h
+lib/cc65/include/geos/gdisk.h
+lib/cc65/include/geos/gdlgbox.h
+lib/cc65/include/geos/gfile.h
+lib/cc65/include/geos/ggraph.h
+lib/cc65/include/geos/gmemory.h
+lib/cc65/include/geos/gmenu.h
+lib/cc65/include/geos/gprocess.h
+lib/cc65/include/geos/gsprite.h
+lib/cc65/include/geos/gstruct.h
+lib/cc65/include/geos/gsym.h
+lib/cc65/include/geos/gsys.h
lib/cc65/include/iso646.h
lib/cc65/include/joystick.h
+lib/cc65/include/joystick/joy-kernel.h
lib/cc65/include/limits.h
lib/cc65/include/locale.h
+lib/cc65/include/lynx.h
lib/cc65/include/modload.h
lib/cc65/include/mouse.h
+lib/cc65/include/mouse/mouse-kernel.h
lib/cc65/include/nes.h
lib/cc65/include/o65.h
lib/cc65/include/peekpoke.h
@@ -177,38 +127,38 @@ lib/cc65/include/stdio.h
lib/cc65/include/stdlib.h
lib/cc65/include/string.h
lib/cc65/include/supervision.h
-lib/cc65/include/tgi.h
-lib/cc65/include/time.h
-lib/cc65/include/unistd.h
-lib/cc65/include/vic20.h
-lib/cc65/include/zlib.h
-lib/cc65/include/em/em-kernel.h
-lib/cc65/include/geos/gconst.h
-lib/cc65/include/geos/gdisk.h
-lib/cc65/include/geos/gdlgbox.h
-lib/cc65/include/geos/gfile.h
-lib/cc65/include/geos/ggraph.h
-lib/cc65/include/geos/gmemory.h
-lib/cc65/include/geos/gmenu.h
-lib/cc65/include/geos/gprocess.h
-lib/cc65/include/geos/gsprite.h
-lib/cc65/include/geos/gstruct.h
-lib/cc65/include/geos/gsym.h
-lib/cc65/include/geos/gsys.h
-lib/cc65/include/joystick/joy-kernel.h
lib/cc65/include/sys/types.h
lib/cc65/include/sys/utsname.h
+lib/cc65/include/tgi.h
lib/cc65/include/tgi/tgi-error.h
lib/cc65/include/tgi/tgi-kernel.h
lib/cc65/include/tgi/tgi-mode.h
-@dirrm lib/cc65/include/tgi
-@dirrm lib/cc65/include/sys
-@dirrm lib/cc65/include/joystick
-@dirrm lib/cc65/include/geos
-@dirrm lib/cc65/include/em
-@dirrm lib/cc65/include
+lib/cc65/include/time.h
+lib/cc65/include/unistd.h
+lib/cc65/include/vic20.h
+lib/cc65/include/zlib.h
+lib/cc65/joy/a2.stdjoy.joy
+lib/cc65/joy/a2e.stdjoy.joy
+lib/cc65/joy/ataristd.joy
+lib/cc65/joy/c128-ptvjoy.joy
+lib/cc65/joy/c128-stdjoy.joy
+lib/cc65/joy/c16-stdjoy.joy
+lib/cc65/joy/c64-hitjoy.joy
+lib/cc65/joy/c64-numpad.joy
+lib/cc65/joy/c64-ptvjoy.joy
+lib/cc65/joy/c64-stdjoy.joy
+lib/cc65/joy/cbm510-std.joy
+lib/cc65/joy/geos-stdjoy.joy
+lib/cc65/joy/lynx-stdjoy.joy
+lib/cc65/joy/nes-stdjoy.joy
+lib/cc65/joy/pet-ptvjoy.joy
+lib/cc65/joy/plus4-stdjoy.joy
+lib/cc65/joy/vic20-ptvjoy.joy
+lib/cc65/joy/vic20-stdjoy.joy
lib/cc65/lib/apple2.lib
lib/cc65/lib/apple2.o
+lib/cc65/lib/apple2enh.lib
+lib/cc65/lib/apple2enh.o
lib/cc65/lib/atari.lib
lib/cc65/lib/atari.o
lib/cc65/lib/atmos.lib
@@ -225,6 +175,8 @@ lib/cc65/lib/cbm610.lib
lib/cc65/lib/cbm610.o
lib/cc65/lib/geos.lib
lib/cc65/lib/geos.o
+lib/cc65/lib/lynx.lib
+lib/cc65/lib/lynx.o
lib/cc65/lib/nes.lib
lib/cc65/lib/nes.o
lib/cc65/lib/pet.lib
@@ -235,14 +187,114 @@ lib/cc65/lib/supervision.lib
lib/cc65/lib/supervision.o
lib/cc65/lib/vic20.lib
lib/cc65/lib/vic20.o
+lib/cc65/mou/c128-1351.mou
+lib/cc65/mou/c128-joy.mou
+lib/cc65/mou/c64-1351.mou
+lib/cc65/mou/c64-joy.mou
+lib/cc65/ser/a2.ssc.ser
+lib/cc65/ser/a2e.ssc.ser
+lib/cc65/ser/c128-swlink.ser
+lib/cc65/ser/c64-swlink.ser
+lib/cc65/ser/cbm510-std.ser
+lib/cc65/ser/cbm610-std.ser
+lib/cc65/ser/plus4-stdser.ser
lib/cc65/tgi/a2.hi.tgi
lib/cc65/tgi/a2.lo.tgi
+lib/cc65/tgi/a2e.hi.tgi
+lib/cc65/tgi/a2e.lo.tgi
+lib/cc65/tgi/atmos-240-200-2.tgi
lib/cc65/tgi/c128-vdc.tgi
lib/cc65/tgi/c128-vdc2.tgi
lib/cc65/tgi/c64-hi.tgi
lib/cc65/tgi/geos-tgi.tgi
-@dirrm lib/cc65/emd
-@dirrm lib/cc65/lib
+lib/cc65/tgi/lynx-160-102-16.tgi
+%%PORTDOCS%%%%DOCSDIR%%/BUGS
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/apple2-tgi.cfg
+%%PORTDOCS%%%%DOCSDIR%%/apple2.cfg
+%%PORTDOCS%%%%DOCSDIR%%/atari.cfg
+%%PORTDOCS%%%%DOCSDIR%%/atmos.cfg
+%%PORTDOCS%%%%DOCSDIR%%/bbc.cfg
+%%PORTDOCS%%%%DOCSDIR%%/c128.cfg
+%%PORTDOCS%%%%DOCSDIR%%/c16.cfg
+%%PORTDOCS%%%%DOCSDIR%%/c64.cfg
+%%PORTDOCS%%%%DOCSDIR%%/cbm510.cfg
+%%PORTDOCS%%%%DOCSDIR%%/cbm610.cfg
+%%PORTDOCS%%%%DOCSDIR%%/compile.txt
+%%PORTDOCS%%%%DOCSDIR%%/geos.cfg
+%%PORTDOCS%%%%DOCSDIR%%/internal.txt
+%%PORTDOCS%%%%DOCSDIR%%/lunix.cfg
+%%PORTDOCS%%%%DOCSDIR%%/lynx.cfg
+%%PORTDOCS%%%%DOCSDIR%%/module.cfg
+%%PORTDOCS%%%%DOCSDIR%%/nes.cfg
+%%PORTDOCS%%%%DOCSDIR%%/newvers.txt
+%%PORTDOCS%%%%DOCSDIR%%/none.cfg
+%%PORTDOCS%%%%DOCSDIR%%/osa65.cfg
+%%PORTDOCS%%%%DOCSDIR%%/pet.cfg
+%%PORTDOCS%%%%DOCSDIR%%/plus4.cfg
+%%PORTDOCS%%%%DOCSDIR%%/readme.1st
+%%PORTDOCS%%%%DOCSDIR%%/supervision.cfg
+%%PORTDOCS%%%%DOCSDIR%%/supervision128.cfg
+%%PORTDOCS%%%%DOCSDIR%%/supervision16.cfg
+%%PORTDOCS%%%%DOCSDIR%%/supervision64.cfg
+%%PORTDOCS%%%%DOCSDIR%%/vic20.cfg
+%%PORTDOCS%%%%EXAMPLESDIR%%/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/ascii.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/diodemo.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/fire.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/appfile.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/apphello1.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/apphello2.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/apprmvprot.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/appvector-demo.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/appyesno.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/ca65-vlir/Makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/ca65-vlir/cvthead.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/ca65-vlir/vlir0.s
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/ca65-vlir/vlir1.s
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/ca65-vlir/vlir2.s
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/dialog.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/filesel.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/geosconio.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/geosconiores.res
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/getid.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/getidres.grc
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/grphstr.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/hello1.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/hello2.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/inittab.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/menu.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/rmvprot.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/vector-demo.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/geos/yesno.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/gunzip65.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/hello.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/mandelbrot.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/mousedemo.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/nachtm.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/plasma.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/sieve.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tgidemo.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/hello.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/tutorial/text.s
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/tutorial
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/geos/ca65-vlir
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/geos
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/cc65/tgi
+@dirrm lib/cc65/ser
+@dirrm lib/cc65/mou
+@dirrm lib/cc65/lib
+@dirrm lib/cc65/joy
+@dirrm lib/cc65/include/tgi
+@dirrm lib/cc65/include/sys
+@dirrm lib/cc65/include/mouse
+@dirrm lib/cc65/include/joystick
+@dirrm lib/cc65/include/geos
+@dirrm lib/cc65/include/em
+@dirrm lib/cc65/include
+@dirrm lib/cc65/emd
@dirrm lib/cc65/asminc
@dirrm lib/cc65