aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2013-09-23 21:02:19 +0000
committerRene Ladan <rene@FreeBSD.org>2013-09-23 21:02:19 +0000
commit1cae283b41a6813d35c133c904b94167401281f6 (patch)
treed3bdbd6336b6d0cdc3d9ca3845ebe6415c530af2
parent3dc4c7dffb182306181559edb29b0c5b8eb21e3a (diff)
downloadports-1cae283b41a6813d35c133c904b94167401281f6.tar.gz
ports-1cae283b41a6813d35c133c904b94167401281f6.zip
Notes
-rw-r--r--astro/boinc-astropulse/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/astro/boinc-astropulse/Makefile b/astro/boinc-astropulse/Makefile
index e30d9d3de419..5a4969d78a74 100644
--- a/astro/boinc-astropulse/Makefile
+++ b/astro/boinc-astropulse/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/fftw3.h:${PORTSDIR}/math/fftw3 \
RUN_DEPENDS= boinc_client:${PORTSDIR}/net/boinc-client
LIB_DEPENDS= libfftw3f.so:${PORTSDIR}/math/fftw3-float
-NO_STAGE= yes
USES= gmake pkgconfig
USE_XZ= yes
USE_AUTOTOOLS= autoconf:env automake:env libtool
@@ -84,18 +83,20 @@ pre-configure:
(cd ${WRKSRC} ; ./_autosetup)
do-install:
- ${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} ${BOINC_CLIENT_HOME}/projects
${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects
+ ${INSTALL} -d -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${WRKSRC}/${AP_BINARY} ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
+ ${WRKSRC}/${AP_BINARY} \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.if ${PORT_OPTIONS:MX11}
${INSTALL_PROGRAM} -o ${BOINC_CLIENT_USER} -g ${BOINC_CLIENT_GROUP} \
- ${WRKSRC}/ap_graphics ${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
+ ${WRKSRC}/ap_graphics \
+ ${STAGEDIR}${BOINC_CLIENT_HOME}/projects/${SETI_SITE}/
.endif
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
- @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>