aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-03-29 01:23:56 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-03-29 01:23:56 +0000
commit24b7d817bd4b62df0451d98c14e37701d31b8325 (patch)
tree3a9f6c28c3ab36053cf8c64ea6cabaecb79a6d50
parent055063ecf555aeae59f6900de09984b97e159d4e (diff)
downloadports-24b7d817bd4b62df0451d98c14e37701d31b8325.tar.gz
ports-24b7d817bd4b62df0451d98c14e37701d31b8325.zip
Notes
-rw-r--r--devel/ups-debug/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/ups-debug/Makefile b/devel/ups-debug/Makefile
index 391a2e2de50b..75dd185a249a 100644
--- a/devel/ups-debug/Makefile
+++ b/devel/ups-debug/Makefile
@@ -24,6 +24,14 @@ ALL_TARGET= ups
MAN1= ups.1
DOCS= CHANGES FAQ README
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != i386 || ${OSVERSION} > 500000
+BROKEN= "compiles only under -STABLE on i386"
+# Avoid building packages on bento for unsupported platforms
+IGNORE= ${BROKEN}
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -33,4 +41,4 @@ post-install:
.endif
${INSTALL_DATA} ${WRKSRC}/Ups ${X11BASE}/lib/X11/app-defaults
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>