aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-29 14:34:03 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-29 14:34:03 +0000
commit27d523fd79942bd85a217a9bf100147ad45c5290 (patch)
tree457a996b27185ba62fef1896f2ddb7187984c059
parent26c49e25b38c18ec3cd911a4ff5fd37455ff2ff3 (diff)
downloadports-27d523fd79942bd85a217a9bf100147ad45c5290.tar.gz
ports-27d523fd79942bd85a217a9bf100147ad45c5290.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/vii/Makefile26
-rw-r--r--sysutils/vii/distinfo2
-rw-r--r--sysutils/vii/pkg-descr14
4 files changed, 43 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 2537efbfe26f..8330dfcacf23 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -531,6 +531,7 @@
SUBDIR += uwatch
SUBDIR += vcp
SUBDIR += videogen
+ SUBDIR += vii
SUBDIR += virtualmin
SUBDIR += vobcopy
SUBDIR += vttest
diff --git a/sysutils/vii/Makefile b/sysutils/vii/Makefile
new file mode 100644
index 000000000000..6666ab10bcd6
--- /dev/null
+++ b/sysutils/vii/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: vii
+# Date created: 12 Aug 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vii
+PORTVERSION= 4.0
+CATEGORIES= sysutils
+MASTER_SITES= http://vii.sourceforge.net/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= Execute a command repeatedly and scroll the output
+
+GNU_CONFIGURE= yes
+MAKE_ARGS+= CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/vii
+MAN1= vii.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man1/${PORTNAME}.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/vii/distinfo b/sysutils/vii/distinfo
new file mode 100644
index 000000000000..5903f284f640
--- /dev/null
+++ b/sysutils/vii/distinfo
@@ -0,0 +1,2 @@
+MD5 (vii-4.0.tar.gz) = ffdcbf72ef961cac01a15911ae5a73c8
+SIZE (vii-4.0.tar.gz) = 120680
diff --git a/sysutils/vii/pkg-descr b/sysutils/vii/pkg-descr
new file mode 100644
index 000000000000..8073a6c83382
--- /dev/null
+++ b/sysutils/vii/pkg-descr
@@ -0,0 +1,14 @@
+Vii (pronounced seven) is a simple program which accepts input from the
+standard input and displays pages of the input on the terminal.
+
+These pages are delimited by form-feeds (or EOF). The display can be scrolled
+if the output is wider or longer than the screen.
+
+Vii can also repeatedly execute a command (at a configurable interval) and the
+most recent output is displayed. This is useful for status monitoring where the
+command itself does not have a repeatable or curses interface.
+
+WWW: http://vii.sourceforge.net/
+
+- ehaupt
+ehaupt@critical.ch