aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-10-31 15:47:27 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-10-31 15:47:27 +0000
commit33bfd768cb9c9688841822a306d081551734ac0a (patch)
tree4a15182548d2dfd5e724ae5398432466d675afc3
parent2ebf96d98df924ef81e49469eb879dfc9f684c77 (diff)
downloadports-33bfd768cb9c9688841822a306d081551734ac0a.tar.gz
ports-33bfd768cb9c9688841822a306d081551734ac0a.zip
Update to latest commit.
Notes
Notes: svn path=/head/; revision=483596
-rw-r--r--dns/bind9-devel/Makefile4
-rw-r--r--dns/bind9-devel/distinfo6
-rw-r--r--dns/bind9-devel/files/extrapatch-bind-min-override-ttl14
-rw-r--r--dns/bind9-devel/files/patch-configure8
-rw-r--r--dns/bind9-devel/pkg-plist8
5 files changed, 19 insertions, 21 deletions
diff --git a/dns/bind9-devel/Makefile b/dns/bind9-devel/Makefile
index 599d571b91f4..2667d54d78f0 100644
--- a/dns/bind9-devel/Makefile
+++ b/dns/bind9-devel/Makefile
@@ -40,13 +40,13 @@ LIB_DEPENDS= libxml2.so:textproc/libxml2
# XXX: remove tar:bz2
USES= cpe libedit ssl tar:bz2
# ISC releases things like 9.8.0-P1, which our versioning doesn't like
-ISCVERSION= 9.13.1a0.2018.10.23
+ISCVERSION= 9.13.1a0.2018.10.31
# XXX: Remove gitlab
USE_GITLAB= yes
GL_SITE= https://gitlab.isc.org
GL_ACCOUNT= isc-projects
GL_PROJECT= bind9
-GL_COMMIT= ed35755a24416e93670e7815f0f6f542b9de1570
+GL_COMMIT= 97bb9b2be91af38b7d70aeac76581f5402776c73
CPE_VENDOR= isc
CPE_VERSION= ${ISCVERSION:C/-.*//}
diff --git a/dns/bind9-devel/distinfo b/dns/bind9-devel/distinfo
index f47995a7e226..92eb5727a303 100644
--- a/dns/bind9-devel/distinfo
+++ b/dns/bind9-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1540363221
-SHA256 (isc-projects-bind9-ed35755a24416e93670e7815f0f6f542b9de1570_GL0.tar.gz) = 4d18ba06be3c26391669028999d32b7258efce279d6315ef586f4ad9a43045aa
-SIZE (isc-projects-bind9-ed35755a24416e93670e7815f0f6f542b9de1570_GL0.tar.gz) = 7266198
+TIMESTAMP = 1540998998
+SHA256 (isc-projects-bind9-97bb9b2be91af38b7d70aeac76581f5402776c73_GL0.tar.gz) = c477c852f21ffa900b95d36d8d2fc3240139b3675ccc7321e0be9d0e47318ffe
+SIZE (isc-projects-bind9-97bb9b2be91af38b7d70aeac76581f5402776c73_GL0.tar.gz) = 7267166
diff --git a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
index 4eba563b458a..13433158014c 100644
--- a/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
+++ b/dns/bind9-devel/files/extrapatch-bind-min-override-ttl
@@ -1,4 +1,4 @@
---- bin/named/config.c.orig 2018-10-24 02:49:29 UTC
+--- bin/named/config.c.orig 2018-10-31 13:26:42 UTC
+++ bin/named/config.c
@@ -174,12 +174,14 @@ options {\n\
max-recursion-queries 75;\n\
@@ -15,9 +15,9 @@
provide-ixfr true;\n\
qname-minimization relaxed;\n\
query-source address *;\n\
---- bin/named/server.c.orig 2018-10-24 02:49:29 UTC
+--- bin/named/server.c.orig 2018-10-31 13:26:42 UTC
+++ bin/named/server.c
-@@ -4102,6 +4102,16 @@ configure_view(dns_view_t *view, dns_vie
+@@ -4101,6 +4101,16 @@ configure_view(dns_view_t *view, dns_vie
}
obj = NULL;
@@ -34,7 +34,7 @@
result = named_config_get(maps, "max-cache-ttl", &obj);
INSIST(result == ISC_R_SUCCESS);
view->maxcachettl = cfg_obj_asuint32(obj);
---- lib/dns/include/dns/view.h.orig 2018-10-24 02:49:29 UTC
+--- lib/dns/include/dns/view.h.orig 2018-10-31 13:26:42 UTC
+++ lib/dns/include/dns/view.h
@@ -153,6 +153,8 @@ struct dns_view {
bool requestnsid;
@@ -45,9 +45,9 @@
dns_ttl_t maxncachettl;
uint32_t nta_lifetime;
uint32_t nta_recheck;
---- lib/dns/resolver.c.orig 2018-10-24 02:49:29 UTC
+--- lib/dns/resolver.c.orig 2018-10-31 13:26:42 UTC
+++ lib/dns/resolver.c
-@@ -5936,6 +5936,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
+@@ -5926,6 +5926,18 @@ cache_name(fetchctx_t *fctx, dns_name_t
}
/*
@@ -66,7 +66,7 @@
* Enforce the configure maximum cache TTL.
*/
if (rdataset->ttl > res->view->maxcachettl) {
---- lib/isccfg/namedconf.c.orig 2018-10-24 02:49:29 UTC
+--- lib/isccfg/namedconf.c.orig 2018-10-31 13:26:42 UTC
+++ lib/isccfg/namedconf.c
@@ -1921,6 +1921,8 @@ view_clauses[] = {
{ "max-acache-size", &cfg_type_sizenodefault,
diff --git a/dns/bind9-devel/files/patch-configure b/dns/bind9-devel/files/patch-configure
index 21887f7433a8..c755393270a1 100644
--- a/dns/bind9-devel/files/patch-configure
+++ b/dns/bind9-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-10-24 02:49:29 UTC
+--- configure.orig 2018-10-31 13:26:42 UTC
+++ configure
-@@ -16276,27 +16276,9 @@ done
+@@ -16328,27 +16328,9 @@ done
# problems start to show up.
saved_libs="$LIBS"
for TRY_LIBS in \
@@ -30,7 +30,7 @@
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking linking as $TRY_LIBS" >&5
$as_echo_n "checking linking as $TRY_LIBS... " >&6; }
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
-@@ -16339,47 +16321,7 @@ $as_echo "no" >&6; } ;;
+@@ -16391,47 +16373,7 @@ $as_echo "no" >&6; } ;;
no) as_fn_error $? "could not determine proper GSSAPI linkage" "$LINENO" 5 ;;
esac
@@ -79,7 +79,7 @@
DNS_GSSAPI_LIBS="$LIBS"
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: using GSSAPI from $use_gssapi/lib and $use_gssapi/include" >&5
-@@ -20882,7 +20824,7 @@ $as_echo "" >&6; }
+@@ -20980,7 +20922,7 @@ $as_echo "" >&6; }
# Check other locations for includes.
# Order is important (sigh).
diff --git a/dns/bind9-devel/pkg-plist b/dns/bind9-devel/pkg-plist
index 7d1cd6af1da3..863c95b0f5b1 100644
--- a/dns/bind9-devel/pkg-plist
+++ b/dns/bind9-devel/pkg-plist
@@ -160,8 +160,7 @@ include/isc/fuzz.h
include/isc/hash.h
include/isc/heap.h
include/isc/hex.h
-include/isc/hmacmd5.h
-include/isc/hmacsha.h
+include/isc/hmac.h
include/isc/ht.h
include/isc/httpd.h
include/isc/interfaceiter.h
@@ -175,7 +174,7 @@ include/isc/likely.h
include/isc/list.h
include/isc/log.h
include/isc/magic.h
-include/isc/md5.h
+include/isc/md.h
include/isc/mem.h
include/isc/meminfo.h
include/isc/msgcat.h
@@ -209,12 +208,11 @@ include/isc/resultclass.h
include/isc/rwlock.h
include/isc/safe.h
include/isc/serial.h
-include/isc/sha1.h
-include/isc/sha2.h
include/isc/sockaddr.h
include/isc/socket.h
include/isc/stat.h
include/isc/stats.h
+include/isc/stdatomic.h
include/isc/stdio.h
include/isc/stdtime.h
include/isc/strerr.h