aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2004-08-12 12:48:01 +0000
committerMathieu Arnold <mat@FreeBSD.org>2004-08-12 12:48:01 +0000
commit3a7b17911b12b557fc9c450a975d5a86e1c8303e (patch)
treec1163267eb35cfcd7d2b1680f5e16f391848e9b1
parentb45207534f07eb7c813498681685467341d13336 (diff)
downloadports-3a7b17911b12b557fc9c450a975d5a86e1c8303e.tar.gz
ports-3a7b17911b12b557fc9c450a975d5a86e1c8303e.zip
Notes
-rw-r--r--biology/p5-bioperl/Makefile4
-rw-r--r--databases/p5-Class-DBI/Makefile4
-rw-r--r--devel/cvsmonitor/Makefile9
-rw-r--r--devel/p5-Data-TemporaryBag/Makefile7
-rw-r--r--devel/p5-File-Flat/Makefile11
-rw-r--r--devel/p5-File-Modified/Makefile7
-rw-r--r--devel/p5-Log-Dispatch-Config/Makefile9
-rw-r--r--devel/p5-PAR/Makefile6
-rw-r--r--devel/p5-PatchReader/Makefile6
-rw-r--r--devel/p5-Test-Reporter/Makefile7
-rw-r--r--devel/p5-VCP/Makefile4
-rw-r--r--graphics/netpbm/Makefile2
-rw-r--r--mail/mailscanner-devel/Makefile4
-rw-r--r--mail/mailscanner/Makefile4
-rw-r--r--mail/p5-Mail-GnuPG/Makefile4
-rw-r--r--misc/mc/Makefile2
-rw-r--r--net/rude/Makefile11
-rw-r--r--print/muttprint/Makefile4
-rw-r--r--textproc/p5-PerlPoint-Package/Makefile6
-rw-r--r--textproc/p5-XML-SAX/Makefile11
-rw-r--r--www/dtse/Makefile2
-rw-r--r--www/p5-Bundle-Sledge/Makefile4
-rw-r--r--www/p5-Template-Toolkit/Makefile6
-rw-r--r--www/p5-WWW-Mechanize/Makefile4
-rw-r--r--www/reportmagic/Makefile11
-rw-r--r--www/rt2/Makefile7
-rw-r--r--www/rt3/Makefile4
27 files changed, 110 insertions, 50 deletions
diff --git a/biology/p5-bioperl/Makefile b/biology/p5-bioperl/Makefile
index 74acd831820a..67893e19e8fd 100644
--- a/biology/p5-bioperl/Makefile
+++ b/biology/p5-bioperl/Makefile
@@ -20,7 +20,6 @@ COMMENT= A collection of Perl modules for bioinformatics
# prevents a flood of build-time warnings.
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Ace.pm:${PORTSDIR}/biology/p5-AcePerl \
${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy \
${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
@@ -610,9 +609,12 @@ MAN3= Bio::Align::AlignI.3 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500600
IGNORE= "This port requires Perl 5.6 or better"
.endif
+.endif
# now install all extra stuff (docs, examples, scripts, models)
post-install:
diff --git a/databases/p5-Class-DBI/Makefile b/databases/p5-Class-DBI/Makefile
index a06d30c5c322..c453d0c1b8f8 100644
--- a/databases/p5-Class-DBI/Makefile
+++ b/databases/p5-Class-DBI/Makefile
@@ -19,7 +19,6 @@ COMMENT= Simple Database Abstraction
BUILD_DEPENDS= ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable \
${SITE_PERL}/Ima/DBI.pm:${PORTSDIR}/databases/p5-Ima-DBI \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/UNIVERSAL/moniker.pm:${PORTSDIR}/devel/p5-UNIVERSAL-moniker \
${SITE_PERL}/${PERL_ARCH}/List/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils \
@@ -37,8 +36,11 @@ post-configure:
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/5.005-lib::Class::DBI.pm ${PATCHDIR}/5.005-Makefile.PL
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/cvsmonitor/Makefile b/devel/cvsmonitor/Makefile
index 9c2bf62d0088..7fd8156decbc 100644
--- a/devel/cvsmonitor/Makefile
+++ b/devel/cvsmonitor/Makefile
@@ -27,7 +27,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storab
${SITE_PERL}/Validate/Net.pm:${PORTSDIR}/net/p5-Validate-Net \
${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/Chart/Math/Axis.pm:${PORTSDIR}/math/p5-Chart-Math-Axis \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/File/Flat.pm:${PORTSDIR}/devel/p5-File-Flat \
${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
${SITE_PERL}/Time/ParseDate.pm:${PORTSDIR}/devel/p5-Time-modules \
@@ -84,4 +83,10 @@ do-install:
.endfor
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Data-TemporaryBag/Makefile b/devel/p5-Data-TemporaryBag/Makefile
index a9034d92e302..d089ce9d89aa 100644
--- a/devel/p5-Data-TemporaryBag/Makefile
+++ b/devel/p5-Data-TemporaryBag/Makefile
@@ -15,17 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Handle long size data using temporary file
-BUILD_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-RUN_DEPENDS= ${BUILD_DEPENDS}
-
PERL_CONFIGURE= yes
MAN3= Data::TemporaryBag.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500600
EXTRA_PATCHES= ${PATCHDIR}/500503-TemporaryBag.pm
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Flat/Makefile b/devel/p5-File-Flat/Makefile
index 95097369d108..e771df782223 100644
--- a/devel/p5-File-Flat/Makefile
+++ b/devel/p5-File-Flat/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Implements a flat filesystem
-BUILD_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
+BUILD_DEPENDS= ${SITE_PERL}/Class/Autouse.pm:${PORTSDIR}/devel/p5-Class-Autouse \
${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
${SITE_PERL}/File/Remove.pm:${PORTSDIR}/devel/p5-File-Remove \
${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp \
@@ -27,4 +26,10 @@ PERL_CONFIGURE= yes
MAN3= File::Flat.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-File-Modified/Makefile b/devel/p5-File-Modified/Makefile
index 2283ce7385ee..57a05de1fd23 100644
--- a/devel/p5-File-Modified/Makefile
+++ b/devel/p5-File-Modified/Makefile
@@ -14,8 +14,7 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for checking intelligently if files have changed
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1 \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -24,6 +23,10 @@ MAN3= File::Modified.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
post-patch:
${PERL} -pi -e 's/\r\n/\n/;' -e 's/^use warnings;//' ${WRKSRC}/Modified.pm
diff --git a/devel/p5-Log-Dispatch-Config/Makefile b/devel/p5-Log-Dispatch-Config/Makefile
index 18357f2a7a03..13f7a2b51cea 100644
--- a/devel/p5-Log-Dispatch-Config/Makefile
+++ b/devel/p5-Log-Dispatch-Config/Makefile
@@ -22,7 +22,6 @@ PM_DEPENDS= ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch
PM_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
PM_DEPENDS+= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
PM_DEPENDS+= ${SITE_PERL}/IO/Scalar.pm:${PORTSDIR}/devel/p5-IO-stringy
-PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
PERL_CONFIGURE= yes
@@ -30,4 +29,10 @@ PERL_CONFIGURE= yes
# Log::Dispatch::Configurator.3 \
# Log::Dispatch::Configurator::AppConfig.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-PAR/Makefile b/devel/p5-PAR/Makefile
index a4c9d77ee6df..56f69f798aea 100644
--- a/devel/p5-PAR/Makefile
+++ b/devel/p5-PAR/Makefile
@@ -18,7 +18,6 @@ COMMENT= Perl Archive Toolkit
BUILD_DEPENDS= ${SITE_PERL}/Archive/Zip.pm:${PORTSDIR}/archivers/p5-Archive-Zip \
${SITE_PERL}/${PERL_ARCH}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Module/ScanDeps/DataFeed.pm:${PORTSDIR}/devel/p5-Module-ScanDeps \
${SITE_PERL}/Module/Signature.pm:${PORTSDIR}/security/p5-Module-Signature \
${SITE_PERL}/PAR/Dist.pm:${PORTSDIR}/devel/p5-PAR-Dist \
@@ -36,7 +35,10 @@ MAN3= App::Packer::PAR.3 PAR.3 \
.include <bsd.port.pre.mk>
-pre-everything::
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
.if ${PERL_LEVEL} < 500601
IGNORE= p5-PAR only supports the ports versions of Perl.
IGNORE+=If you have installed a Perl port, and are getting this message,
diff --git a/devel/p5-PatchReader/Makefile b/devel/p5-PatchReader/Makefile
index c22a8318c766..d897b56a6f39 100644
--- a/devel/p5-PatchReader/Makefile
+++ b/devel/p5-PatchReader/Makefile
@@ -21,9 +21,9 @@ MAN3= PatchReader.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-RUN_DEPENDS= ${BUILD_DEPENDS}
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Test-Reporter/Makefile b/devel/p5-Test-Reporter/Makefile
index 022fe8979128..c033fd943f0d 100644
--- a/devel/p5-Test-Reporter/Makefile
+++ b/devel/p5-Test-Reporter/Makefile
@@ -25,9 +25,12 @@ MAN3= Test::Reporter.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.include <bsd.port.post.mk>
.if ${PERL_LEVEL} < 500601
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-VCP/Makefile b/devel/p5-VCP/Makefile
index f0ab2e03e6d1..c5ec080a12ef 100644
--- a/devel/p5-VCP/Makefile
+++ b/devel/p5-VCP/Makefile
@@ -21,7 +21,6 @@ BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/Parser.pm:${PORTSDIR}/textproc/p5-X
${SITE_PERL}/IPC/Run3.pm:${PORTSDIR}/devel/p5-IPC-Run3 \
${SITE_PERL}/Pod/Links.pm:${PORTSDIR}/www/p5-PodToHTML \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Regexp/Shellish.pm:${PORTSDIR}/devel/p5-Regexp-Shellish \
${SITE_PERL}/BFD.pm:${PORTSDIR}/devel/p5-BFD \
${SITE_PERL}/Text/Table.pm:${PORTSDIR}/textproc/p5-Text-Table \
@@ -104,8 +103,11 @@ MAN3= RevML::Doctype.3 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500600
BROKEN= "Does not compile with perl ${PERL_VERSION}"
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/netpbm/Makefile b/graphics/netpbm/Makefile
index d0a1ed937a76..83ccf7ca8fca 100644
--- a/graphics/netpbm/Makefile
+++ b/graphics/netpbm/Makefile
@@ -62,7 +62,7 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/doc/USERDOC ${DOCSDIR}/
.endif
-.if !defined(WITHOUT_PERL) && ${PERL_LEVEL} < 500601
+.if !defined(WITHOUT_PERL) && ${PERL_LEVEL} < 500800
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
diff --git a/mail/mailscanner-devel/Makefile b/mail/mailscanner-devel/Makefile
index d268fcd4799b..348c85835ba5 100644
--- a/mail/mailscanner-devel/Makefile
+++ b/mail/mailscanner-devel/Makefile
@@ -22,7 +22,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/Convert/BinHex.pm:${PORTSDIR}/converters/p5-Convert-BinHex \
${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
@@ -50,10 +49,13 @@ MLINKS= MailScanner.8 mailscanner.8 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
DOC_FILES= INSTALL INSTALL.FreeBSD INSTALL.OpenBSD README
ETC_FILES= MailScanner.conf filename.rules.conf \
diff --git a/mail/mailscanner/Makefile b/mail/mailscanner/Makefile
index e9e16c7a52d6..f5e8ff7639db 100644
--- a/mail/mailscanner/Makefile
+++ b/mail/mailscanner/Makefile
@@ -21,7 +21,6 @@ BUILD_DEPENDS= \
${SITE_PERL}/HTML/Tagset.pm:${PORTSDIR}/www/p5-HTML-Tagset \
${SITE_PERL}/${PERL_ARCH}/HTML/HeadParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
${SITE_PERL}/MIME/Parser.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Convert/TNEF.pm:${PORTSDIR}/converters/p5-Convert-TNEF \
${SITE_PERL}/Convert/BinHex.pm:${PORTSDIR}/converters/p5-Convert-BinHex \
${SITE_PERL}/Net/CIDR.pm:${PORTSDIR}/net-mgmt/p5-Net-CIDR \
@@ -49,10 +48,13 @@ MLINKS= MailScanner.8 mailscanner.8 \
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
DOC_FILES= INSTALL INSTALL.FreeBSD INSTALL.OpenBSD README
ETC_FILES= MailScanner.conf filename.rules.conf \
diff --git a/mail/p5-Mail-GnuPG/Makefile b/mail/p5-Mail-GnuPG/Makefile
index d621f136016a..68441b5d4152 100644
--- a/mail/p5-Mail-GnuPG/Makefile
+++ b/mail/p5-Mail-GnuPG/Makefile
@@ -18,7 +18,6 @@ COMMENT= Perl5 interface to process and/or create PGP email
BUILD_DEPENDS= ${SITE_PERL}/GnuPG/Interface.pm:${PORTSDIR}/security/p5-GnuPG-Interface \
${SITE_PERL}/MIME/Entity.pm:${PORTSDIR}/mail/p5-MIME-Tools \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Mail/Address.pm:${PORTSDIR}/mail/p5-Mail-Tools \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -29,8 +28,11 @@ MAN3= Mail::GnuPG.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index b5866886c9f9..1142b24455e9 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -62,7 +62,7 @@ LIB_DEPENDS+= slang.1:${PORTSDIR}/devel/libslang
CONFIGURE_ARGS+=--without-subshell
.endif
-.if ${PERL_LEVEL} < 500601
+.if ${PERL_LEVEL} < 500800
RUN_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
diff --git a/net/rude/Makefile b/net/rude/Makefile
index 25ec5d23bfb9..beaf698495c7 100644
--- a/net/rude/Makefile
+++ b/net/rude/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= Janos.Mohacsi@bsd.hu
COMMENT= Rude is a Real-time UDP Data Emitter and Collector (crude)
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Tk.pm:${PORTSDIR}/x11-toolkits/p5-Tk
HAS_CONFIGURE= yes
CONFIGURE_ENV= --with-debug-lvl=3
@@ -38,4 +37,10 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index eaeba8c3ba6b..a5342235999c 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -23,8 +23,7 @@ RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
uncompface:${PORTSDIR}/mail/faces \
convert:${PORTSDIR}/graphics/ImageMagick \
${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate \
- ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv
.if defined(WITH_CUPS)
RUN_DEPENDS+= cupstestppd:${PORTSDIR}/print/cups-lpr \
espgs:${PORTSDIR}/print/cups-pstoraster
@@ -33,6 +32,7 @@ RUN_DEPENDS+= cupstestppd:${PORTSDIR}/print/cups-lpr \
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
LIB_DEPENDS+= gnugetopt:${PORTSDIR}/devel/libgnugetopt
MAKE_ENV+= CCFLAGS="-I${PREFIX}/include"
PLIST_SUB+= LANGINFO=""
diff --git a/textproc/p5-PerlPoint-Package/Makefile b/textproc/p5-PerlPoint-Package/Makefile
index 0ffafc8ae658..5eeec7e2ad50 100644
--- a/textproc/p5-PerlPoint-Package/Makefile
+++ b/textproc/p5-PerlPoint-Package/Makefile
@@ -46,10 +46,10 @@ post-install:
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-.if ${PERL_LEVEL} < 500600
-BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec \
+BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable \
${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
.endif
diff --git a/textproc/p5-XML-SAX/Makefile b/textproc/p5-XML-SAX/Makefile
index 09a4b864cec1..bd57461e1a99 100644
--- a/textproc/p5-XML-SAX/Makefile
+++ b/textproc/p5-XML-SAX/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= skv@FreeBSD.org
COMMENT= Simple API for XML
-RUN_DEPENDS= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
- ${SITE_PERL}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
+RUN_DEPENDS= ${SITE_PERL}/XML/NamespaceSupport.pm:${PORTSDIR}/textproc/p5-XML-NamespaceSupport
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
@@ -33,4 +32,10 @@ post-configure:
@${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' \
${WRKSRC}/Makefile
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/dtse/Makefile b/www/dtse/Makefile
index af131a82a50d..d59e57a26206 100644
--- a/www/dtse/Makefile
+++ b/www/dtse/Makefile
@@ -36,7 +36,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USE_GCC= 3.3
.endif
-.if ${PERL_LEVEL} < 500600
+.if ${PERL_LEVEL} < 500800
BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
diff --git a/www/p5-Bundle-Sledge/Makefile b/www/p5-Bundle-Sledge/Makefile
index a054198ad35d..8949b4e4e0c7 100644
--- a/www/p5-Bundle-Sledge/Makefile
+++ b/www/p5-Bundle-Sledge/Makefile
@@ -29,7 +29,6 @@ PM_DEPENDS+= ${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleto
PM_DEPENDS+= ${SITE_PERL}/Class/Trigger.pm:${PORTSDIR}/devel/p5-Class-Trigger
PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
PM_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
-PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
PM_DEPENDS+= ${SITE_PERL}/HTML/FillInForm.pm:${PORTSDIR}/www/p5-HTML-FillInForm
PM_DEPENDS+= ${SITE_PERL}/HTML/Template.pm:${PORTSDIR}/www/p5-HTML-Template
PM_DEPENDS+= ${SITE_PERL}/HTML/StickyQuery.pm:${PORTSDIR}/www/p5-HTML-StickyQuery
@@ -51,9 +50,12 @@ MAN3= Bundle::Sledge.3
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+PM_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
PM_DEPENDS+= ${SITE_PERL}/CGI.pm:${PORTSDIR}/www/p5-CGI.pm
PM_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/www/p5-Template-Toolkit/Makefile b/www/p5-Template-Toolkit/Makefile
index 2fb270ad0132..b4fec66e74a6 100644
--- a/www/p5-Template-Toolkit/Makefile
+++ b/www/p5-Template-Toolkit/Makefile
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Extensive Toolkit for template processing
-BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+BUILD_DEPENDS= ${SITE_PERL}/AppConfig.pm:${PORTSDIR}/devel/p5-AppConfig
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -25,9 +24,12 @@ MASTER_SITE_BACKUP+= http://www.template-toolkit.org/download/
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec/Functions.pm:${PORTSDIR}/devel/p5-File-Spec
.endif
+.endif
.if defined(BATCH)
CONFIGURE_ENV= |
diff --git a/www/p5-WWW-Mechanize/Makefile b/www/p5-WWW-Mechanize/Makefile
index 90be75bd4322..fd1aebf50fbf 100644
--- a/www/p5-WWW-Mechanize/Makefile
+++ b/www/p5-WWW-Mechanize/Makefile
@@ -17,7 +17,6 @@ COMMENT= This module is to help you automate interaction with a website
BUILD_DEPENDS= ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
${SITE_PERL}/Pod/Usage.pm:${PORTSDIR}/textproc/p5-PodParser
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -31,6 +30,8 @@ MAN1= mech-dump.1
.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
@@ -41,5 +42,6 @@ post-patch:
-e '$$_="" if /use warnings/;' \
${WRKSRC}/lib/WWW/Mechanize.pm ${WRKSRC}/lib/WWW/Mechanize/Link.pm
.endif
+.endif
.include <bsd.port.post.mk>
diff --git a/www/reportmagic/Makefile b/www/reportmagic/Makefile
index 9ca9ea8c0e07..0e01fcba3569 100644
--- a/www/reportmagic/Makefile
+++ b/www/reportmagic/Makefile
@@ -20,8 +20,7 @@ COMMENT= A web site statistics post-processor for Analog
RUN_DEPENDS= analog:${PORTSDIR}/www/analog \
${SITE_PERL}/GD/Graph3d.pm:${PORTSDIR}/graphics/p5-GD-Graph3d \
${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-Parser \
- ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles
WRKSRC= ${WRKDIR}/${DISTNAME}
NO_BUILD= YES
@@ -36,4 +35,10 @@ post-install:
@${ECHO} "using Report Magic."
@${ECHO}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/rt2/Makefile b/www/rt2/Makefile
index 992cd56052dd..9501f344e8ad 100644
--- a/www/rt2/Makefile
+++ b/www/rt2/Makefile
@@ -38,8 +38,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libexec/apache/libperl.so:${PORTSDIR}/www/mod_perl \
${SITE_PERL}/Text/Template.pm:${PORTSDIR}/textproc/p5-Text-Template \
${SITE_PERL}/Text/Wrapper.pm:${PORTSDIR}/textproc/p5-Text-Wrapper \
${SITE_PERL}/Tie/IxHash.pm:${PORTSDIR}/devel/p5-Tie-IxHash \
- ${SITE_PERL}/CGI/Cookie.pm:${PORTSDIR}/www/p5-CGI.pm \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
+ ${SITE_PERL}/CGI/Cookie.pm:${PORTSDIR}/www/p5-CGI.pm
WRKSRC= ${WRKDIR}/rt-${RT_VERSION}
RT_VERSION= ${PORTVERSION:C/\./-/g}
@@ -155,9 +154,11 @@ post-install:
BROKEN= "Broken pkg-plist"
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} < 500601
BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
-RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
.endif
.include <bsd.port.post.mk>
diff --git a/www/rt3/Makefile b/www/rt3/Makefile
index 7ba0241f7fe7..061fb9117006 100644
--- a/www/rt3/Makefile
+++ b/www/rt3/Makefile
@@ -25,7 +25,6 @@ BUILD_DEPENDS+= ${APXS}:${PORTSDIR}/${APACHE_PORT} \
${SITE_PERL}/DBIx/SearchBuilder.pm:${PORTSDIR}/databases/p5-DBIx-SearchBuilder \
${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp \
${SITE_PERL}/FreezeThaw.pm:${PORTSDIR}/devel/p5-FreezeThaw \
${SITE_PERL}/Getopt/Long.pm:${PORTSDIR}/devel/p5-Getopt-Long \
${SITE_PERL}/${PERL_ARCH}/HTML/Entities.pm:${PORTSDIR}/www/p5-HTML-Parser \
@@ -148,9 +147,12 @@ post-install:
IGNORE= This program only support perl 5.6.1 or above
.endif
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.if ${PERL_LEVEL} == 500601
BUILD_DEPENDS+= ${SITE_PERL}/Encode/compat.pm:${PORTSDIR}/devel/p5-Encode-compat \
${SITE_PERL}/${PERL_ARCH}/Text/Iconv.pm:${PORTSDIR}/converters/p5-Text-Iconv
.endif
+.endif
.include <bsd.port.post.mk>