aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-01-15 17:16:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-01-15 17:16:55 +0000
commit3b981f7463ded7c7be13b873d3f850acf00d605d (patch)
tree1aa522739794c24066280715fdf1e40ce4af05d3
parent01cd106ee1e774d77bbbdb72a12bcbebf30be576 (diff)
downloadports-3b981f7463ded7c7be13b873d3f850acf00d605d.tar.gz
ports-3b981f7463ded7c7be13b873d3f850acf00d605d.zip
Notes
-rw-r--r--www/p5-Apache2-Scoreboard/Makefile26
-rw-r--r--www/p5-Apache2-Scoreboard/distinfo5
-rw-r--r--www/p5-Apache2-Scoreboard/files/patch-mp2-api40
-rw-r--r--www/p5-Apache2-Scoreboard/pkg-descr3
4 files changed, 28 insertions, 46 deletions
diff --git a/www/p5-Apache2-Scoreboard/Makefile b/www/p5-Apache2-Scoreboard/Makefile
index ef9f107e7a35..64f437e2e35d 100644
--- a/www/p5-Apache2-Scoreboard/Makefile
+++ b/www/p5-Apache2-Scoreboard/Makefile
@@ -6,29 +6,29 @@
#
PORTNAME= Apache2-Scoreboard
-PORTVERSION= 2.08
+PORTVERSION= 2.09.2
CATEGORIES= www perl5
-MASTER_SITES= CPAN
+MASTER_SITES= CPAN/../../authors/id/M/MJ/MJH
PKGNAMEPREFIX= p5-
-DISTNAME= Apache-Scoreboard-${PORTVERSION}
+DISTNAME= ${PORTNAME:C/2//}-${PORTVERSION}
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl interface to the Apache scoreboard structure
-BUILD_DEPENDS= ${LOCALBASE}/libexec/apache2/mod_perl.so:${PORTSDIR}/www/mod_perl2
+BUILD_DEPENDS= ${APACHE_PKGNAMEPREFIX}mod_perl2>=2.0.0:${PORTSDIR}/www/mod_perl2
RUN_DEPENDS= ${BUILD_DEPENDS}
-BROKEN= does not compile
+PERL_CONFIGURE= yes
+USE_APACHE= 2.0+
+USE_LDCONFIG= yes
+WRKSRC= ${WRKDIR}/${DISTNAME:R}
-PERL_CONFIGURE= 5.8.0+
-
-MAN3= Apache::Scoreboard.3 Apache::DummyScoreboard.3
-
-USE_LDCONFIG= YES
+MAN3= Apache::DummyScoreboard.3 Apache::Scoreboard.3
post-patch:
- @${RM} -f ${WRKSRC}/lib/Apache/*.orig
- ${SED} -i.bak 's@%%LOCALBASE%%@${LOCALBASE}@g' ${WRKSRC}/Makefile.PL
- ${SED} -i.bak 's@%%LOCALBASE%%@${LOCALBASE}@g' ${WRKSRC}/Dummy/Makefile.PL
+ @${REINPLACE_CMD} \
+ -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ -e 's|%%APACHEINCLUDEDIR%%|${APACHEINCLUDEDIR}|g' \
+ ${WRKSRC}/Makefile.PL ${WRKSRC}/Dummy/Makefile.PL
.include <bsd.port.mk>
diff --git a/www/p5-Apache2-Scoreboard/distinfo b/www/p5-Apache2-Scoreboard/distinfo
index 25cd9221814f..08fe844bc2de 100644
--- a/www/p5-Apache2-Scoreboard/distinfo
+++ b/www/p5-Apache2-Scoreboard/distinfo
@@ -1,3 +1,2 @@
-MD5 (Apache-Scoreboard-2.08.tar.gz) = f66b6e222cfc4b41c9b327af2478b44b
-SHA256 (Apache-Scoreboard-2.08.tar.gz) = c089aeb59d329ad1f9cbac2a631b1ee06e95c7dd31ae49a985e75642d798caba
-SIZE (Apache-Scoreboard-2.08.tar.gz) = 18572
+SHA256 (Apache-Scoreboard-2.09.2.tar.gz) = 671252a383aabc5c7906dd54e7dce92b65d944a56782f7233ca5a83c6299cc34
+SIZE (Apache-Scoreboard-2.09.2.tar.gz) = 18728
diff --git a/www/p5-Apache2-Scoreboard/files/patch-mp2-api b/www/p5-Apache2-Scoreboard/files/patch-mp2-api
index fae4e0c3fbe0..d4335c8de7bd 100644
--- a/www/p5-Apache2-Scoreboard/files/patch-mp2-api
+++ b/www/p5-Apache2-Scoreboard/files/patch-mp2-api
@@ -1,37 +1,21 @@
---- Makefile.PL.orig Mon Apr 17 17:08:56 2006
-+++ Makefile.PL Mon Apr 17 17:10:29 2006
-@@ -30,13 +30,18 @@
- Apache::TestMM::filter_args();
- Apache::TestMM::generate_script('t/TEST');
-
-+# XXX: this is a hack!
-+my $extra_inc = "-I%%LOCALBASE%%/include/apache2/modules/perl/";
-+
- ModPerl::MM::WriteMakefile(
- NAME => 'Apache::Scoreboard',
- VERSION_FROM => 'lib/Apache/Scoreboard.pm',
- PREREQ_PM => \%require,
+--- Makefile.PL.orig 2008-01-22 03:17:41.000000000 +0800
++++ Makefile.PL 2011-01-16 01:12:53.000000000 +0800
+@@ -45,7 +45,7 @@
clean => {
FILES => "@{ clean_files() }",
-- }
-+ },
-+ # XXX: this is a hack!
-+ INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC')
+ },
+- INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC'),
++ INC => join " ", "-I%%LOCALBASE%%/%%APACHEINCLUDEDIR%%/modules/perl/", $extra_inc, ModPerl::MM::get_def_opt('INC'),
);
sub clean_files {
---- Dummy/Makefile.PL.orig Mon Apr 17 17:12:37 2006
-+++ Dummy/Makefile.PL Mon Apr 17 17:13:12 2006
-@@ -18,7 +18,12 @@
-
- genxs();
-
-+# XXX: this is a hack!
-+my $extra_inc = "-I%%LOCALBASE%%/include/apache2/modules/perl/";
-+
+--- Dummy/Makefile.PL.orig 2008-01-22 03:17:31.000000000 +0800
++++ Dummy/Makefile.PL 2011-01-16 01:13:41.000000000 +0800
+@@ -29,6 +29,6 @@
ModPerl::MM::WriteMakefile(
NAME => 'Apache::DummyScoreboard',
VERSION_FROM => 'DummyScoreboard.pm',
-+ # XXX: this is a hack!
-+ INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC')
+- INC => join " ", $extra_inc, ModPerl::MM::get_def_opt('INC'),
++ INC => join " ", "-I%%LOCALBASE%%/%%APACHEINCLUDEDIR%%/modules/perl/", $extra_inc, ModPerl::MM::get_def_opt('INC'),
+
);
diff --git a/www/p5-Apache2-Scoreboard/pkg-descr b/www/p5-Apache2-Scoreboard/pkg-descr
index 635c50e5c60a..c147b5c80510 100644
--- a/www/p5-Apache2-Scoreboard/pkg-descr
+++ b/www/p5-Apache2-Scoreboard/pkg-descr
@@ -1,4 +1,3 @@
Perl interface to the Apache scoreboard structure
-- Trevor Cornpropst
-tcornpropst@cox.net
+WWW: http://search.cpan.org/dist/Apache-Scoreboard/