aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-05-02 12:42:02 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-05-02 12:42:02 +0000
commit41b77afd3d0d43d72dd4d977ea44d368ce22dc08 (patch)
treee8bc5941af9a7c4abfd6bbe52e187924714513ea
parent786c7a388f3473a1b1201d63c277089fe97facd2 (diff)
downloadports-41b77afd3d0d43d72dd4d977ea44d368ce22dc08.tar.gz
ports-41b77afd3d0d43d72dd4d977ea44d368ce22dc08.zip
Notes
-rw-r--r--audio/tomahawk/Makefile30
-rw-r--r--audio/tomahawk/distinfo4
-rw-r--r--audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake22
-rw-r--r--audio/tomahawk/files/patch-src__libtomahawk__Source.cpp4
-rw-r--r--audio/tomahawk/files/patch-src__main.cpp4
-rw-r--r--audio/tomahawk/pkg-plist2
6 files changed, 52 insertions, 14 deletions
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
index 927ff13a8589..33a7ce36a25b 100644
--- a/audio/tomahawk/Makefile
+++ b/audio/tomahawk/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= tomahawk
-PORTVERSION= 0.6.0
+PORTVERSION= 0.6.1
#PORTREVISION= 0
CATEGORIES= audio
@@ -21,24 +21,28 @@ LIB_DEPENDS= attica:${PORTSDIR}/x11-toolkits/attica \
qjson:${PORTSDIR}/devel/qjson \
quazip:${PORTSDIR}/archivers/quazip \
tag:${PORTSDIR}/audio/taglib
-RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc \
- phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer \
- qca-ossl>=2.0.0.b3_4:${PORTSDIR}/security/qca-ossl
+RUN_DEPENDS= qca-ossl>=2.0.0.b3_4:${PORTSDIR}/security/qca-ossl
CMAKE_ARGS+= -DCMAKE_BUILD_TYPE:STRING="Release" \
-DWITH_BREAKPAD:BOOL="OFF" \
- -DWITH_BUILD:STRING="Release"
+ -DWITH_BUILD:STRING="Release" \
+ -DCLUCENE_CONFIG_PATH:PATH="${LOCALBASE}/share/clucene"
GH_ACCOUNT= tomahawk-player
GH_PROJECT= ${PORTNAME}
GH_TAGNAME= ${DISTVERSION}
-GH_COMMIT= 2b8cc4f
+GH_COMMIT= ccb976a
INSTALLS_ICONS= yes
OPTIONS_DEFINE= QTWEETLIB
-OPTIONS_DEFAULT= QTWEETLIB
+OPTIONS_DEFAULT= GSTREAMER QTWEETLIB
+OPTIONS_RADIO= PHONON
+OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE
QTWEETLIB_DESC= Enable Twitter SIP plugin
+VLC_DESC= Multimedia support for VLC
+
+PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,}
USES= cmake pkgconfig
USE_GITHUB= yes
@@ -56,4 +60,16 @@ LIB_DEPENDS+= QTweetLib:${PORTSDIR}/net/qtweetlib
CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF"
.endif
+.if ${PORT_OPTIONS:MGSTREAMER}
+RUN_DEPENDS+= phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer
+.endif
+
+.if ${PORT_OPTIONS:MVLC}
+RUN_DEPENDS+= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc
+.endif
+
+.if ${PORT_OPTIONS:MXINE}
+RUN_DEPENDS+= phonon-xine>=4.4.4_5:${PORTSDIR}/multimedia/phonon-xine
+.endif
+
.include <bsd.port.mk>
diff --git a/audio/tomahawk/distinfo b/audio/tomahawk/distinfo
index 7f51ef1855ce..d6ca1979ad16 100644
--- a/audio/tomahawk/distinfo
+++ b/audio/tomahawk/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tomahawk-0.6.0.tar.gz) = 62a4921ba876f192a6c46e800a3e3f874da276a9815fcbcb8f24cbb020e44ae2
-SIZE (tomahawk-0.6.0.tar.gz) = 6470677
+SHA256 (tomahawk-0.6.1.tar.gz) = 587100b08e08507b96cc7d2fa165d7125037f0f9343715be4cfe5ece6ef87655
+SIZE (tomahawk-0.6.1.tar.gz) = 6432875
diff --git a/audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake b/audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake
new file mode 100644
index 000000000000..18e4b3a0f2dc
--- /dev/null
+++ b/audio/tomahawk/files/patch-CMakeModules__FindCLucene.cmake
@@ -0,0 +1,22 @@
+--- ./CMakeModules/FindCLucene.cmake.orig 2013-04-29 23:22:22.000000000 +0200
++++ ./CMakeModules/FindCLucene.cmake 2013-04-29 23:23:02.000000000 +0200
+@@ -85,14 +85,14 @@
+ SET(CLUCENE_GOOD_VERSION TRUE)
+
+ FIND_PATH(CLUCENE_LIBRARY_DIR
+- NAMES CLuceneConfig.cmake/CLuceneConfig.cmake CLucene/CLuceneConfig.cmake
+- PATHS ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} NO_DEFAULT_PATH)
++ NAMES CLuceneConfig.cmake CLucene/CLuceneConfig.cmake
++ PATHS ${TRIAL_LIBRARY_PATHS} ${TRIAL_INCLUDE_PATHS} ${CLUCENE_CONFIG_PATH} NO_DEFAULT_PATH)
+ IF (CLUCENE_LIBRARY_DIR)
+ MESSAGE(STATUS "Found CLucene library dir: ${CLUCENE_LIBRARY_DIR}")
+ # include CLuceneConfig/CLuceneConfig.cmake
+- IF(EXISTS ${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake/CLuceneConfig.cmake)
+- INCLUDE(${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake/CLuceneConfig.cmake)
+- ENDIF(EXISTS ${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake/CLuceneConfig.cmake)
++ IF(EXISTS ${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake)
++ INCLUDE(${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake)
++ ENDIF(EXISTS ${CLUCENE_LIBRARY_DIR}/CLuceneConfig.cmake)
+ # include CLucene/CLuceneConfig.cmake
+ IF(EXISTS ${CLUCENE_LIBRARY_DIR}/CLucene/CLuceneConfig.cmake)
+ INCLUDE(${CLUCENE_LIBRARY_DIR}/CLucene/CLuceneConfig.cmake)
diff --git a/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp b/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
index 86f18dc1512c..098ba3d6d6ef 100644
--- a/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
+++ b/audio/tomahawk/files/patch-src__libtomahawk__Source.cpp
@@ -1,5 +1,5 @@
---- ./src/libtomahawk/Source.cpp.orig 2013-02-13 21:31:17.000000000 +0100
-+++ ./src/libtomahawk/Source.cpp 2013-02-13 21:32:00.000000000 +0100
+--- ./src/libtomahawk/Source.cpp.orig 2013-03-24 10:41:13.000000000 +0100
++++ ./src/libtomahawk/Source.cpp 2013-04-29 22:46:47.000000000 +0200
@@ -148,7 +148,7 @@
m_avatar = new QPixmap( avatar );
m_fancyAvatar = 0;
diff --git a/audio/tomahawk/files/patch-src__main.cpp b/audio/tomahawk/files/patch-src__main.cpp
index 15132377717e..ac03be1230f3 100644
--- a/audio/tomahawk/files/patch-src__main.cpp
+++ b/audio/tomahawk/files/patch-src__main.cpp
@@ -1,5 +1,5 @@
---- ./src/main.cpp.orig 2013-02-13 21:57:24.000000000 +0100
-+++ ./src/main.cpp 2013-02-13 21:57:46.000000000 +0100
+--- ./src/main.cpp.orig 2013-03-24 10:41:13.000000000 +0100
++++ ./src/main.cpp 2013-04-29 22:46:47.000000000 +0200
@@ -34,8 +34,10 @@
#ifndef ENABLE_HEADLESS
diff --git a/audio/tomahawk/pkg-plist b/audio/tomahawk/pkg-plist
index f8b39ba8a7a8..9073f0f8120a 100644
--- a/audio/tomahawk/pkg-plist
+++ b/audio/tomahawk/pkg-plist
@@ -18,7 +18,7 @@ lib/libtomahawk_infoplugin_spotify.so
lib/libtomahawk_portfwd.so
lib/libtomahawklib.so
libexec/tomahawk_crash_reporter
-share/applications/tomahawk.desktop
+%%DESKTOPDIR%%/tomahawk.desktop
share/icons/hicolor/128x128-grayscale/apps/tomahawk.png
share/icons/hicolor/128x128/apps/tomahawk.png
share/icons/hicolor/16x16/apps/tomahawk.png